8K video was automatically transcoded to 1080p in NVENCC,it crashes in FFMPEG Version
#11
(01.06.2019, 13:04)Selur Wrote: Works fine here too.

Did you try it in Handbrake too? The FFMPEG NVENC of Handbrake ouputs a real 8K resolution file.
Reply
#12
No, I used Hybrid.
For my Hybrid doesn't resize to a lower resolution unless I tell it to. (Using Crop/Resize->Base->Resize->Picture Resize)
To say anything about the ffmpeg crash I would need a way to reproduce the issue or at least a debug output of the encoding,...
-> read the sticky and provide proper info if you want help
Reply
#13
(01.06.2019, 13:08)Selur Wrote: No, I used Hybrid.
For my Hybrid doesn't resize to a lower resolution unless I tell it to. (Using Crop/Resize->Base->Resize->Picture Resize)
To say anything about the ffmpeg crash I would need a way to reproduce the issue or at least a debug output of the encoding,...
-> read the sticky and provide proper info if you want help

I reinstalled Hybrid, and selected NVENCC HEVC basic settings without any modifications, the only modification was that I raised the kb/s from 1500 to 44000 kbit/s. Than  I  get error.
Reply
#14
And since you did not read the sticky and didn't provide any information for me to reproduce this I don't know how I could help.
as a side note: "HEVC encode with weightp is known to be unstable on some environments."

Tested on my current system:
ffmpeg -y -loglevel fatal -noautorotate -threads 8 -i "C:\Users\Selur\Desktop\paloma8kprores.mov" -map 0:0 -an -sn -vf zscale=rangein=tv:range=tv -pix_fmt yuv444p10le -strict -1 -vsync 0  -f yuv4mpegpipe - | NVEncC --y4m -i - --fps 24.000 --codec h265 --profile main444 --level auto --tier high --sar 1:1 --lookahead 32 --output-depth 10 --cbrhq 44000 --max-bitrate 240000 --aq --gop-len 600 --strict-gop --bframes 4 --ref 7 --weightp --mv-precision Q-pel --cu-max 32 --cu-min 8 --preset quality --colormatrix bt709 --cuda-schedule sync --output "E:\Temp\paloma8kprores_13_36_54_1210_02.265"
and got:
Max B frames are 0 frames.
HEVC encode with weightp is known to be unstable on some environments.
Consider not using weightp with HEVC encode if unstable.
Failed to cuMemAllocPitch, 2 (cudaErrorMemoryAllocation)
When using: (removed the cu-settings)
ffmpeg -y -loglevel fatal -noautorotate -threads 8 -i "C:\Users\Selur\Desktop\paloma8kprores.mov" -map 0:0 -an -sn -vf zscale=rangein=tv:range=tv -pix_fmt yuv444p10le -strict -1 -vsync 0  -f yuv4mpegpipe - | NVEncC --y4m -i - --fps 24.000 --codec h265 --profile main444 --level auto --tier high --sar 1:1 --lookahead 32 --output-depth 10 --cbrhq 44000 --max-bitrate 240000 --aq --gop-len 600 --strict-gop --bframes 4 --ref 7 --weightp --mv-precision Q-pel --preset quality --colormatrix bt709 --cuda-schedule sync --output "E:\Temp\paloma8kprores_13_36_54_1210_02.265""
I get:
y4m: failed to parse y4m header.
Failed to open input file.

-> seems like NVEncC has a problem with yuv444p10le input (opened an issue entry for Rigaya: https://github.com/rigaya/NVEnc/issues/127)

using:
ffmpeg -y -loglevel fatal -noautorotate -threads 8 -i "C:\Users\Selur\Desktop\paloma8kprores.mov" -map 0:0 -an -sn -vf zscale=rangein=tv:range=tv -pix_fmt yuv444p10le -strict -1 -vsync 0  -f yuv4mpegpipe - | NVEncC --y4m -i - --fps 24.000 --codec h265 --sar 1:1 --output-depth 10 --cbrhq 44000 --max-bitrate 240000 --colormatrix bt709  --output "E:\Temp\paloma8kprores_13_36_54_1210_02.265"
encoding seem to start,..
Reply
#15
(01.06.2019, 13:43)Selur Wrote: And since you did not read the sticky and didn't provide any information for me to reproduce this I don't know how I could help.
as a side note: "HEVC encode with weightp is known to be unstable on some environments."

Tested on my current system:
ffmpeg -y -loglevel fatal -noautorotate -threads 8 -i "C:\Users\Selur\Desktop\paloma8kprores.mov" -map 0:0 -an -sn -vf zscale=rangein=tv:range=tv -pix_fmt yuv444p10le -strict -1 -vsync 0  -f yuv4mpegpipe - | NVEncC --y4m -i - --fps 24.000 --codec h265 --profile main444 --level auto --tier high --sar 1:1 --lookahead 32 --output-depth 10 --cbrhq 44000 --max-bitrate 240000 --aq --gop-len 600 --strict-gop --bframes 4 --ref 7 --weightp --mv-precision Q-pel --cu-max 32 --cu-min 8 --preset quality --colormatrix bt709 --cuda-schedule sync --output "E:\Temp\paloma8kprores_13_36_54_1210_02.265"
and got:
Max B frames are 0 frames.
HEVC encode with weightp is known to be unstable on some environments.
Consider not using weightp with HEVC encode if unstable.
Failed to cuMemAllocPitch, 2 (cudaErrorMemoryAllocation)
When using: (removed the cu-settings)
ffmpeg -y -loglevel fatal -noautorotate -threads 8 -i "C:\Users\Selur\Desktop\paloma8kprores.mov" -map 0:0 -an -sn -vf zscale=rangein=tv:range=tv -pix_fmt yuv444p10le -strict -1 -vsync 0  -f yuv4mpegpipe - | NVEncC --y4m -i - --fps 24.000 --codec h265 --profile main444 --level auto --tier high --sar 1:1 --lookahead 32 --output-depth 10 --cbrhq 44000 --max-bitrate 240000 --aq --gop-len 600 --strict-gop --bframes 4 --ref 7 --weightp --mv-precision Q-pel --preset quality --colormatrix bt709 --cuda-schedule sync --output "E:\Temp\paloma8kprores_13_36_54_1210_02.265""
I get:
y4m: failed to parse y4m header.
Failed to open input file.

-> seems like NVEncC has a problem with yuv444p10le input (opened an issue entry for Rigaya: https://github.com/rigaya/NVEnc/issues/127)

Now I used factory settings, and error.

NVEnc --y4m -i - --fps 59.940 --codec h264 --profile high --level auto --sar 1:1 --lookahead 16 --cbrhq 44000 --max-bitrate 17500 --gop-len 0 --bframes 3 --ref 3 --mv-precision Q-pel --cabac --deblock --preset default --colormatrix bt709 --cuda-schedule sync --keyfile GENERATED_KEY_FILE --output "C:\Users\Stears\AppData\Local\Temp\aki.264"
Reply
#16
That command line doesn't help me at all.
Have you read the sticky, like I asked you to?!?
My guess atm. is that your card runs out of memory.
Reply
#17
(01.06.2019, 14:00)Selur Wrote: That command line doesn't help me at all.
Have you read the sticky, like I asked you to?!?

What can help you exactly?
Reply
#18
Like I asked you multiple times: Read the sticky.
If you are unclear about what that means, it means you should read the '[INFO] Infos needed to fix&reproduce bugs,..'-sticky.
It contains the information I need to reproduce/analyse an issue.

Cu Selur

Ps.: As a side note, I hope you have 16GB+ system RAM and a graphic card with lots of RAM otherwise 8K encoding will fail due to memory limits,.. (Using for example x264 encoding 8k footage take ~23GB of system RAM on my system,..)
PPs.: Just checked my card during with the last call I posted. I shows memory usage of ~8GB, so your card probably needs more to be able to do 444 with 8k
Reply
#19
See https://github.com/rigaya/NVEnc/issues/127 for further updates.
Atm. it looks like at least the 8GB of my Geforce GTX 1070 Ti are not enough to handle 10bit 4:4:4 HEVC encoding with 4k or 8k. (4:2:0 works fine, when lowering the lookahead)
-> for the time being I won't change anything in Hybrid in this regard

Cu Selur
Reply
#20
(01.06.2019, 15:52)Selur Wrote: See https://github.com/rigaya/NVEnc/issues/127 for further updates.
Atm. it looks like at least the 8GB of my Geforce GTX 1070 Ti are not enough to handle 10bit 4:4:4 HEVC encoding with 4k or 8k. (4:2:0 works fine, when lowering the lookahead)
-> for the time being I won't change anything in Hybrid in this regard

Cu Selur

Hi!

Did you try it with NVENCC HW decoder?

Don't forget: The 8K 30fps transcoding is an advertized basic feature of Turing cards. Maybe nobody use the so-called "in video memory" transcoding funcion yet, because it is an SDK9 feature for Turing cards. Maybe it workd with that. It must work, because otherwise that would be cheater marketing trick. Satelit and TV proivider companies have big bulky special industrial HW encoders, with laughable meemory size , despite of that they can encode a lot of TV channles at the same time.

Just watch them: https://www.google.com/search?client=fir...26SugE4M-I
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)