This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

A cookie will be stored in your browser regardless of choice to prevent you being asked this question again. You will be able to change your cookie settings at any time using the link in the footer.

[BUG] Audio sync problem
#1
  • What Hybrid version did you use?(Windows 10 64 bit, Hybrid version is 2021.04.12.1)

  • What did happen? If an error message came up what did it exactly say? - No get error message, audio out of sync

  • What did you do to get to the bug?

Input video is:
- MPEG2, interlaced, top field first
- original size is 720x576 with 4:3 DAR (real is 16:9)
- audio: MP2

Target:
- I encode with NVENC to x264
- image resized to 720x576, input PAR: 64x45
- I use many filters with Vapoursynth

I have audio and tried these steps:
- passtrough all
- add first and encode to acc or ac3
- tried decode and demux with ffmpeg and used many options, but no helped, sound will out of sync. On audio tab see a preview, and there was synced.

Attached debug file.


Attached Files
.zip   HybridDebugOutput.zip (Size: 23,41 KB / Downloads: 10)
Reply
#2
Quote:On audio tab see a preview, and there was synced.
That preview is meant to be able to listen to the original audio to know the language&co even when the streams are not flagged.
It has nothing to do with the processed output

Looking at the debug output, the Vapoursynth script contains:
....
# cutting from frame 22500 to 24000  - WARNING: This might cause synch issues
clip = core.std.Trim(clip=clip, first=22500, last=24000)
...
audio is cut using:
ffmpeg -y -ss 00:14:00.000 -threads 8 -i "F:\Be\!UPCBox\Torz\Broadway Szilveszter 2009 - 1.mpg" -map 0:1 -vn -sn -ss 00:01:00.000 -t 00:01:00.000 -acodec copy -map_metadata -1 -metadata encoding_tool="Hybrid 2021.04.12.1" "F:\Vidtemp\iId_6_aid_0_2021-05-11@19_08_12_9910_01.mp2"
Audio extraction&cutting doesn't show any errors and the audio length is reported as time=00:00:59.97.
NVEncC reports it encoded 1501 frames, which would be correct (+/- 1 frame can happen due to lots of reasons).

I can fix the problem that Vapoursynth produces one frame too much, but that probably won't fix the sync issue and I don't see a way to fix it.
(such strange things is why 'Cut Support' is *experimental*)

I'll create a dev version which will lower the 'last' frame in the Trim call by one and send you a link, but like I wrote I don't think this will fix the issue.

Cu Selur

Ps.: send link via pm.
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)