This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

A cookie will be stored in your browser regardless of choice to prevent you being asked this question again. You will be able to change your cookie settings at any time using the link in the footer.

[BUG] Vapoursynth stopped working in latest dev build (crashes)
#1
Bug 
Using Hybrid 2021.05.25.1.

The Vapoursynth previewer and output crashes. Any file type.

"Indexer crashed"

No problems in 2021.04.15.1.


Log files:


2021.04.15.1 (no crash in vsViewer or output):

.zip   HybridDebugOutput_20210415.zip (Size: 49,61 KB / Downloads: 5)


2021.05.25.1 (crash in vsViewer and output):

.zip   HybridDebugOutput_20210525.zip (Size: 67,23 KB / Downloads: 9)
Reply
#2
2021.04.15.1 (no crash in vsViewer or output):
-> don't care

HybridDebugOutput_20210525
-> seems like DGDecNV has a problem with your buggy source file.
As a workaround you could do the following:
a. replace the DGDecode.dll and DGIndex.exe in Hybrid\64bit\vsfilters\SourceFilter\d2vSource with the 64bit version you linked to.
b. disable DGDecNV (Filtering->Vapoursynth->Source->Use DGDecNV when available)
c. report the issue to DG

Since I have no problem indexing the source DGDecNV (DGDecNV&DGIndex 2053.0.0.228), it might be an issue with your NVIDIA drivers.
Deinstalling them completely and making a clean reinstall might help.

Cu Selur
Reply
#3
I'm on a GPU-less machine. No Nvidia drivers. Perhaps that's the issue.

Replaced DGDecode.dll with version 2.0.0.5 in C:\Program Files\Hybrid\64bit\vsfilters\SourceFilter\d2vSource.

Cleared "Use DGDecNV when available" check box under Filtering -> Vapoursynth -> Misc -> Source. (It is now enabled by default; in Hybrid 2020.04.15.1 is was not.)

Output now works.

However, the Vapoursynth previewer still crashes.

It's not my buggy source file, it happens on any file, including an mp4 file encoded with Hybrid.

I saved the VapourSynth script file as .vpy.

I ran the Vapoursynth previewer directly and opened the vpy file. I received a log message, "Failed to initialize Vapoursynth."

After some troubleshooting, I got vsviewer.exe to produce this error message:

[Image: tCn3EEr.png]

In Hybrid version 2021.05.25, Python has been updated to version 3.9. This version of Python is Windows 10 only:

https://bugs.python.org/issue40740
https://github.com/vapoursynth/vapoursynth/issues/677

I tried to see if it was possible to roll Python back to version 3.8 for Hybrid version 2021.05.25, but was unsuccessful.

I guess that's the end of Vapoursynth previewer on Windows 7, and probably Vapoursynth as well because I didn't test it extensively with other filters and such.

I suppose Windows 7 could only last so long!
Reply
#4
Quote:Cleared "Use DGDecNV when available" check box under Filtering -> Vapoursynth -> Misc -> Source. (It is now enabled by default; in Hybrid 2020.04.15.1 is was not.)
Yes, I'm experimenting with it. Smile

Quote:I got vsviewer.exe to produce this error message:
that indicates you are missing a c++ runtime libary. (which probably comes by default with Windows 10)
api-ms-win-crt-runtime-l1-1-0 is from the 'Visual C++ Redistributable for Visual Studio 2015'
https://www.microsoft.com/en-us/download...x?id=48145
Strange thing is that vsViewer was compiled with VS2019.

---
Totally missed that you are using Windows 7.
"2020.12.13.1" was the last build which supported Windows 7, all newer build are compiled with Qt6
see: https://forum.selur.net/Thread-Windows-7...0xc0000005

Cu Selur
Reply
#5
That missing dll is a Windows 10 thing. You can't just copy it onto a Windows 7 machine, it won't work. Big Grin (I think you have the wrong dll... it's api-ms-win-core-path-l1-1-0.dll. Wink)

Even though it's not supported, Hybrid still works on Windows 7 pretty well (up until version 2020.04.15 at least for Vapoursynth), but of course I haven't tried every filter and such. It appears even the latest 2020.05.25 still works for AviSynth. Wink
Reply
#6
Strange. If it's just vsViewer that isn't working and vspipe is you could copy vsViewer from an older version.

Cu Selur
Reply
#7
I tried that. Same problem.  Tongue

I tried loading vsViewer.exe into x64dbg. The "Failed to initialize Vapoursynth" error happens when I either "check" or "preview" the script in vsViewer. When this error comes up, the x64dbg log shows it's trying to load python39.dll. (Doesn't matter what version of vsViewer is used.)

I only tested straight output, I didn't enable any filters... I suspect that anything that needs python39.dll won't work on Windows 7. (I'm guessing straight input -> output via Vapoursynth with no filters doesn't need python39.dll.)

The Python version and dll's are built into Vapoursynth itself, so a whole build (or previous version) of Vapoursynth that uses python38.dll would be needed to make it work in Windows 7. Tongue 

I have a Windows 10 machine... it works fine there, as expected. Smile

But I still prefer Windows 7 machine as the main one. I just can't get used to Windows 10's interface. (Not to mention all the bloatware and spyware that has to be disabled.) I'm using all classic themes and mods, and the start bar that is closest to classic is SimpleClassicThemeTaskbar, and while it's workable, it's full of bugs and I'm not sure how future work on it will progress. (The current "Development build" doesn't work at all.)

(It turns out the Windows Classic Theme is still present in Windows 10 and it can be enabled with a PowerShell script, or the SimpleClassicTheme front end.)

But Windows 7 is still way more stable for classic Windows. It just can't run a lot of the latest builds of things that reply on files that can only run on a Windows 10 kernel. (Like Python 3.9 Tongue )
Reply
#8
Have you tried simply replacing the whole Hybrid/64bit/Vapoursynth-folder with one from an older version of Hybrid? (vsViewer could be taken from the latest build)

Cu Selur
Reply
#9
Thumbs Up 
I renamed the VapourSynth folder and copied the one from 2020.04.15 over, and that seems to work pretty good so far!

I had figured that would just break Hybrid completely. Smile
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)