Double of 30000/1001 fps is 59940/1000 fps?
Hi. I use version 2017.12.23.1 32-bit
Trying to convert interlaced video to progressive one with double framerate.
Interlaced video is 30000/1001 fps. Am I right that double fps should be 2*(30000/1001) = 60000/1001?
But Hybrid inserts --fps 59940/1000.
60000/1001 = 59.94005994005994... and 59940/1000 = 59.94, so it's not the same. Is it a bug?

How can I set output fps to 60000/1001? And is there any way to edit CLI by myself? I mean to change those commands (--fps, --bframes, etc) by myself like in text editor.

Btw, if i set deinterlacing with normal framerate, then Hybrid inserts --fps 30000/1001 So Hybryd also detects the source video as 30000/1001 fps
Probably a rounding error somewhere.
Will look into it. 59.94 should be automatically changed to 60000/1001.
Depending in the encoder you use you can add a commander line addition and thus over-shadow settings.
Note that I stopped development for 32bit so you will not see this fixed in a nee release unless you switch to 64bit.

Cu Selur
Found some time to look at it and found the problem will be fixed in the next release (64bit) which is planned for tomorrow. Smile

Cu Selur

Forum Jump:

Users browsing this thread: 1 Guest(s)