This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

A cookie will be stored in your browser regardless of choice to prevent you being asked this question again. You will be able to change your cookie settings at any time using the link in the footer.

[GUIDE] Ubuntu repository - maintained by djcj
Something is 'off' with the vapoursynth build.
/home/selur/opt/hybrid/ "/home/selur/opt/hybrid/vsViewer" --preview-only "/home/selur/Schreibtisch/HybridTemp/tempPreviewVapoursynthFile21_14_18_848.vpy" --aspect 1 --matrix Rec601
# Imports
import vapoursynth as vs
core = vs.get_core()
# Loading source using FFMS2
clip = core.ffms2.Source(source="/home/selur/Schreibtisch/test.avi",cachefile="/home/selur/Schreibtisch/HybridTemp/avi_77c74b7b15937c7267959c738c5ee2fa_936145377.ffindex",format=vs.YUV420P8,alpha=False)
# making sure input color matrix is set as 470bg
clip = core.resize.Point(clip, matrix_in_s="470bg",range_s="limited")
# making sure frame rate is set to 25/1
clip = core.std.AssumeFPS(clip, fpsnum=25, fpsden=1)
# Setting color range to TV (limited) range.
clip = core.std.SetFrameProp(clip=clip, prop="_ColorRange", intval=1)
# Output
in the vapoursynth script, results in:
VapourSynth plugins manager: Failed to get VapourSynth API!
Failed to initialize VapourSynth
first time I see: 'Failed to get VapourSynth API'

Cu Selur
I don't know. I guess the vapoursynth Python module isn't loaded somehow.
I built it on Ubuntu 16.04, tested it with "vspipe --version" on Ubuntu 18.04 and didn't get the "Failed to get ..." error.
Check the content of and vapoursynth.conf.

Edit: to clarify, I ran on Ubuntu 16.04 and on Ubuntu 18.04.
I ran on Ubuntu 16.04 and on Ubuntu 19.04.
Calling vspipe on it's own without calling the gives me:
selur@selur-VirtualBox:~/opt/vapoursynth$ ./vspipe --version
Failed to initialize VapourSynth environment
selur@selur-VirtualBox:~/opt/vapoursynth$ ~/opt/hybrid/ ~/opt/vapoursynth/vspipe --version
sourcing /home/selur/opt/vapoursynth/
Failed to initialize VapourSynth environment
with the env, where contains:
scriptDir="$(dirname "$(readlink -f "$0")")"

if [ -f "$env" ]; then
  echo "sourcing $env"
  . "$env"
  echo "'$env' does not exist!"
home/selur/opt/vapoursynth/ contains:
# source this file with
# . "/home/selur/opt/vapoursynth/"
export LD_LIBRARY_PATH="/home/selur/opt/vapoursynth/lib:$LD_LIBRARY_PATH"
export PYTHONPATH="/home/selur/opt/vapoursynth/lib/python3/site-packages:$PYTHONPATH"

/home/selur/.config/vapoursynth/vapoursynth.conf contains:

Cu Selur

Ps.: a new DTTTest version is out which uses arrays instead of the strings. Smile
Does it work if you open a terminal and manually set all the paths and run vspipe?
selur@selur-VirtualBox:~$ export LD_LIBRARY_PATH="/home/selur/opt/vapoursynth/lib:$LD_LIBRARY_PATH"
selur@selur-VirtualBox:~$ export PYTHONPATH="/home/selur/opt/vapoursynth/lib/python3/site-packages:$PYTHONPATH"
selur@selur-VirtualBox:~$ ~/opt/vapoursynth/vspipe --version
Failed to initialize VapourSynth environment
sicne the previous variant, where vapoursynth was build on the system worked, my guess is that something if 'off' with the vapoursynth building,..
I'll set up Ubuntu 19.04 and test it.
Did you find the cause of the problem?
May be compiling the plugins with Hybrid and just compiling and installing Vapoursynth on the guest system is the more workable way to go.

Cu Selur
(17.08.2019, 09:40)Selur Wrote: Did you find the cause of the problem?
May be compiling the plugins with Hybrid and just compiling and installing Vapoursynth on the guest system is the more workable way to go.

Cu Selur

Haven't done anything yet besides installing Ubuntu 19.04 in Virtualbox, sorry. The problem could be related to a not-so-obvious dependency issue or a configuration thing. Yeah, I guess compiling on the guest system may be better, even though that can take a while if you want to include all plugins plus you still have to build imagemagick and ffmpeg libraries. I mean, you could try to bundle python but that's probably overkill. On the plus side, compiling on the guest system allows to build with "-march=native" which may give some minor speed improvements later.
So, if you don't find the dependency issue let's go back to adding a build-vs-plugins and build-vapoursynth which compile vapoursynth and the plugins and place them under ~/opt/vapoursynth.

Cu Selur
vsViewer and vsEdit both have problems with the new R47 API, seems like some problem with the getVSApi functionality and stuff marked deprecated that doesn't work anymore,..
-> looking into it

Forum Jump:

Users browsing this thread: 1 Guest(s)