[HELP] Hybrid freezes at loading
#1
Hello,



I'm with v2019.05.05 (cf previous post)



and Hybrid freezes when loading a "big" mkv file containing 51 chapters.

sometimes it succeeds in loading it - but rarely (and I didn't succeed in loading it with the log activated), and then Hybrid freezes when I press 'Base->Queue chapters'



Here is a level 5 log with original chapters



--> I had the opportunity to see that there were 3 "chapters" beginning with 000:00:00 which seemed strange, but even if I deleted them, Hybrid froze when pressing 'Base->Queue chapters'



So i created a new file without these 3 chapters, loaded it with success

when pressing 'Base->Queue chapters', Hybrid is ok
But when pressing "start jobs", only 1 job is finished and there is no output in the outpout folder

here is the level 5 log with modified chapters


regards
Reply
#2
Hmm,...
Chapters reported by Mediainfo:
00:00:00.000                             : Chapter 1
00:06:53.046                             : Chapter 2
00:13:17.397                             : Chapter 3
00:20:17.083                             : Chapter 4
00:26:31.356                             : Chapter 5
00:32:50.902                             : Chapter 6
00:39:11.716                             : Chapter 7
00:45:21.619                             : Chapter 8
00:52:03.754                             : Chapter 9
00:58:19.930                             : Chapter 10
01:04:35.638                             : Chapter 11
01:10:24.287                             : Chapter 12
01:16:24.947                             : Chapter 13
01:22:40.289                             : Chapter 14
01:28:41.416                             : Chapter 15
01:35:07.035                             : Chapter 16
01:41:07.461                             : Chapter 17
01:47:31.045                             : Chapter 18
01:53:55.128                             : Chapter 19
02:00:17.744                             : Chapter 20
02:06:25.778                             : Chapter 21
02:12:39.585                             : Chapter 22
02:18:45.951                             : Chapter 23
02:24:43.475                             : Chapter 24
02:30:50.842                             : Chapter 25
02:36:59.510                             : Chapter 26
02:43:00.004                             : Chapter 27
02:49:11.541                             : Chapter 28
02:55:12.469                             : Chapter 29
03:01:25.408                             : Chapter 30
03:07:28.037                             : Chapter 31
03:13:38.774                             : Chapter 32
03:19:43.305                             : Chapter 33
03:25:55.643                             : Chapter 34
03:32:06.514                             : Chapter 35
03:38:20.588                             : Chapter 36
03:38:20.788                             : Chapter 37
03:44:34.461                             : Chapter 38
03:50:45.932                             : Chapter 39
03:56:47.360                             : Chapter 40
04:03:04.437                             : Chapter 41
04:09:08.066                             : Chapter 42
04:15:13.265                             : Chapter 43
04:21:28.273                             : Chapter 44
04:27:34.839                             : Chapter 45
04:27:35.406                             : Chapter 46
04:33:34.865                             : Chapter 47
04:39:46.703                             : Chapter 48
04:45:51.167                             : Chapter 49
04:51:58.534                             : Chapter 50
04:58:09.305                             : Chapter 51
but the chapters imported by Hybrid looks wrong:
Setting Chapters to '00:00:00.000 :*: Chapter 1 ### 00:06:53.046 :*: Chapter 2 ### 00:13:17.397 :*: Chapter 3 ### 00:20:17.083 :*: Chapter 4 ### 00:26:31.356 :*: Chapter 5 ### 00:32:50.902 :*: Chapter 6 ### 00:39:11.716 :*: Chapter 7 ### 00:45:21.619 :*: Chapter 8 ### 00:52:03.754 :*: Chapter 9 ### 00:58:19.930 :*: Chapter 10 ### 01:04:35.638 :*: Chapter 11 ### 01:10:24.287 :*: Chapter 12 ### 01:16:24.947 :*: Chapter 13 ### 01:22:40.289 :*: Chapter 14 ### 01:28:41.416 :*: Chapter 15 ### 01:35:07.035 :*: Chapter 16 ### 01:41:07.461 :*: Chapter 17 ### 01:47:31.045 :*: Chapter 18 ### 01:53:55.128 :*: Chapter 19 ### 02:00:17.744 :*: Chapter 20 ### 02:06:25.778 :*: Chapter 21 ### 02:12:39.585 :*: Chapter 22 ### 02:18:45.951 :*: Chapter 23 ### 02:24:43.475 :*: Chapter 24 ### 02:30:50.842 :*: Chapter 25 ### 02:36:59.510 :*: Chapter 26 ### 02:43:00.004 :*: Chapter 27 ### 02:49:11.541 :*: Chapter 28 ### 02:55:12.469 :*: Chapter 29 ### 03:01:25.408 :*: Chapter 30 ### 03:07:28.037 :*: Chapter 31 ### 03:13:38.774 :*: Chapter 32 ### 03:19:43.305 :*: Chapter 33 ### 03:25:55.643 :*: Chapter 34 ### 03:32:06.514 :*: Chapter 35 ### 03:38:20.588 :*: Chapter 36 ### 03:38:20.788 :*: Chapter 37 ### 03:44:34.461 :*: Chapter 38 ### 03:50:45.932 :*: Chapter 39 ### 03:56:47.360 :*: Chapter 40 ### 04:03:04.437 :*: Chapter 41 ### 04:09:08.066 :*: Chapter 42 ### 04:15:13.265 :*: Chapter 43 ### 04:21:28.273 :*: Chapter 44 ### 04:27:34.839 :*: Chapter 45 ### 04:27:35.406 :*: Chapter 46 ### 04:33:34.865 :*: Chapter 47 ### 04:39:46.703 :*: Chapter 48 ### 04:45:51.167 :*: Chapter 49 ### 04:51:58.534 :*: Chapter 50 ### 04:58:09.305 :*: Chapter 51 ### Encoded date :*: 45:30 ### Menu For :*: 1,2 ### Tagged date :*: 45:30'
the last three entries shouldn't be there,...
-> I'll look at the code, but not sure whether I can reproduce this
(I hope this freezing not only happens if you have the debug output enabled,..)

Cu Selur

Ps.: Personally I would try how Hybrid behaves with 'Ignore input time codes enabled'.
PPs.: Side note: if you created these files: Why did you create vfr files out of cfr content? (doesn't make any sense to me)
Reply
#3
Send you a link to a dev version, which should fix the chapter parsing, but the problem is probably not the chapters, but the length and the time codes.
5hrs+ video with 500k time codes which Hybrid will look at one after the other.
Since the time codes only seem to be really vfr in a handful of places I suspect throwing out the time codes would be a good idea.

Cu Selur
Reply
#4
Hi,

I was out for the afternoon, sorry...

no i didn't create this file...

I'm downloading the dev version & will try with 'Ignore input time codes enabled'.

Q : will this dev version fix both issues (install pb + chapter pb) ?
if not, which one will it fix please ?
Reply
#5
Quote:Q : will this dev version fix both issues (install pb + chapter pb) ?
the nvidia messages should not appear and chapters should be parsed properly.
Analysing you source with time code handling enabled will still take a long time.
Reply
#6
ok

Hybrid is starting (takes a much longer longer time than before)

NOTA : When I had the messages & clicked on "OK", then hybrid always crashed...

Hybrid is started ! Smile

About the time codes :
the option is 'Config > Internals > Handling > Ignore all input time codes' ?

do i have to use as input the video file with the modified chapters or it doesn't matter ?
Reply
#7
Aside from that the first launch of a new Hybrid version always takes longer since the tools infos get collected I have no clue why the version I send you should be slower at start up. (Nothing was changed for the startup,...)
Reply
#8
About the time codes :
the option is 'Config > Internals > Handling > Ignore all input time codes' ?

do i have to use as input the video file with the modified chapters or it doesn't matter ?
Reply
#9
Quote: 'Config > Internals > Handling > Ignore all input time codes'
Needs to be enabled before loading a source, otherwise it will not have any effect on the loading of the source,...
It has no influence on the parsing of the chapters.
Reply
#10
- starting Hybrid : ok
- loading : ok
- queuing : ok
- starting the jobs to split the file : seems ok !!! Hybrids already created 3 files !!!

Smile Smile Smile

Hi again,

does this means that i should always enable this option ?
or first let it disabled, & if it crashes like today, enable it ?

regards
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)