This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

A cookie will be stored in your browser regardless of choice to prevent you being asked this question again. You will be able to change your cookie settings at any time using the link in the footer.

[HELP] Problem using Prores
I am trying to convert a VOB file to Prores and am getting an error from Hybrid.  I am curious if I am missing a .dll somewhere for Hybrid that I don't have in a proper directory.   I even have tried converting .264 files to Prores and still get an error.

1.  I am using Windows 10 and Hybrid v 2021.01.31.1.
2.  Set audio for auto add and set the output for 24bit wav
3.  Set proper paths for rendered files
4.  Import VOB file and set container to .mov.  File is an interlaced 16:9 video at 29.97
5.  Left Prores settings at 4:2:2; all else default.
6.  Set Avisynth to deinterlace at "fast" with all other 
7.  I didn't do any other filtering or resizing.
8.  Add to queue and start job.

It aborts.

Any advice would be appreciated.  There is nothing wrong with the original video file as I can create a Prores using Virtual Dub from the same media.

Please, read the 'Infos needed to fix&reproduce bugs,..'-sticky before you post about a problem.
Seems to be a bug in the AvisynthScript used (probably works fine when using Vapoursynth):
LoadDLL("C:\Program Files\Hybrid\32bit\avisynthPlugins\libfftw3f-3.dll")
Import("C:\Program Files\Hybrid\32bit\avisynthPlugins\QTGMC.avsi")
Import("C:\Program Files\Hybrid\32bit\avisynthPlugins\Zs_RF_Shared.avsi")
Import("C:\Program Files\Hybrid\32bit\avisynthPlugins\Dehalo_alpha_mt.avsi")
# loading source: Z:\Recording Media\2021-03-02 Robert Jefferson DVD\VOB Files %\VTS_01_1.VOB
#  color sampling YV12@8, matrix: bt709, scantyp: bottom field first, luminance scale: limited
MPEG2Source(d2v="C:\Users\Mack Retirebook\AppData\Local\Temp\2021-03-17@11_14_05_8610.d2v")
# current resolution: 720x480
# deinterlacing
QTGMC(Preset="Fast", ediThreads=2)
# filtering
# denoising using fft3dfilter
# dehaloing
# scaling to 1280x720
# adjust color to YUY2 (color matrix: PC.709)
# adjusting bit depth current 8 to target 10
# convert to 10bit for encoder
# setting output fps to 29.970fps
#  output: color sampling YV12@10, matrix: bt709, scantyp: progressive, luminance scale: limited
return last
ConvertBits aborts with "YUY2 source is 8-bit only", what's surprising to me is what Hybrid added the 'ConvertToYUY2()' to start with,..
-> I'll try to reproduce this, will report back once I know why this is happening.

Cu Selur
Okay, problem is that Avisynth only supports 8Bit YUY2 and not 10bit YUY2, so Hybrid should use YUV422P instead.
-> looking into it (never ran into this since I usually use Vapoursynth)

Cu Selur
Found the problem will send you a link (via pm) to a dev version which should fix the issue in ~15min.
Make sure to delete old jobs and try with new once.
In case you get any popups about missing model entries, resetting you defaults should fix that

Cu Selur

Thank you so much for looking at this.  I will DL and try this morning.

Very grateful for all the work you put into this project.  I think its fantastic.

Hi Selur,

I am very grateful for the help and apologize for not getting a chance to check this earlier.  We have had medical issues in my family that have precluded me from having time to work this week.  I downloaded your updated version.

I am still having issues.  If I engage QTGMC filter for deinterlace, Dering, dehalo, and sharpen, it still gives me an error C.    I am attaching a copy of the log file
I've also had a common problem that the process in the instances where it doesn't crash that says it is finished, yet there is no file in the folder where I designated the file to render.
Without a debug output I have no clue what you are doing and no way to reproduce or fix the problems you report.

Cu Selur

Forum Jump:

Users browsing this thread: 1 Guest(s)