This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

A cookie will be stored in your browser regardless of choice to prevent you being asked this question again. You will be able to change your cookie settings at any time using the link in the footer.

Help configuring x265 like MediaInfo settings
#1
Hi Selur, new user here, want to ask the general setting for x265 24 fps to same x265 but 60fps, quality remain the some or better.

I attached a text file for mediainfo, can you guide me the Gui setting? I tried few time to convert but crash with some error, my guess is wrong setting input, pls help, many tkys.


Attached Files
.txt   使徒行者.txt (Size: 14,2 KB / Downloads: 5)
Reply
#2
Hi.
I split your post into a new thread since it has nothing to do with the thread of murriato.

Quote:want to ask the general setting for x265 24 fps to same x265 but 60fps, quality remain the some or better.
Not possible, reencoding will always reduce the quality, unless you use lossless compression which will create huge file sizes.
Finding settings which on reencoding will produce better quality is not possible since you can't gain quality.
(It would probably be possible to find settings which would retain more of the original quality, if you have the original source from which your file was created.)

Quote:I attached a text file for mediainfo, can you guide me the Gui setting?
Looking at the attached MediaInfo data, there is the encoding settings info:
Encoding settings           : cpuid=1111039 / frame-threads=4 / numa-pools=16 / wpp / no-pmode / no-pme / no-psnr / no-ssim / log-level=2 / csv / csv-log-level=0 / input-csp=1 / input-res=1920x816 / interlace=0 / total-frames=156743 / level-idc=0 / high-tier=1 / uhd-bd=0 / ref=5 / no-allow-non-conformance / no-repeat-headers / annexb / no-aud / no-hrd / info / hash=0 / no-temporal-layers / no-open-gop / min-keyint=1 / keyint=360 / gop-lookahead=0 / bframes=9 / b-adapt=2 / b-pyramid / bframe-bias=0 / rc-lookahead=60 / lookahead-slices=4 / scenecut=40 / radl=0 / no-intra-refresh / ctu=32 / min-cu-size=8 / rect / no-amp / max-tu-size=16 / tu-inter-depth=2 / tu-intra-depth=2 / limit-tu=4 / rdoq-level=1 / dynamic-rd=0.00 / ssim-rd / signhide / no-tskip / nr-intra=0 / nr-inter=0 / no-constrained-intra / no-strong-intra-smoothing / max-merge=3 / limit-refs=2 / limit-modes / me=3 / subme=5 / merange=25 / temporal-mvp / weightp / weightb / no-analyze-src-pics / deblock=-1:-1 / no-sao / no-sao-non-deblock / rd=4 / no-early-skip / rskip / no-fast-intra / no-tskip-fast / no-cu-lossless / b-intra / no-splitrd-skip / rdpenalty=1 / psy-rd=0.00 / psy-rdoq=5.00 / no-rd-refine / no-lossless / cbqpoffs=-2 / crqpoffs=-2 / rc=crf / crf=20.0 / qcomp=0.70 / qpstep=4 / stats-write=0 / stats-read=0 / ipratio=1.40 / pbratio=1.30 / aq-mode=1 / aq-strength=0.80 / cutree / zone-count=0 / no-strict-cbr / qg-size=16 / no-rc-grain / qpmax=69 / qpmin=0 / no-const-vbv / sar=0 / overscan=0 / videoformat=5 / range=0 / colorprim=1 / transfer=2 / colormatrix=2 / chromaloc=0 / display-window=0 / max-cll=0,0 / min-luma=0 / max-luma=1023 / log2-max-poc-lsb=8 / vui-timing-info / vui-hrd-info / slices=1 / no-opt-qp-pps / no-opt-ref-list-length-pps / no-multi-pass-opt-rps / scenecut-bias=0.05 / no-opt-cu-delta-qp / no-aq-motion / no-hdr / no-hdr-opt / no-dhdr10-opt / no-idr-recovery-sei / analysis-reuse-level=5 / scale-factor=0 / refine-intra=0 / refine-inter=0 / refine-mv=0 / no-limit-sao / ctu-info=0 / no-lowpass-dct / refine-mv-type=0 / copy-pic=1 / max-ausize-factor=1.0 / no-dynamic-refine / no-single-sei
To start things up, I think it's a stupid idea to try to replicate these settings unless you want to append another video clip to this one. Reencoding a clip with the same (none-lossless) settings is usually a bad idea.
Also it will take quite some time to:
a. map each reported encoding setting first to an x265 option (see: https://x265.readthedocs.io/en/latest/cli.html and in the source code https://bitbucket.org/multicoreware/x265.../param.cpp -> 'x265_print_params')
b. map each option to where that setting is in Hybrid
Back in 2015 I wrote a small tool (Mis2x265) which converts those 'Encoding settings' to normal command lines, but since the x265 options changed quite a bit since then it does not really help since a lot of options get ignored.
Here's the output of Mis2x265 for the reported 'Encoding settings'.
ignored: cpuid
ignored: frame-threads
ignored: numa-pools
ignored: pmode
ignored: psnr
ignored: ssim
ignored: log-level
ignored: csv
ignored: csv-log-level
ignored: input-csp
ignored: input-res
ignored: total-frames
ignored: level-idc
ignored: high-tier
ignored: uhd-bd
ignored: allow-non-conformance
ignored: repeat-headers
ignored: annexb
ignored: aud
ignored: info
ignored: hash
ignored: gop-lookahead
ignored: radl
ignored: intra-refresh
ignored: limit-tu
ignored: dynamic-rd
ignored: ssim-rd
ignored: nr-intra
ignored: nr-inter
ignored: limit-modes
ignored: analyze-src-pics
ignored: rskip
ignored: b-intra
ignored: splitrd-skip
ignored: rd-refine
ignored: crf
ignored: stats-write
ignored: stats-read
ignored: zone-count
ignored: strict-cbr
ignored: qg-size
ignored: rc-grain
ignored: const-vbv
ignored: sar
ignored: overscan
ignored: videoformat
ignored: range
ignored: colorprim
ignored: transfer
ignored: colormatrix
ignored: chromaloc
ignored: display-window
ignored: max-cll
ignored: min-luma
ignored: max-luma
ignored: log2-max-poc-lsb
ignored: vui-timing-info
ignored: vui-hrd-info
ignored: slices
ignored: opt-qp-pps
ignored: opt-ref-list-length-pps
ignored: multi-pass-opt-rps
ignored: scenecut-bias
ignored: opt-cu-delta-qp
ignored: aq-motion
ignored: hdr
ignored: hdr-opt
ignored: dhdr10-opt
ignored: idr-recovery-sei
ignored: analysis-reuse-level
ignored: scale-factor
ignored: refine-intra
ignored: refine-inter
ignored: refine-mv
ignored: limit-sao
ignored: ctu-info
ignored: lowpass-dct
ignored: refine-mv-type
ignored: copy-pic
ignored: max-ausize-factor
ignored: dynamic-refine
ignored: single-sei
x265 call:
x265 --wpp --no-pme --interlaceMode 0 --ref 5 --no-hrd --no-temporal-layers --no-open-gop --min-keyint 1 --keyint 360 --bframes 9 --b-adapt 2 --b-pyramid --bframe-bias 0 --rc-lookahead 60 --lookahead-slices 4 --scenecut 40 --ctu 32 --min-cu-size 8 --rect --no-amp --max-tu-size 16 --tu-inter-depth 2 --tu-intra-depth 2 --rdoq-level 1 --signhide --no-tskip --no-constrained-intra --no-strong-intra-smoothing --max-merge 3 --limit-refs 2 --me 3 --subme 5 --merange 25 --temporal-mvp --weightp --weightb --deblock -1:-1 --no-sao --no-sao-non-deblock --rd 4 --no-early-skip --no-fast-intra --no-tskip-fast --no-cu-lossless --rdpenalty 1 --psy-rd 0.00 --psy-rdoq 5.00 --no-lossless --cbqpoffs -2 --crqpoffs -2 --qcomp 0.70 --qpstep 4 --ipratio 1.40 --pbratio 1.30 --aq-mode 1 --aq-strength 0.80 --cutree --qpmax 69 --qpmin 0

Since it would take quite some time to write down a mapping to the gui for each of the options, I'm not going to look these up one by one and create such a mapping for you.
If you tried for yourself and you are unsure about a few mappings I can sure help you, but spending a few hours to go through all those settings would be a waste from my standpoint.

Quote:I tried few time to convert but crash with some error, my guess is wrong setting input, pls help, many tkys.
The settings should not cause a crash, so you probably stumbled over a bug.
So read https://forum.selur.net/Thread-INFO-Info...oduce-bugs thoroughly and share a debug output level 9 of the job processing with me, since without you providing detailed information I can't know what you did and where the problem is.
As a side note: There is a bug in the x265 which comes with rev 2019.11.23.1 which break 2pass encoding unless you enable 'x265->Rate Control->Rate Distortion Optimization->Scene cut aware quantization'. So in case you use 2pass encoding make sure to enable it.

Cu Selur
Reply
#3
Quote:I tried few time to convert but crash with some error, my guess is wrong setting input, pls help, many tkys.
The settings should not cause a crash, so you probably stumbled over a bug.
So read https://forum.selur.net/Thread-INFO-Info...oduce-bugs thoroughly and share a debug output level 9 of the job processing with me, since without you providing detailed information I can't know what you did and where the problem is.
As a side note: There is a bug in the x265 which comes with rev 2019.11.23.1 which break 2pass encoding unless you enable 'x265->Rate Control->Rate Distortion Optimization->Scene cut aware quantization'. So in case you use 2pass encoding make sure to enable it.

Cu Selur

Just sent the email with debug file, hope can solve the issue. My intention is just change the originel video to 60fps, sorry for mislead about the better quality mentioned previously.
Reply
#4
Seeing that you use Avisynth and that the decoder during the encoding call fails, check whether the 'Avisynth Preview' properly shows your video.
The Avisynth script looks like this:
LoadPlugin("C:\PROGRA~1\Hybrid\32bit\AVISYN~1\LSMASHSource.dll")
LoadPlugin("C:\PROGRA~1\Hybrid\32bit\AVISYN~1\svpflow1.dll")
LoadPlugin("C:\PROGRA~1\Hybrid\32bit\AVISYN~1\svpflow2.dll")
LoadPlugin("C:\PROGRA~1\Hybrid\32bit\AVISYN~1\masktools2.dll")
LoadPlugin("C:\PROGRA~1\Hybrid\32bit\AVISYN~1\RgTools.dll")
LoadPlugin("C:\PROGRA~1\Hybrid\32bit\AVISYN~1\warpsharp.dll")
Import("C:\Program Files\Hybrid\32bit\avisynthPlugins\InterFrame2.avsi")
Import("C:\Program Files\Hybrid\32bit\avisynthPlugins\LimitedSharpenFaster.avs")
SetFilterMTMode("DEFAULT_MT_MODE", MT_MULTI_INSTANCE)
# loading source: E:\迅雷下载\使徒行者.mkv
#  input color sampling YV12
#  input luminance scale tv
LWLibavVideoSource("E:\迅雷下载\使徒行者.mkv",cache=false,format="YUV420P16", prefer_hw=3,repeat=true)
# current resolution: 1920x816
# Dithering from 16 to 8bit for Interframe
ConvertBits(8)
InterFrame(NewNum=60,NewDen=1,OverrideAlgo=23,Cores=8)
# filtering
# sharpening
LimitedSharpenFaster(Smode=3,edgemode=0)
# scaling
Spline36Resize(1920,900)
# current resolution: 1920x900
# adjusting bit depth current 8 to target 10
# convert to 10bit for encoder
ConvertBits(10)
PreFetch(2)
return last
In case the preview fails with LWLibavVideoSource opening the video, try:
a. disabling 'Filtering->Avisynth->Misc->Sourcefilter Settings->prefer hw decoding'.
b. whether it helps to rename the video and folder to ascii characters.

Cu Selur
Reply
#5
Selur Wrote:Seeing that you use Avisynth and that the decoder during the encoding call fails, check whether the 'Avisynth Preview' properly shows your video.
The Avisynth script looks like this:
LoadPlugin("C:\PROGRA~1\Hybrid\32bit\AVISYN~1\LSMASHSource.dll")
LoadPlugin("C:\PROGRA~1\Hybrid\32bit\AVISYN~1\svpflow1.dll")
LoadPlugin("C:\PROGRA~1\Hybrid\32bit\AVISYN~1\svpflow2.dll")
LoadPlugin("C:\PROGRA~1\Hybrid\32bit\AVISYN~1\masktools2.dll")
LoadPlugin("C:\PROGRA~1\Hybrid\32bit\AVISYN~1\RgTools.dll")
LoadPlugin("C:\PROGRA~1\Hybrid\32bit\AVISYN~1\warpsharp.dll")
Import("C:\Program Files\Hybrid\32bit\avisynthPlugins\InterFrame2.avsi")
Import("C:\Program Files\Hybrid\32bit\avisynthPlugins\LimitedSharpenFaster.avs")
SetFilterMTMode("DEFAULT_MT_MODE", MT_MULTI_INSTANCE)
# loading source: E:\迅雷下载\使徒行者.mkv
#  input color sampling YV12
#  input luminance scale tv
LWLibavVideoSource("E:\迅雷下载\使徒行者.mkv",cache=false,format="YUV420P16", prefer_hw=3,repeat=true)
# current resolution: 1920x816
# Dithering from 16 to 8bit for Interframe
ConvertBits(8)
InterFrame(NewNum=60,NewDen=1,OverrideAlgo=23,Cores=8)
# filtering
# sharpening
LimitedSharpenFaster(Smode=3,edgemode=0)
# scaling
Spline36Resize(1920,900)
# current resolution: 1920x900
# adjusting bit depth current 8 to target 10
# convert to 10bit for encoder
ConvertBits(10)
PreFetch(2)
return last
In case the preview fails with LWLibavVideoSource opening the video, try:
a. disabling 'Filtering->Avisynth->Misc->Sourcefilter Settings->prefer hw decoding'.
b. whether it helps to rename the video and folder to ascii characters.

Cu Selur

Hi, I just follow your advised to disable the prefer hw decoding, plus enble the prefer FFmpegsource to start the video encoding, no issue. Although take very long time to process, the video 60fps quality is superb, love the outcome, thanks.


Attached Files Thumbnail(s)
   
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)