How to 60fps with NVEnc (FFmpeg)?
#1
[Image: 67978747_385276268845981_673278078606534...e=5DD7BB42]
I do like this
but video not smooth
Reply
#2
It doesn't make any sense to enable all of these options at the same time.
It seems like you did not read their descriptions.
Read the descriptions and also read Convert to 60fps.

Cu Selur
Reply
#3
(18.08.2019, 15:21)Selur Wrote: It doesn't make any sense to enable all of these options at the same time.
It seems like you did not read their descriptions.
Read the descriptions and also read Convert to 60fps.

Cu Selur
I only use "interpolate frame rate" 60fps
"scene change" 7
all process is finished but i can not open file

media player classic say : cannot render the file

sorry i'm so noob
Reply
#4
I have no clue what you did, assuming it's a bug, read
[INFO] Infos needed to fix&reproduce bugs,..
.

I tried:
  1. taking a random input file and feeding it to Hybrid
  2. enabling 'Filtering->Speed Change->Interpolate frame rate' and setting it to '60 fps'
  3. selecting 'NVEnc (FFmpeg)' as encoder (using H264 as Encoder)
  4. creating a new job
->output .mp4 file plays fine and is 60fps

used encoding call was:
ffmpeg -y -noautorotate -threads 8 -i "F:\TestClips&Co\files\test.avi" -map 0:0 -an -sn -vf framerate=fps=60:scene=7,zscale=rangein=tv:range=tv -pix_fmt yuv420p -vsync 0  -vcodec h264_nvenc -preset 5 -profile:v 2 -level 0 -rc vbr_hq -2pass 1 -qmin 0 -qmax 51 -b:v 1500k -spatial-aq 0 -temporal_aq 0 -rc-lookahead 0 -surfaces 32 -no-scenecut 0 -refs 3 -nonref_p 1 -strict_gop 1 -bsf:v h264_mp4toannexb "E:\Temp\test_16_18_34_6610_01.264"

using H.265 as encoder the encoding call is:
ffmpeg -y -noautorotate -threads 8 -i "F:\TestClips&Co\files\test.avi" -map 0:0 -an -sn -vf framerate=fps=60:scene=7,zscale=rangein=tv:range=tv -pix_fmt yuv420p -vsync 0  -vcodec hevc_nvenc -preset 5 -profile:v 1 -level 0 -tier main -rc vbr_hq -2pass 1 -qmin 0 -qmax 51 -b:v 1500k -spatial-aq 0 -temporal_aq 0 -surfaces 32 -no-scenecut 0 -refs 3 -nonref_p 1 -strict_gop 1 -bsf:v hevc_mp4toannexb "E:\Temp\test_16_18_11_7810_01.265"
I get a broken output, when using profile 'Main' (-profile:v 1) switching to 'Main 10' (-profile:v 2) output seems fine.
No clue why.
Mapping should be:
0 <> none
1 <> main
2 <> main10
3 <> rext

-> I'd recommend to use NVEnc instead of 'NVEnc (FFmpeg)'.
(Also I recommend to not use the 'Speed Change' option, but use Interframe with Vapoursynth for better quality interpolation, see the 'Convert to 60fps' thread from above.)

Cu Selur
Reply
#5
Ok Bro
Thanks a lot
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)