This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

A cookie will be stored in your browser regardless of choice to prevent you being asked this question again. You will be able to change your cookie settings at any time using the link in the footer.

Hybrid on Ubuntu 16.04 crashes

I am using the Linux version and running on Ubuntu 16.04 and the newest version will not start.  Unfortunately the latest version that I can get to run is dated back in 2014.  In fact it is v2014.02.25_1.  I know a very old version, but it does start up and I am able to execute jobs with it.

Hybrid acts like it is starting up, and gets to a certain point and stops.  Here is the last few lines of the startup log.  Unfortunately, since I am unable to get it to start I can configure it to dump a debug log.

  checking for wine
 Check name: FrameCounter, path: /usr/bin/FrameCounter, checkSingle: false
 Check name: aften, path: /usr/bin/aften, checkSingle: false
 Check name: x265, path: /usr/bin/x265, checkSingle: false
 setting tool versions,..
 updating tool versions,...
The X11 connection broke (error 4). Did the X11 server die?

I did a little searching around and found where one guy with the same issue did a reinstall of his Ubuntu desktop.  I have tried that, as well as using a different X servers, all with the same result.  I have updated my system and tools using an apt-get update and apt-get upgrade.

Anyway, since the source code is not available, it is hard to know what it is doing right after the updating tool versions line in the startup log.  Was hoping someone might have some ideas.

Since I build Hybrid in a Ubuntu 16.04 VM I doubt it's a general Hybrid problem.
Did you try deleting your old setting? (Installing and uninstalling old versions will break the settings.)
Also try and see what happens if you start Hybrid from a console using '--debug'.
Cu Selur
Reinstalled from scratch, and installed Ubuntu 18.04 and the same issue is still there.  Here is the last few lines running with --debug:

Detected cpu cores: 4
Total memory detected: 7975MB
Hybrid pid: 7164
updating tools for collectors,...
 updating collector,...
 setting tools for file info collector,...
Initial output bit depth is: 8
Finished initialization, finished after 1.223s

Gdk-Message: 18:40:37.912: Hybrid-551: Fatal IO error 11 (Resource temporarily unavailable) on X server :1.0.

The February 2014 version that I have does not have this issue and runs fine.  I am running from tightvnc, so I will try directly from the console later...

My guess it's related to vnc, see:, I'll try to reproduce this here with a VM and may be I find a way to get this working, but my hope is slim.
Can't get tightvnc working here. (only get a gray screen when connecting to the VM + journalctl shows some errors,...)
Using teamviewer I got no problem with Hybrid.
-> my guess is that there is a problem with tightvnc and Qt 5.5 on Ubuntu 16.04, sadly I see no way to change that.

Cu Selur
Thanks!  Finally resolved the issue.  It worked fine from the console.  So I started checking into the remote Desktop and VNC server that I was using.

Apparently it will not work with XFCE as a desktop.  I switched to trying to run the Gnome desktop, but could not get that desktop to start with TightVNC.

I switched to TigerVNC and the got the Gnome desktop working.  After that, Hybrid works fine.

Apparently there is a long standing bug with trying to use acceleration on a remote desktop that hasn't been fixed.   Whatever TigerVNC is doing, it works around that bug and allows the Gnome Desktop to start.


Forum Jump:

Users browsing this thread: 1 Guest(s)