This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

A cookie will be stored in your browser regardless of choice to prevent you being asked this question again. You will be able to change your cookie settings at any time using the link in the footer.

Linux Vapoursynth problems
#1
I am on Linux Mint 19.2 and I installed hybrid from your Ubuntu repository.
When trying to use the QTGMC (Vapoursynth) deinterlacer, the job always crashes. The problem can be also reproduced in the Vapoursynth Preview function, then VSEdit is opened and fails:

Failed to evaluate the script:
Python exception: Failed to load znedi3. Error given: znedi3: cannot open shared object file: No such file or directory

The plugin znedi3 is obviously used in QTGMC (script havsfunc.py), but it's missing in the installation.
Could it please be added (or is there a reason for it not being included)?

Thanks,
kybos


PS: When I close VSEdit after this error, Hybrid crashes immediately:

malloc_consolidate(): invalid chunk size
Aborted (core dumped)
Reply
#2
Strange thing about this is as far as I can see everywhere in QTGMC zdnedi3 is only used through this:
core.znedi3.nnedi3 if hasattr(core, 'znedi3') else core.nnedi3.nnedi3
so only when it exists,...
Reply
#3
(13.05.2019, 16:20)Selur Wrote: Strange thing about this is as far as I can see everywhere in QTGMC zdnedi3 is only used through this:
core.znedi3.nnedi3 if hasattr(core, 'znedi3') else core.nnedi3.nnedi3
so only when it exists,...

I will not pretend to understand the code fully, but in the script havsfunc.py (which is loaded in the VS script created by Hybrid), there are several lines like this:

myNNEDI3 = core.znedi3.nnedi3

Could that be the problem?
Reply
#4
Yup, probably is. I'll write a modified havsfunc.py in an hour or so and post it here.

Cu Selur
Reply
#5
Okay, I see why I didn't stop this, it's because that's not how the script looks like for me.
See the scripts Hybrid should use: https://github.com/Selur/VapoursynthScriptsInHybrid
(replacing the script you use with the scripts from the git repository should help)

Cu Selur
Reply
#6
(14.05.2019, 16:45)Selur Wrote: Okay, I see why I didn't stop this, it's because that's not how the script looks like for me.
See the scripts Hybrid should use: https://github.com/Selur/VapoursynthScriptsInHybrid
(replacing the script you use with the scripts from the git repository should help)

Cu Selur

Thanks, that was it. I copied all the scripts from git into /usr/share/vsscripts and now the VS preview works.
But still, after closing VSEdit, Hybrid crashes as before. I suppose I will have to create a debug log for that...
Reply
#7
Preview issues require a debug output of level 6 or higher.
Just to be sure, check that the binary used is vsviewer not vsedit,...

Cu Selur
Reply
#8
(14.05.2019, 17:46)Selur Wrote: Preview issues require a debug output of level 6 or higher.
Just to be sure, check that the binary used is vsviewer not vsedit,...

Cu Selur

Yes, binary is vsViewer.
I created debug log level 6, see attchmnt.
I don't provide a sample file, as it happens with any video file.

Thanks, kybos


.zip   HybridDebugOutput.zip (Size: 19,11 KB / Downloads: 17)
Reply
#9
@kybos: Sorry, totally forgot about the issue. Smile
looking at the debug output there is an error:
Quote:qt5ct: using qt5ct plugin
qt5ct: D-Bus global menu: no
Which might be related to: https://forum.manjaro.org/t/solved-qt5ct...ault/48596

Cu Selur
Reply
#10
(09.06.2019, 16:45)Selur Wrote: @kybos: Sorry, totally forgot about the issue. Smile
looking at the debug output there is an error:
Quote:qt5ct: using qt5ct plugin
qt5ct: D-Bus global menu: no
Which might be related to: https://forum.manjaro.org/t/solved-qt5ct...ault/48596

Cu Selur

No problem.
I checked qt5ct but it works without issues.
Both messages you mentioned come also when Hybrid starts, and exactly these both messages are issued when I start vsViewer directly (which also works).

But now I tried the Hybrid VS preview again and got a popup:
   

I suppose this is not a file system URL, but I definitely have no ffmsindex on my system, there is only the ffms2.so library. Is there still something missing in the installation?

Thanks,
Kybos
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)