This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

A cookie will be stored in your browser regardless of choice to prevent you being asked this question again. You will be able to change your cookie settings at any time using the link in the footer.

Not working temporaldegrain2, WNNM filters
#1
Preview window does not appear, when any of these filters are enabled.


Attached Files
.zip   HybridDebugOutput.zip (Size: 60,66 KB / Downloads: 10)
Reply
#2
Can't reproduce this here.
Both filters work fine on my system with different sources.

For WNNM I suspect that the filter might require AVX2, but no clue why TemporalDegrain2 would not work.

Do you get an error message if you open vsViewer (Tools->vsViewer) and open one of the scripts and press F5?

Cu Selur
Reply
#3
(10.04.2023, 06:56)Selur Wrote: Can't reproduce this here.
Both filters work fine on my system with different sources.

For WNNM I suspect that the filter might require AVX2, but no clue why TemporalDegrain2 would not work.

Do you get an error message if you open vsViewer (Tools->vsViewer) and open one of the scripts and press F5?

Cu Selur

My CPU do not support AVX2.
1. I open vsViewer
2. Open in temporaldegrain2 script
3. Then I prees F5.
4. vsViewer without an error message closes.
Reply
#4
Does TemporalDegrain2 work if you replace the fft3dfilter.dll with the one from https://github.com/myrsloik/VapourSynth-...r/releases ?

Cu Selur
Reply
#5
(10.04.2023, 12:46)Selur Wrote: Does TemporalDegrain2 work if you replace the fft3dfilter.dll with the one from https://github.com/myrsloik/VapourSynth-...r/releases ?

Cu Selur

Now it working.
Reply
#6
Okay, that is an older/slower version of fft3dfilter which does not require AVX2.
Sadly, there is no older version of wnnm (https://github.com/AmusementClub/VapourS...M/releases), that does not require AVX2, so you can't use that filter.

Cu Selur

Ps.: What cpu are you using?
Reply
#7
(10.04.2023, 13:15)Selur Wrote: Cu Selur

Ps.: What cpu are you using?
Intel Xeon E5-1650 v2, 3700 MHz (37 x 100)
Reply
#8
Ah, okay, 10+years old cpu, that explains the lack of AVX2. Smile

Cu Selur
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)