This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

A cookie will be stored in your browser regardless of choice to prevent you being asked this question again. You will be able to change your cookie settings at any time using the link in the footer.

Settings for AVCHD 2.0 Progressive compliant file, playback
#91
If your content is real interlaced content bobbing is the right way.
If your content is interlaced, but the progressive version has tons of duplicates same frame rate deinterlacing and frame interpolation would be better.

Cu Selur
Reply
#92
I found that some of my home video tapes, from DV camcorder have levels exceeding 16-235 range.
Using Hybrid, x264 everything beyond that range gets clipped.
In recent years LCD TVs are capable to display wider range of video (I would think so).

How would be possible to encode with x264 passing a full range of 0 - 255?
Not doing a level scaling from 0 -255 to 16-235 but just passing a whole range and letting media player or TV to clip it.

The question is, is it even a good idea, the levels might be conditioned, clipped in TV or player anyway?
Reply
#93
Quote:Using Hybrid, x264 everything beyond that range gets clipped.
not totally sure Hybrid or x264 crop this, it might be just the player.

LCDs should be able to playback full range (0-255).
Players (software&hardware) should follow the VUI flag regarding luma range.
So even if the luma range is 0-255 if the flag says 'limited/tv' the player should crop the luma, most players assume tv/limited when no flag is present.

There are multiple ways to deal with it:
a. simply change the output flag in x264 (x264->VUI->Video Usability Information->Luma Range)
b. Overwrite the output luma range (Misc->Overwrite Output->Output Luminance)
c. use Vapoursynth or Avisynth to adjust the Luma (compress to 16-235, 0-255) and then use a. or b.
Keep it as it is and simply cut off the luma range, I think this is what usually is done, but I could be wrong there. (best ask the folks over at videohelp.com, there are a bunch of folks who regularly and professionally deal with dv content)

Cu Selur
Reply
#94
Following suggested:
b. Overwrite the output luma range (Misc->Overwrite Output->Output Luminance)

Can't find "Overwrite Output" under x264 Misc setting.
Reply
#95
I missed Filtering, "Filtering->Misc->Overwrite Output->Output Luminance)

Side note: The flags of a h264 and h265 videos can be changed using ffmpegs bitstream filters without reencoding. https://ffmpeg.org/ffmpeg-bitstream-filters.html
(no this is not possible in Hybrid, but support for it might come somewhere in the future)

Cu Selur
Reply
#96
Thanks, that works.

One more thing to ask.
Having a Color Matrix problem when using Avisynth and external DV Mainconcept decoder.
 
Encoding with x264, using Avisynth and external DV Mainconcept decoder:
·       Filtering>Avisynth (Support is set for Avisynth)>Color>Matrix>ColorMatrix enabled, set From: Rec. 601 To: Rec. 709.
·       Filtering>Avisynth>Misc>Source>Enabling “Prefer AviSource for avi input”, to enable 32-bit DV Mainconept.
 
Encoded file, as TMPGENC Authring Works shows has wrong Color Space/matrix.
YUV Color Space (Matrix Coefficients) has to be ITU-R BT.709, but file is encoded as BT.470-2 System B, G, and is not AVCHD 2.0 compliant file.
 
Using same file, same settings but using Avisynth and internal DV decoder - is all good.
Reply
#97
The color matrix flag is specified under x264->VUI.
Without knowing the Avisynth Scripts used I have no clue what is happening, two debug outputs would even be better.

If you share more details might ne able to tell whats happening.

Cu Selur

Ps.: ging to bed now.
Reply
#98
I sent a debug file through PM, but after I checked under x264->VUI, set bt709 and it fixed the problem.
It is all good now.
Before, for PAL DV file (VHS capture) I was using only Color>Matrix and setting From: Rec. 601 To: Rec. 709 and it was good enough. But for NTSC also need to go to x264->VUI and set color matrix flag.
Reply
#99
Quote:Before, for PAL DV file (VHS capture) I was using only Color>Matrix and setting From: Rec. 601 To: Rec. 709 and it was good enough. But for NTSC also need to go to x264->VUI and set color matrix flag.
That probably depends on whether and how the input is flagged,..

Cu Selur
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)