This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

A cookie will be stored in your browser regardless of choice to prevent you being asked this question again. You will be able to change your cookie settings at any time using the link in the footer.

Wrong frame rate
#1
Input file is interlaced 25 fps
Deinterlacer  QTGMC
When I check "Bob" box and select *.mkv for output - output file is frame rate 98.888 FPS.
When I check "Bob" box and select *.avi for output - output file is frame rate normally 50.000 FPS.


Attached Files
.zip   HybridDebugOutput.zip (Size: 63,48 KB / Downloads: 2)
Reply
#2
You only attached a debug output which contains the creation of the mkv output. (which looks fine)
You did not provide a debug output regarding .avi output.
I tried to reproduce the issue here with .avi output but couldn't.
-> please provide a debug output which shows the problem with the .avi creation

Cu Selur
Reply
#3
(02.12.2019, 16:53)Selur Wrote: -> please provide a debug output which shows the problem with the .avi creation

Cu Selur


Attached Files
.zip   HybridDebugOutput.zip (Size: 290,2 KB / Downloads: 2)
Reply
#4
According to the debug output the muxing call specifies 50fps:
"C:\PROGRA~1\Hybrid\64bit\mencoder.exe" -ovc copy "C:\Windows\Temp\9 [2016 - Den' rozhdeniya v Kremle. Muz-TV 20 let v efire_19_13_50_2910_05.avi" -demuxer lavf -force-avi-aspect 1.36458 -mc 0  -oac copy -audiofile "C:\Windows\Temp\iId_1_aid_68_lang_en_19_13_50_2910_02.wav" -ofps 50/1 -of avi -o "D:\My Programms\MPEG Programs\AA-CODECS\Hybrid\Selur\9 [2016 - Den' rozhdeniya v Kremle. Muz-TV 20 let v efire.avi"
don't see any problem.

Cu Selur
Reply
#5
(02.12.2019, 17:44)Selur Wrote: According to the debug output the muxing call specifies 50fps:
"C:\PROGRA~1\Hybrid\64bit\mencoder.exe" -ovc copy "C:\Windows\Temp\9 [2016 - Den' rozhdeniya v Kremle. Muz-TV 20 let v efire_19_13_50_2910_05.avi" -demuxer lavf -force-avi-aspect 1.36458 -mc 0  -oac copy -audiofile "C:\Windows\Temp\iId_1_aid_68_lang_en_19_13_50_2910_02.wav" -ofps 50/1 -of avi -o "D:\My Programms\MPEG Programs\AA-CODECS\Hybrid\Selur\9 [2016 - Den' rozhdeniya v Kremle. Muz-TV 20 let v efire.avi"
don't see any problem.

Cu Selur
Yes, when choosing *.avi output frame rate are set right. When choosing *.mkv output frame rate are wrong.
Reply
#6
The mkv muxing call was:
"C:\PROGRA~1\Hybrid\64bit\mkvmerge.exe" --ui-language en -o "D:\Encode\2019\9 [2016 - Den' rozhdeniya v Kremle. Muz-TV 20 let v efire.mkv" --global-tags "C:\Users\t_khanyan\AppData\Local\Temp\9 [2016 - Den' rozhdeniya v Kremle. Muz-TV 20 let v efire_17_05_20_7710__07.xml" --default-track 1:yes --default-duration 1:50/1fps --aspect-ratio-factor 1:1/1 --no-chapters --compression -1:none --forced-track 1:yes --no-audio --no-subtitles "C:\Users\T_KHAN~1\AppData\Local\Temp\9 [2016 - Den' rozhdeniya v Kremle. Muz-TV 20 let v efire_17_05_20_7710_04.mkv" --language 0:en --default-track 0:yes --forced-track 0:no -a 0 --compression -1:none --no-video --no-subtitles --no-chapters "C:\Users\t_khanyan\AppData\Local\Temp\iId_3_aid_68_lang_en_17_05_20_7710_01.wav"
looks fine to me. "--default-duration 1:50/1fps" sets the fps to 50.
Tried to reproduce the issue and couldn't, for me both UTVideo with avi and mkv produces 50fps video when using QTGMC and bob (with Avisynth and Vapoursynth).

Cu Selur
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)