Selur's Little Message Board
Files taking too long to load - Printable Version

+- Selur's Little Message Board (https://forum.selur.net)
+-- Forum: Hybrid - Support (https://forum.selur.net/Forum-Hybrid-Support)
+--- Forum: Problems & Questions (https://forum.selur.net/Forum-Problems-Questions)
+--- Thread: Files taking too long to load (/Thread-Files-taking-too-long-to-load)



Files taking too long to load - Yudae - 26.06.2019

Whenever I try to load a large file (around 1gb) the program freezes for a few minutes until it's eventually done reading the file and becomes operational again. Is there any trick to make the files to be read faster? (The files were on my HD and not on my SSD)


RE: Files taking too long to load - Selur - 26.06.2019

No clue about the characteristics of the file, your OS, your Hybrid settings.
I probably will need a debug output level 9 of the loading of the file to see why Hybrid is 'freezing',..
Might be due to Hybrid extracting time codes, extracting subtitles,... mplayer trying to build a font cache,... no way to know from your description.
-> Can't really help atm. Read the sticky about what infos are needed.

Cu Selur


RE: Files taking too long to load - Yudae - 26.06.2019

(26.06.2019, 16:44)Selur Wrote: No clue about the characteristics of the file, your OS, your Hybrid settings.
I probably will need a debug output level 9 of the loading of the file to see why Hybrid is 'freezing',..
Might be due to Hybrid extracting time codes, extracting subtitles,... mplayer trying to build a font cache,... no way to know from your description.
-> Can't really help atm. Read the sticky about what infos are needed.

Cu Selur
I'm using a Windows 10 Pro. The freezing to read files might be my PC, which is a bit old (AMD FXtm 8320 eight core 3.5gHz; 3x 4gb 1333mHz RAM; GPU: AMD Radeon HD 6570; Hybrid and video files in a HD)
File types are pretty much any large video I at first thought were any large files but doesn't seem to be the case. Some read quickly even though they are larger.

The settings I've changed in Hybrid:
- Audio passthrough all; x264 encoding mode constant rate factor 1 pass, Quantization factor 16; AVC profile/level unrestricted; filtering i'm using AVIsynth to change videos to 60fps

Here's the debug output file (I've closed Hybrid right after it "froze". If you want I can generate another one waiting until it loads completely.
https://www.dropbox.com/s/eacvi3msaxxxb8z/HybridDebugOutput.txt?dl=0


RE: Files taking too long to load - Selur - 26.06.2019

File is reported as vfr by Mediainfo:
Frame rate mode                          : VFR
Frame rate mode                          : Variable
Frame rate                               : 25.000
Frame rate                               : 25.000 FPS
Minimum frame rate                       : 3.571
Minimum frame rate                       : 3.571 FPS
Maximum frame rate                       : 25.000
Maximum frame rate                       : 25.000 FPS
which is why Hybrid extracts the timecodes using:
"C:\Program Files\Hybrid\32bit\mp4fpsmod.exe" -p "C:\Users\Kuroki Tsubasa\AppData\Local\Temp\Deadpool 2_timecodes_v2.txt" "H:\Organizar\Deadpool 2.mp4"
this is probably what takes so long.
Using the collected data, Hybrid checks whether the source is really vfr.
If you are sure your source if cfr you can enable 'Config->Internals->Ignore all input timecodes' to tell Hybrid to never extract time codes.

Your other sources are probably indicated as cfr which is why they load faster. Smile

Cu Selur


RE: Files taking too long to load - Yudae - 26.06.2019

(26.06.2019, 17:36)Selur Wrote: File is reported as vfr by Mediainfo:
Frame rate mode                          : VFR
Frame rate mode                          : Variable
Frame rate                               : 25.000
Frame rate                               : 25.000 FPS
Minimum frame rate                       : 3.571
Minimum frame rate                       : 3.571 FPS
Maximum frame rate                       : 25.000
Maximum frame rate                       : 25.000 FPS
which is why Hybrid extracts the timecodes using:
"C:\Program Files\Hybrid\32bit\mp4fpsmod.exe" -p "C:\Users\Kuroki Tsubasa\AppData\Local\Temp\Deadpool 2_timecodes_v2.txt" "H:\Organizar\Deadpool 2.mp4"
this is probably what takes so long.
Using the collected data, Hybrid checks whether the source is really vfr.
If you are sure your source if cfr you can enable 'Config->Internals->Ignore all input timecodes' to tell Hybrid to never extract time codes.

Your other sources are probably indicated as cfr which is why they load faster. Smile

Cu Selur
Ohh it worked! Thanks a lot! Big Grin