[BUG] Please implement the "threads" setting in Avisynth for NNEDI3Resize
#1
Bug 
NNEDI3Resize has a "threads" setting:

[Image: 0dgN2EX.png]


However, in Hybrid, when selecting NNEDI3Resize in Avisnth, the "ResampleMT" check box is greyed out, and the "threads" setting defaults to 1:

[Image: YM1m5aN.png]

[Image: GZjFTDd.png]


The "1" setting is flakey / buggy for me. It's sometimes fine and I get full CPU activity and processing. However, sometimes, I get minimal CPU activity and severely slow processing (.10 fps or lower). I can solve this by changing the "threads" setting in NNEDI3 to "6"... it's actually supposed to default to "0" which sets it to the number of detected processors. Of course, I have to use the "Custom" function to get this to work with Hybrid:

[Image: j3H8f7V.png]

[Image: Jns7Eqj.png]


Please add the "threads" setting in Hybrid for NNEDI3Resize in Avisynth, and correct the default setting for "threads" (should be "0")! Smile
Reply
#2
Quote:when selecting NNEDI3Resize in Avisnth, the "ResampleMT" check box is greyed out,
That is correct, since there is ne ResampleMT-Version of NNEDI3Resize.

Quote:and the "threads" setting defaults to 1
That was added due to stability reasons when using MT.
-> Will remove the threads=1 unless Avisynth without MT is used. Don't plan to add the 'threads' option.

Cu Selur
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)