This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

A cookie will be stored in your browser regardless of choice to prevent you being asked this question again. You will be able to change your cookie settings at any time using the link in the footer.

[BUG] Progress bar and Encoding speed is wrong
Quote:And Hybrid can't handle it properly,
not even the dev version I send you?

Quote:when I cut another film with ffmpeg, the same problem occurs again.
From the look of it ffmpeg does not cut the time codes which is probably a bug or related to 'accurate_seek'. When using ffmpeg I hope 'accurate_seek' is disabled by ffmpeg automatically when using stream copy, since otherwise it will break the headers at the beginning.

In general when cutting video with ffmpeg:
- In general frame accurate cutting is not possible, 'accurate_seek' is meant for transcoding only.
- a general good read is:

In general when cutting mkvs:
Instead of using ffmpeg for cutting mkvs better use mkvtoolnix (mkvmerge); it properly handles time stamps etc.

If you want to cut mkvs frame accurate, with a format that isn't lossless or I-Frame only, you need to reencode.
There are a bunch of tools like MKV Cutter (small alpha version tool I wrote), Avidemux (open source), Smart Cutter (commercial), .... just to name a few, there are a bunch of others out there that you can find using your favorite internet search engine.
Those tools use smart cutting, meaning they reencode parts to allow frame accurate cutting.

Cu Selur
Quote:not even the dev version I send you?
Yes, it seems that the dev version can only handle the video I send to you properly. Another videos cutted by ffmpeg can't be handled well. 
[url=][/url]It can't help me solve the problems. I think most video tools actually use ffmpeg. Why can't I use it directly? Maybe Boilsoft Video Splitter doesn't use ffmpeg, but its speed is far slower than ffmpeg and it doesn't support some formats: you have to encode it if you want to cut it. Oh, forget it!
#13 I don't know what's the meaning of 2pass crf which you mentioned on the old forum and I also had a problem "ERROR: COIN.264 is too small! (byteSize: 0byte)" when I attempted to use the Flash3k deband filter. Here is the debug file.!og9SSKpA! Password: 8AABSSpCc_N2mmXck_x2tg
2pass crf was removed a while back, see changelog.
Will look at the debug output once I'm home from work.
encoding call:
"C:\PROGRA~1\Hybrid\32bit\ffmpeg.exe" -y -loglevel fatal -noautorotate -threads 8 -i "D:\Hybird\encodingTempSynthSkript_03_29_10_5410.avs" -an -sn -vf zscale=rangein=tv:range=tv -pix_fmt yuv420p -vsync 0  -f rawvideo - | "C:\PROGRA~1\Hybrid\64bit\x264.exe" --preset veryslow --crf 22.00 --profile high --level 4.1 --ref 4 --vbv-maxrate 62500 --vbv-bufsize 78125 --sar 1:1 --non-deterministic --range tv --colormatrix bt709 --demuxer raw --input-res 1920x1080 --input-csp i420 --input-range tv --input-depth 8 --fps 24000/1001 --output-depth 8 --output "D:\Hybird\03_29_10_5410_03.264" -
looks fine to me.
The Avisynth script:
# loading source: G:\00017.mkv
#  input color sampling YV12
#  input luminance scale tv
# current resolution: 1920x1080
# filtering
# debanding
return last
looks fine too.
RAM usage shouldn't be that high to cause problems.
Tried to replicate the issue here, but for me everything worked as it should

1. does the Avisynth Preview work properly or does it show errors.
2. what happens if you call the encoding call from above inside a Windows Command Prompt?

Cu Selur
Quote:1. does the Avisynth Preview work properly or does it show errors.

Avisynth preview error: not load a 64 bit DLL in 32 bit Avisynth: 'C:/Program Files (x86)/AviSynth/plugins/ffms2.dll'. (D:\Hybird\tempPreviewAvisynthFile22_31_05_706.avs, line 1) Couldn't import -1 (1): R ??)

Quote:2. what happens if you call the encoding call from above inside a Windows Command Prompt?
raw [info]: 1920x1080p 1:1 @ 24000/1001 fps (cfr)
x264 [info]: using SAR=1/1
x264 [info]: using cpu capabilities: MMX2 SSE2Fast SSSE3 SSE4.2 AVX FMA3 BMI2 AVX2
x264 [info]: profile High, level 4.1, 4:2:0, 8-bit
okay something is not right on your system, since the debug output shows that :
is used, but your script is complaining about:
C:/Program Files (x86)/AviSynth/plugins/ffms2.dll
which is another Avisynth installation inside the 'Program Files (x86)' so it should be a 32bit Avisynth version and thus should only used with 32bit dlls.
Since Hybrid ships with it's own 32bit Avisynth and 32bit dlls it looks like you or some stuff you installed messed up a bunch of stuff.
Also this has nothing to do with Flash3k.
-> this is does not look like a Hybrid bug, but like something you did to your system.

Cu Selur
I need to install Avisynth in order to compare the screenshots of same frame between the Remux file and the Encoded file. However, even I reinstall Avisynth on disk D, Hybrid will still use the 64 bit dll which I copy to the plugins folder of Avisynth (I'm told to do so if I use the 64 bit system, now I replace them with 32 bit dlls). Now, Hybrid works fine. I wonder if it's necessnary to use the 64 bit dlls on 64 bit system. Besides, I also want to know that how to use Flash3k with Vapoursynth and does Hybrid have the FillMargins fliter?
Quote:I wonder if it's necessnary to use the 64 bit dlls on 64 bit system.
Hybrid does use:
1. 32bit Avisynth++ MT / Avisynth MT
2. 64bit Vapoursynth
and it's not necessary to use 64bit filters on a 64bit system.
But if you use 32bit Avisynth/Vapoursynth you need to use 32bit filters.
But if you use 64bit Avisynth/Vapoursynth you need to use 64bit filters.
You can't mix 32 and 64bit.

Quote:does Hybrid have the FillMargins fliter?
Hybrid does not support FillMargins ( atm., but if you know your way around Avisynth you can use it through the Filtering->Avisynth->Customs section.

Quote:how to use Flash3k with Vapoursynth
1. switch to Vapoursynth (select Vapoursynth under Filtering->Support)
2. enable Filtering->Vaoursynth->Artefacts->Deband
3. select and configure Flash3kDB

Cu Selur
Okay, thanks a lot.

Forum Jump:

Users browsing this thread: 1 Guest(s)