This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

A cookie will be stored in your browser regardless of choice to prevent you being asked this question again. You will be able to change your cookie settings at any time using the link in the footer.

[HELP] image squence can't use
Dear Selur
I try to convert  pictures to videos,but it chashed
My pictuers is png
[Image: ZpYYpkF.png]
I assume you graphic card and driver combination supports using encoding 4k H.265 video.

Looking at the encoding call:
"C:\PROGRA~1\Hybrid\64bit\ffmpeg.exe" -y -noautorotate -nostdin -threads 14  -i "C:/Users/XPRAMT/Downloads/A/%05d.png" -frames:v 1809 scale=out_range=pc -pix_fmt yuv444p -an -sn -vf  scale=out_range=pc -pix_fmt yuv420p10le -strict -1 -vsync 0  -f yuv4mpegpipe - | "C:\PROGRA~1\Hybrid\64bit\NVEncC.exe" --y4m -i - --fps 30.068 --codec h265 --profile main10 --level auto --tier high --sar 1:1 --lookahead 16 --output-depth 10 --cqp 20 --gop-len 0 --ref 3 --bframes 3 --bref-mode disabled --no-b-adapt --mv-precision Q-pel --preset default --fullrange --colorprim undef --transfer undef --colormatrix bt709 --cuda-schedule sync --output "C:\Users\XPRAMT\AppData\Local\Temp\00001_15_29_54_8710_01.265"
I see no apparent, to you see an error if you call this inside a Windows Command prompt?

Cu Selur
I copy the code to cmd,it appeared error:

Stream #0:0: Video: mjpeg (Baseline), yuvj420p(pc, bt470bg/unknown/unknown), 3840x2160 [SAR 1:1 DAR 16:9], 25 fps, 25 tbr, 25 tbn, 25 tbc
[NULL @ 0000025637b6a3c0] Unable to find a suitable output format for 'scale=out_range=pc'
scale=out_range=pc: Invalid argument
y4m: failed to parse y4m header.
failed to initialize file reader(s).
Failed to open input file.

And I delet "scale=out_range=pc",it can work normally.
Strange thing is that '-vf scale=out_range=pc' should work unless I read the documentation wrong, see
Also I tried reproducing the issue here using:
ffmpeg -y -noautorotate -nostdin -threads 8  -i "E:/sequence/ED-360-png/%05d.png" -frames:v 15691 -pix_fmt rgb24 -an -sn -vf  scale=out_range=pc -pix_fmt yuv420p10le -strict -1 -vsync 0  -f yuv4mpegpipe - | NVEnc --y4m -i - --fps 25.000 --codec h265 --profile main10 --level auto --tier high --sar 1:1 --lookahead 16 --output-depth 10 --vbrhq 0 --vbr-quality 20.00 --max-bitrate 240000 --gop-len 0 --ref 3 --bframes 0 --no-b-adapt --mv-precision Q-pel --preset default --colormatrix bt709 --cuda-schedule sync --output "E:\Temp\00001_16_45_16_5310_01.265" -
encoding worked fine.
Only real difference is that for my images '-pix_fmt rgb24' is used and for yours '-pix_fmt yuv444p' is used.

Hmm,... with a .jpg image sequence, I can reproduce the issue:
ffmpeg -y -noautorotate -nostdin -threads 8  -i "E:/sequence/jpg/%05d.jpg" -frames:v 430 scale=out_range=pc -pix_fmt yuv444p -an -sn -vf  scale=out_range=pc -pix_fmt yuv420p10le -strict -1 -vsync 0  -f yuv4mpegpipe - | NVEnc --y4m -i - --fps 25.000 --codec h265 --profile main10 --level auto --tier high --sar 1:1 --lookahead 16 --output-depth 10 --vbrhq 0 --vbr-quality 20.00 --max-bitrate 240000 --gop-len 0 --ref 3 --bframes 0 --no-b-adapt --mv-precision Q-pel --preset default --colormatrix bt709 --cuda-schedule sync --output "E:\Temp\00001_new_16_48_55_9910_01.265"
seems like the pix_fmt is the problem,..

-> will look into it.

Cu Selur
DOH, got it for some reason the '-vf' is missing.
-> will fix and report back

Cu Selur
Send you a link to a dev version via PM which should fix the problem.
(you need to recreate the job)

Cu Selur
It works perfectly
Thank you very much

Forum Jump:

Users browsing this thread: 1 Guest(s)