This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

A cookie will be stored in your browser regardless of choice to prevent you being asked this question again. You will be able to change your cookie settings at any time using the link in the footer.

Red Border converting 30fps to 60fps
#1
Windows 10 64bit, Hybrid 2020.05.01.1

I'm trying to use frame interpolation (tried both Avisynth and Vapoursynth) to change a video from 30fps to 60fps, the resulting file seems alright initially but then has a red border after a few seconds.

Pretty sure it's a problem with the source file but I'm not very knowledgeable about this kind of thing, so here's a snippet of the source file:
https://drive.google.com/open?id=108ENP_...z89BD-Tb0w
Reply
#2
I can reproduce the issue here.
First thought it was a bug, but its not.
I culprit for it is this:
Quote:The latest version is: 4.3.0.168 (2019-07-28).

The distribution includes:
  • svpflow1.dll, svpflow2.dll 32-/64-bit plugins for Avisynth and Vapoursynth on Windows
  • svpflow1.so, svpflow2.so 64-bit plugins for Vapoursynth on Linux
  • svpflow1.dylib, svpflow2.dylib 64-bit plugins for Vapoursynth on MacOS
  • sample scripts
  • readme and licenses files
Please note that SVPflow libs require a SVP Manager running (Windows and macOS only), otherwise you'll see a red rectangle around the video frame.

You're free to disable SVP completely ("Temporarily disable SVP" + ui.disable_on_launch = true in All settings), however it still must be running in background.

Download link is there
see: https://www.svp-team.com/wiki/Manual:SVPflow

Previous versions of Hybrid came with an older versions of SVP (since I overlooked that there was an update), where this doesn't happen.
Didn't notice the problem since I tested the newer dlls only on Linux.

Cu Selur

Ps.: attached the dll used previously dlls.
if your copy the 64bit files into your 'Hybrid\64bit\vsfilters\FrameFilter\Interframe'-folder and the 32bit files into your 'Hybrid\32bit\avisynthPlugins'-folder everything should work again.


Attached Files
.zip   svp_4.0.0.128.zip (Size: 1,24 MB / Downloads: 229)
Reply
#3
Awesome, all fixed now, thanks very much for the fast response!
Reply
#4
No problem, happy to help.
Now I just have to think about what to do for the next release of Hybrid. Sad

Should I:
a. drop support for Interframe/SVP
or
b. replace the newer dlls with the older ones.

Not totally sure that the better way would be.

Cu Selur
Reply
#5
I encountered this problem and found this thread.

I have been trying to process a video since last night and have been running into problem after problem blocking me. (Not all problems are Hybrid related.)

Just when I thought I had everything solved I run into this stupid red box around the video.

I downloaded the .dll's attached to the second post (https://forum.selur.net/attachment.php?aid=865), and copied them into the folders as indicated.

Unfortunately, this did not fix the problem for me. Hybrid now crashes when the job is processed in AviSynth. (Switch the dll's back to the "red box" ones and it doesn't crash.)

I guess this project will have to wait. Sad


I double checked the files and I definitely have the 32 bit and 64 bit files in the right directories (verified with sigcheck).


.zip   HybridDebugOutputCrashOldDlls.zip (Size: 19,43 KB / Downloads: 12)


.zip   HybridDebugOutputSuccessExistingDlls.zip (Size: 38,66 KB / Downloads: 15)


p, li { white-space: pre-wrap; }
LoadCPlugin("C:\PROGRA~1\Hybrid\32bit\AVISYN~1\ffms2.dll")
LoadPlugin("C:\PROGRA~1\Hybrid\32bit\AVISYN~1\svpflow1.dll")
LoadPlugin("C:\PROGRA~1\Hybrid\32bit\AVISYN~1\svpflow2.dll")
Import("C:\Program Files\Hybrid\32bit\avisynthPlugins\InterFrame2.avsi")
SetFilterMTMode("DEFAULT_MT_MODE", MT_MULTI_INSTANCE)
# loading source: E:\USER\fin\test\test.mp4
#  input color sampling YV12
#  input luminance scale tv
FFVideoSource("E:\USER\fin\test\test.mp4",colorspace="YV12")
# current resolution: 1312x960
InterFrame(NewNum=60,NewDen=1,OverrideAlgo=23,Cores=16)
# filtering
PreFetch(4)
return last
Reply
#6
I got my video, finally, by rolling back Hybrid to version 2020.02.19.1.

This version also has the bug where it does not set the "Tuning" option in AviSynth, so I had to use a custom script:

LoadCPlugin("C:\PROGRA~1\Hybrid\32bit\AVISYN~1\ffms2.dll")
SetFilterMTMode("DEFAULT_MT_MODE", MT_MULTI_INSTANCE)
# loading source: E:\USER\fin\Test\Test.mp4
#  input color sampling YV12
#  input luminance scale tv
FFVideoSource("E:\USER\fin\Test\TEST.MP4",colorspace="YV12")
# current resolution: 1312x960

# CUSTOM SCRIPT PART - position: AdjustFrameRate - START
function CustomAdjustFrameRate(clip clp) {
  last=clp
  LoadPlugin("C:\PROGRA~1\Hybrid\32bit\AVISYN~1\svpflow1.dll")
  LoadPlugin("C:\PROGRA~1\Hybrid\32bit\AVISYN~1\svpflow2.dll")
LoadPlugin("C:\PROGRA~1\Hybrid\32bit\AVISYN~1\SplineResize.dll")
  Import("C:\Program Files\Hybrid\32bit\avisynthPlugins\InterFrame2.avsi")
  InterFrame(Tuning="Smooth",NewNum=60000,NewDen=1001,OverrideAlgo=23,Cores=16)
}
# CUSTOM SCRIPT PART - position: AdjustFrameRate - END

CustomAdjustFrameRate() # loading custom script content
# filtering
# scaling
Spline144Resize(1440,1080)
# current resolution: 1440x1080
# letterboxing
AddBorders(240,0,240,0)
# Current resolution: 1920x1080
PreFetch(4)
return last

The checksums of svpflow1.dll and svpflow2.dll in Hybrid 2020.02.19.1 match what was posted above by Selur in the second post. (Svpflow1.dll CRC32: 0586759C, Svpflow2.dll CRC32: ABA31676) So I have no idea why those files cause Hybrid 2020.05.01.1 to crash.

The new files are definitely not as "smooth" as the old ones. No idea if that would be different if the "SVP Manager" is running with the new files, and I'm not taking the time to find out! Tongue

I'm on Windows Server 2008 R2 SP1 (i.e., Windows 7), by the way.
Reply
#7
(02.05.2020, 21:03)Selur Wrote: Should I:
a. drop support for Interframe/SVP

I first learned of Hybrid from a popular YouTube tutorial on how to convert to 60 fps using frame interpolation. In fact, there are multiple tutorials that recommend Hybrid for this. I use Hybrid all the time for this and would certainly not be using any new versions that no longer have Interframe.
Reply
#8
So even though I said I wouldn't, I installed the "SVP Manager" and bought the stupid $20 license.

It does indeed make the red box go away.

It also makes the resulting video smooth as with the old dll's. Not sure what's going on there... if it's somehow limited unless the manager is running, or what.

Both the old and new dll's produce videos with artifacts. I would say the new dll's seem to have WORSE artifacting than the old dll's. The video quality also seems better with the old dll's. Not sure if I'm supposed to change anything in the "SVP Manager" or not?


So I feel like the old dll's are definitely better, at least for now.
Reply
#9
Quote:Both the old and new dll's produce videos with artifacts.
You are right.

Quote:I would say the new dll's seem to have WORSE artifacting than the old dll's. The video quality also seems better with the old dll's.
Can't say anything about the quality of the output of Interframe using newer dlls.

Cu Selur
Reply
#10
Any idea why just swapping in the old dll's for me caused Hybrid to crash? Is it a Windows thing? (Not surprising if so!) Tongue
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)