This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

A cookie will be stored in your browser regardless of choice to prevent you being asked this question again. You will be able to change your cookie settings at any time using the link in the footer.

Segmentation fault upon a startup
#11
try the attached version (made a quick fix), will look into it properly after work today and probably release a new version then.

Cu Selur


Attached Files
.zip   Hybrid.zip (Size: 9,6 MB / Downloads: 12)
Reply
#12
Provided that the settings folder lies at ~/.hybrid, moving it didn't help.
The version you provided has the same behavior. Same with the current version.
I am now suspecting something with dependencies... Though it's weird that the older versions (from February + the one you sent me here in May) both worked.
Reply
#13
Strange thing is that no one aside from you has reported this for rev 2020.07.17.1
2020.07.17.1 works fine on my Ubuntu 18.04 and 20.04

If you call Hybrid in a terminal, is there any output?

Cu Selur
Reply
#14
Hi,

maybe it's another Problem with ArchLinux...

ArchLinux QT Version is 5.15 and Selurs Package is build against Qt 5.9.5

And i think, that the complete Package with all tools, the Hybrid Binary is a static linked.

Greetz,
Bitspyer

(20.07.2020, 16:59)Selur Wrote: (...)
If you call Hybrid in a terminal, is there any output?

Cu Selur

No, i got directly a core dump with Hybrid --debug
Reply
#15
The package is only tested and compiled for Ubuntu 18.04 and newer, I doubt it will work on Arch.

Cu Selur
Reply
#16
(29.07.2020, 15:41)Selur Wrote: The package is only tested and compiled for Ubuntu 18.04 and newer, I doubt it will work on Arch.

Cu Selur

It works a long time. I guess it's the diffrence in the Qt Library...
As i wrote, in your complete Zip Package with all tools, i think the Hybrid Binary is static linked. Am i right?

Damn, just overseen that the First Download Package is UPX Packed Version and the Hybrid Binary in the complete Package not...

But still:  this Version is running under Arch without Problems....(from the complete ZIP Package with all tools...)

Bitspyer
Reply
#17
Hmm...

Some tests...
Latest Binary UPX Packed => core dump

Decompressed Binary => runs

Compress Binary again with upx (Version from 23rd Jan 2020) under ArchLinux : All Fine and running.

Maybe broken UPX under Ubuntu?
Do you use 20.04 or 18.04 ?

Edit:

Broken UPX doesnt make sense, because in this case the UPX Package won't run on any Linux....

Greetz,
Bitspyer
Reply
#18
I use 18.04 to build and package the builds.
I'll remove the upx step for the next release if it causes problems.

Cu Selur
Reply
#19
I just installed Ubuntu 18.04 LTS Desktop as Guest in KVM,

after install the qt5-default Meta-Package (you should write this as recommended for Hybrid Wink ), i try to start Hybrid.... => Core-Dump.

I installed upx (upx-ucl, version 3.94-4) and decompressed Hybrid => Working.

Compressed again with upx default settings (upx Hybrid) => Core-Dump again.

Second Test with Ubuntu 20.04

Installed qt5-default and libqt5multimedia5 (recommended for Hybrid), downloaded Hybrid => Core-Dump

Installed upx (3.95-2), decompressed Hybrid => Working

Compressed again with upx default settings => Working

Copied to ArchLinux => Working (upx compressed)

Conlosion: upx under 18.04 creates broken Binaries.

Hope this helps in this special case.....

SeeYa
Bitspyer
Reply
#20
Strange thing is that the compressed version works fine on the build systems.
-> I'll remove the upx compression in the next release.

Cu Selur
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)