This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

A cookie will be stored in your browser regardless of choice to prevent you being asked this question again. You will be able to change your cookie settings at any time using the link in the footer.

Crash when using qaac encoder
#1
When I try to use qaac to encode the audio, the log returns the following error message:
-> 18_41_50_3410_02_audio crashed: ERROR: D:\Projects\temp\iId_2_aid_0_lang_en.aac was not created!
Aborting '18_41_50_3410_02_audio' due to: ERROR: D:\Projects\temp\iId_2_aid_0_lang_en.aac was not created!

Using other encoders for aac like fdkaac or neroaac everything works fine.
I also already have the qtfiles folder to use qaac in portable mode.
I can use it well in other GUIs, but for some reason, it is not working for me in hybrid.

Thanks for any help.
Reply
#2
1. Works fine here, you are not sharing any useful details.
2. You share parts of a log which starts with:
Quote:This log is only intended for user information. It should not be part of a bug/problem report!!
3. You did not read the '[INFO] Infos needed to fix&reproduce bugs,..'-sticky or simply ignored it.
-> Sorry, but I won't spend time on this.

Cu Selur
Reply
#3
Sorry, I forgot to give you some details.

OS is Windows 10 x64 v1909.
All I did was set some x264 parameters, resize and apply spline36 and sharp filter. Also set to encode the audio in aac using qaac at 160kpbs in cvbr mode.

I'll leave the debug logs below.

Regards


Attached Files
.7z   debug.7z (Size: 11,37 KB / Downloads: 3)
Reply
#4
What happens if you call:
"C:\Hybrid\64bit\ffmpeg.exe" -y -threads 4 -loglevel fatal -nostdin -i "C:\Projects\temp\iId_4_aid_0_lang_ja_DELAY_-44ms_13_01_28_3610_01.flac" -ac 2 -ar 48000 -acodec pcm_s24le -f wav - | "C:\Hybrid\64bit\qaac.exe" --no-delay --threading --cvbr 160 - -o "C:\Projects\temp\iId_4_aid_0_lang_ja.aac"
according to the log that call simply crashes,...


Cu Selur
Reply
#5
Yeah, that's right. It crashes and the job queue stops, saying that the aac file wasn't created.

I tried to get more information by changing the debug to level 9.
So I found this error message:
Qaac output: ERROR: CoreAudioToolbox.dll: The specified module could not be found.
process finished with exitcode: 2 and exitStatus: 0
Any idea what that might be?

I think it's no problem with dependencies, because when hybrid checks for them, the debug log says:
Checking for qaac / Apple Application Support in the registry,...
Checking for HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Apple Inc.\Apple Application Support
-> InstallDir:
Checking for HKEY_LOCAL_MACHINE\SOFTWARE\Apple Inc.\Apple Application Support
-> InstallDir:
looking for portable qaac version tools,..
path to qaac: C:\Hybrid\64bit\qaac.exe
checking for qtfiles folder: C:\Hybrid\64bit\qtfiles
-> found everything needed for qaac support

Confused
Reply
#6
Hybrid only checks if the files are there, but it does not check that the files in your portable folder match your qtaac file.
My guess is that you mixed 32bit and 64bit files.

Cu Selur
Reply
#7
That's not the case.
All files in the portable folder were extracted from iTunes64Setup.exe using makeportable batch file. From there I just renamed the 'QTfiles64' folder to 'qtfiles' and moved it next to the qaac file. The qaac executable itself is also 64bit (already included in hybrid).
In addition, using qaac in CLI everything goes well. So I guess there's no problem with the files.

Any other guess? Huh
Reply
#8
03.05.2019  01:55            80.696 ASL.dll
03.05.2019  01:55         9.039.672 CoreAudioToolbox.dll
03.05.2019  01:55         2.229.560 CoreFoundation.dll
03.05.2019  01:55        27.159.352 icudt62.dll
03.05.2019  01:55           104.760 libdispatch.dll
03.05.2019  01:55         2.457.912 libicuin.dll
03.05.2019  01:55         1.579.320 libicuuc.dll
11.06.2011  01:15           608.080 msvcp100.dll
17.03.2016  22:54           639.808 msvcp140.dll
11.06.2011  01:15           829.264 msvcr100.dll
03.05.2019  01:55           237.368 objc.dll
17.03.2016  22:54            89.416 vcruntime140.dll
are the files the Hybrid/64bit/QTfiles64 folder here that work fine.

Cu Selur
Reply
#9
I saw where the problem was, the name of qtfiles folder.
Searching on how to integrate qaac portable support in hybrid, I found this post you made in hybrid's thread on the VideoHelp website:
https://forum.videohelp.com/threads/3451...ost2337288
So I thought the right thing to do would be to rename the 'QTfiles64' folder to 'qtfiles', which was causing the crash.
Then, it's solved.

My apologies for the mistake and thank you for your patience trying to help me with this. I really appreciate that. Smile
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)