This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

A cookie will be stored in your browser regardless of choice to prevent you being asked this question again. You will be able to change your cookie settings at any time using the link in the footer.

Possible 2 bugs in Linux & vapoursynth
#11
lol, adjusted the git accordingly.
just called the build-plugins script and vslsmashsource compiled, nice!
Now there's only, mvtoolssf, nnedi3cl and eedi3m which fail atm. Smile

Cu Selur

Ps.: I'm happy that someone shows some interest in this. Thanks! Smile
Reply
#12
Hi,

Could you tell me me more about the bug(s) into the plugins mvtoolssf, nnedi3cl and eedi3m ?
Eventually, it's possible I may help you; I have a little bit more time these days with the teleworking.

For me, no problem to compile, and no crash in running (maybe special parameters ?) for
nnedi3cl : interlacer, Yadifmod, force & 100%, parameters 0/0/NNEDI3CL/0. The result seems
fine on an interlacer video sample.

For eedi3m, I suppose it's VapourSynth, Line, AntiAliasing, Nedi3AA (not sure ?), OpenCL,
device 0 or -1 ? No problem with this, but I can't see any effect on my video.

I have not tested mvtoolssf.

Alain
--
Reply
#13
Haven't really looked at it myself and basically on my way to bed atm. but I attached the logs of the tools that failed.
May be you see the problem.

Cu Selur


Attached Files
.zip   logs.zip (Size: 4,05 KB / Downloads: 6)
Reply
#14
Good news:
I reset my build system and now only 'mvtoolssf' fails. Smile

Cu Selur


Attached Files
.zip   mvtoolssf.zip (Size: 531 bytes / Downloads: 5)
Reply
#15
Okay, build fails due to the switch to meson, but I have no clue how to get it working again.
My guess is it should be something along the lines of
ghdl IFeelBloated/vapoursynth-mvtools-sf
CFLAGS="$CFLAGS -Wno-deprecated-declarations" meson build --prefix="$vsprefix"
ninja -C build -j $JOBS
but I don't know how to extend this properly to make it working like it. :/

Cu Selur
Reply
#16
Hi,

I confirm all plugins compile without any problem with 20.04 LTS and 18.04 LTS, fresh install, except
waifu2x, which needs CUDA.

It's possible meson, and it's Python3 dependencies, is installed more than one time on your machine ?
Same for ninja, which exists in a very old version in /usr/bin ?

It's possible PYTHONPATH is not correct. You use pip3 install -q --upgrade --user,
so PYTHONPATH may include
$HOME/.local/lib/python3.8/site-packages
(I'm not really sure).

I will see mvtoolssf problem.

Al1
--
Reply
#17
You might be right with the python&Co paths on my old build system, but seems to be working on the new one. Smile

Quote:I will see mvtoolssf problem.
I keep my fingers crossed. Smile

Cu Selur
Reply
#18
Hi,

I have some errors now.

1. The script build-vapoursynth.sh seems broken at the end.
export PYTHONUSERBASE="$PWD/temp"
pip3 install -q --user cython
./temp/bin/cython --3str src/cython/vapoursynth.pyx
pip3 uninstall -y -q cython

Normal: my distrib 20.04LTS has a global python3 package Cython, or I have installed previously
for all users in the site-package /usr/lib/python3.

pip3 install --user cython
Requirement already satisfied: cython in /usr/lib/python3/dist-packages (0.29.14)
./temp/bin/cython
./temp/bin/cython: Command not found.

Maybe use

export PYTHONUSERBASE="$PWD/temp"
pip3 install -q -I --user cython
./temp/bin/cython --3str src/cython/vapoursynth.pyx
pip3 uninstall -y -q cython

2. build-plugins/header.sh has lost 2 functions, mkghc () and ghc().
The original build-plugins/plugin-mvtoolssf.sh is

mkghc IFeelBloated/vapoursynth-mvtools-sf libmvtoolssf 5dfa8756092daa7dcc635eef799c6964bd40c259

3. So, I have tried your 3 lines

ghdl IFeelBloated/vapoursynth-mvtools-sf
CFLAGS="$CFLAGS -Wno-deprecated-declarations" meson build --prefix="$vsprefix"
ninja -C build -j $JOBS

and I have this time the same error than you:

Run-time dependency vsfilterscript found: NO (tried pkgconfig and cmake)

meson.build:15:0: ERROR: Dependency "vsfilterscript" not found, tried pkgconfig and cmake

Your old code

mkghc IFeelBloated/vapoursynth-mvtools-sf libmvtoolssf 5dfa8756092daa7dcc635eef799c6964bd40c259

works perfectly with the old commit 5dfa...

So, I'm too tired (1:40 AM here in France) and I'm sleeping, but I have a (very simple) theory.

If the package
IFeelBloated / vapoursynth-mvtools-sf
https://github.com/IFeelBloated/vapoursynth-mvtools-sf
needs now the package
IFeelBloated / vsFilterScript
https://github.com/IFeelBloated/vsFilterScript
?

This last package seems not to be in your scripts; it explains the new meson dependency in mstools-sf...

All the best & good night,

Alain
--
Reply
#19
Quote:This last package seems not to be in your scripts; it explains the new meson dependency in mstools-sf...
Wasn't a dependency before.
-> Adjusted the script and now mvtools-sf is working again.
(committed the current working version)

Thanks a lot!

Cu Selur
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)