This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

A cookie will be stored in your browser regardless of choice to prevent you being asked this question again. You will be able to change your cookie settings at any time using the link in the footer.

[HELP] Unwanted change of contrast
#1
Windows 10 64Bit
Hybrid 2020.08.02.1

When I do simple encoding using x264 I see that contrast of my output video changes. I haven't used any filters etc.  That contrast change is more noticeable when watching actual video  

Top image is original. Bottom after conversion.Please, read the 'Infos needed to fix&reproduce bugs,..'-sticky before you post about a problem.Please, read the 'Infos needed to fix&reproduce bugs,..'-sticky before you post about a problem.Please, read the 'Infos needed to fix&reproduce bugs,..'-sticky before you post about a problem.

   

.zip   HybridDebugOutput.zip (Size: 23,27 KB / Downloads: 7) Please, read the 'Infos needed to fix&reproduce bugs,..'-sticky before you post about a problem.
Reply
#2
It looks like video vs full levels problem in source vs rendered file. Try to experiment with these settings:

[Image: IEgEw8J.jpg]
[Image: BVJonyz.jpg]

It could be also gamma shift problem due color managed vs non color managed video player and some proper or missing gamma/Color tags in video file. https://forum.blackmagicdesign.com/viewt...1&t=101253
Try to turn of "Adjust Color... to input" and set manually Color Primaries, Transfer Characteristics and Color Matrix to bt709
[Image: DoxdoVd.jpg]
Reply
#3
(20.08.2020, 22:46)shijan Wrote: It looks like video vs full levels problem in source vs rendered file. Try to experiment with these settings:

Thank you for your comment. It helped when I set "Luma range" to "TV" or "Auto" 

Even un-ticking "Luma Range" solved the problem.

As you suggested it is player related. I played the output file using VLC and noticed increased contrast however the same file imported to Adobe Premiere looked OK. 

Thanks for help.
Reply
#4
By default Hybrid passes through the luma range (tv/pc) from the source if the luma range of the source is wrongly flagged or detected this problem occurs. (It also can happen if the player used simply ignores the flag.)

Looking at the info of the source sample you shared with me:
colour_description_present               : Yes
colour_description_present_Source        : Container / Stream
Color range                              : Limited
colour_range_Source                      : Container
colour_range_Original                    : Full
colour_range_Original_Source             : Stream
Color primaries                          : BT.709
colour_primaries_Source                  : Container / Stream
Transfer characteristics                 : BT.709
transfer_characteristics_Source          : Container / Stream
Matrix coefficients                      : BT.709
matrix_coefficients_Source               : Container / Stream
Codec configuration box                  : avcC
One can see that the stream is flagged 'PC/Full'-scale, but the container is flagged 'TV/Limited' luma scale.
This is problematic, since this will cause problems with various players, since some will use the stream flag and others will use the container flag.
Atm. Hybrid takes the flag of the container, since this is the flag that should have been set last.
-> I'll add an option to the next release to select whether the stream (Original) scale should be preferred during the analysis.

Atm. when doing no filtering, your problem should be fixed if you simply disable the 'Adjust->Color->Range' and
then set the 'Luma range' to pc range.

Disabling the 'Luma range' filtering is a bad idea, since it gives even more uncertainty to what will happen on playback.

Cu Selur
Reply
#5
My files come from GoPro camera and they look normal when I play them using VLC on Windows 10

(21.08.2020, 05:31)Atm. when doing no filtering, your problem should be fixed if you simply disable the \Adjust->Color->Range Wrote: then set the 'Luma range' to pc range.


I disabled "Adjust Color->Range" however when I set "Luma Range" to PC I get high contrast on VLC. It looks OK when I set it to TV. Are these settings OK?

   
Reply
#6
(Assuming you didn't do any range conversion or changed the levels.)
That depends,...
colour_description_present_Source        : Container / Stream
Color range                              : Limited
colour_range_Source                      : Container
colour_range_Original                    : Full
if the container (= Color range 'Limited') is correct: Yes
if the stream (= Color range 'Full') is correct: No

Cu Selur
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)