This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

A cookie will be stored in your browser regardless of choice to prevent you being asked this question again. You will be able to change your cookie settings at any time using the link in the footer.

Avisynth preview error:
#11
1. load source
2. QTGMC (Avisynth)  set "refined"
3. Press Avisynth Preview + 'Filter view enabled'
My config
Avisynth 32 bit
No Avisynth during CropView: enable
No Avisynth during Preview: disable


Attached Files
.zip   HybridDebugOutput.zip (Size: 3,82 KB / Downloads: 3)
Reply
#12
Quote:1. load source
2. QTGMC (Avisynth) set "refined"
3. Press Avisynth Preview + 'Filter view enabled'
My config
Avisynth 32 bit
No Avisynth during CropView: enable
No Avisynth during Preview: disable
I tried to reproduce the issue by:
  1. Starting Hybrid
  2. Changing 'Filtering->Support' to 'Avisynth'
  3. Loading a an interlaced source (using Base->Open File)
  4. Setting 'Filtering->(De-)Interlace/Telecine->QTGMC Avisynth->Preset' to 'Custom'
  5. Setting 'Filtering->(De-)Interlace/Telecine->QTGMC Avisynth->Source matching' to 'refined'
  6. Enabling 'Filtering->Filter view'
  7. Pressing the 'Filtering->Avisynth preview'-button and waiting,...
  8. Avisynth Preview didn't open and the normal log showed:
    Avisynth preview error: -> Could not allocate video frame. Out of memory. memory_max = 1073741824, memory_used = 1046798796 Request=13187072 -> Could not allocate video frame. Out of memory. memory_max = 1073741824, memory_used = 1049401036 Request=13187072 -> Could not allocate video frame. Out of memory. memory_max = 1073741824, memory_used = 1049401036 Request=13187072 -> Could not allocate video frame. Out of memory. memory_max = 1073741824, memory_used = 1049401036 Request=13187072 -> Could not allocate video frame. Out of memory. memory_max = 1073741824, memory_used = 1049401036 Request=13187072 -> Could not allocate video frame. Out of memory. memory_max = 1073741824, memory_used = 1049401036 Request=13187072 -> Could not allocate video frame. Out of memory. memory_max = 1073741824, memory_used = 1049401036 Request=13187072 -> Could not allocate video frame. Out of memory. memory_max = 1073741824, memory_used = 1049401036 Request=13187072 -> Could not allocate video frame. Out of memory. memory_max = 1073741824, memory_used = 1049401036 Request=13187072 -> Could not allocate video frame. Out of memory. memory_max = 1073741824, memory_used = 1049401036 Request=13187072  could not get PVideoFrame data (0)
  9. Disabling 'Filtering->Filter view' and pressing the 'Filtering->Avisynth preview'-button while looking at the windows taks manager showed that avisynth was using ~1.8GB of RAM.
    Using Avisynth 64bit with 'Filtering->Filter view' enabled showed that avsViewer requires 47010,4MB of RAM.
    -> Nothing I can do about this 32bit applications simply can't use those settings and allocate that much RAM.
    So, how about changing the settings?
    Settings EdiThreads to 1 didn't lower the RAM usage, so that probably doesn't really help.
    Disabling MT lowered RAM usage to 2GB on 64bit and to 1GB on 32bit. (1.2 GB with EdiThreads at 2)
    => Disabling MT by enabling 'Filtering->Avisynth->Misc->Miscellaneous->Disable MT' works fine here.
    (there might be other ways to lower the RAM usage by changing other options)

    Good thing is I did find that I forgot to copy some files to the 64bit avisynthPlugins folder.Smile
    -> I'll compile a new dev version (+ send you a link via PM once the build is ready an uploaded).
    So, you can either use 64bit Avisynth (which lacks a few filters which are not available as 64bit versions) or stick with 32bit Avisynth and disable MT.

    Cu Selur
Reply
#13
Quote:Here's the promised link to a current dev version with which I used Avisynth 64bit and your settings:
using Avisynth 64bit: when press :Crop view" or  "Avisynth preview" appears error

Quote:LoadPlugin-Error: 'C:\Program Files\Hybrid\64bit\Avisynth\avisynthPlugins\nnedi2.dll' does not exist!
I try uncheck "Resizer" box or set another plugin - does not help.
"Preview/CropView:" not working (preview window appears and closed)  in both modes: check or uncheck Crop view: box.
Disabling MT does not help.

using Avisynth 32bit: the same problemsю
Disabling MT does not help.


Attached Files
.zip   HybridDebugOutput.zip (Size: 14,87 KB / Downloads: 7)
Reply
#14
Accidentially compiled and uploaded an old version. :/
-> will send you a new link in a few minutes.
If that dev version doesn't help I have no clue since I can't reproduce the issue with the settings I mentioned.
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)