This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

A cookie will be stored in your browser regardless of choice to prevent you being asked this question again. You will be able to change your cookie settings at any time using the link in the footer.

[BUG] Various bugs with latest dev build (2020.09.25-21270)
#1
Bug 
- In Vapoursynth, QTGMC is broken. An error is reported that C:\Program Files\Hybrid\64bit\vsfilters\Support\libfftw3f-3.dll is missing. Which it is. I can copy it in from C:\Program Files\Hybrid\64bit\Avisynth\avisynthPlugins and it will work. But not sure if this is supposed to be the same one.

- The AviSynth64 previewer crashes. It does output files though. I included a log for this:

.zip   HybridDebugOutput.zip (Size: 19,45 KB / Downloads: 20)

Faulting application name: avsViewer64.exe, version: 0.0.0.0, time stamp: 0x5e7be927
Faulting module name: AviSynth.dll, version: 3.4.0.0, time stamp: 0x5dbf3d81
Exception code: 0xc0000005
Fault offset: 0x00000000000871f6
Faulting process id: 0x1558
Faulting application start time: 0x01d69477d4578dc3
Faulting application path: C:\Program Files\Hybrid\64bit\Avisynth\avsViewer64.exe
Faulting module path: C:\Program Files\Hybrid\64bit\Avisynth\AviSynth.dll
Report Id: 126c11d3-006b-11eb-a978-0050560b8935

- Not a bug, just a note... my request to add Match preset / Match preset 2 / Match enhance for QTGMC should also work for Vapoursynth. Handling of those presets is in the C:\Program Files\Hybrid\64bit\vsscripts\havsfunc.py script. I tested it via custom script and it works. Consider adding it!  Wink
Reply
#2
Bug 
- For QTGMC progressive options, if Input Type = 1, 2, or 3, then QTGMC will always be inserted into the script, even if the "Auto" check box is cleared. The only way to remove QTGMC from the script is to enable the "Auto" check box, then change the Input Type back to 0. Expected behavior is on progressive input video, QTGMC will be removed from scipts if "Auto" check box is cleared (even if Input Type is set to 1, 2, or 3 for progressive options).

This affects AviSynth32 and 64, as well as Vapoursynth.
Reply
#3
Quote:C:\Program Files\Hybrid\64bit\vsfilters\Support\libfftw3f-3.dll is missing.
you are correct, copying the one from "Hybrid\64bit\Avisynth\avisynthPlugins" is okay.

Quote:The AviSynth64 previewer crashes.
Sadly, no clue what's causing the crash, works fine here and we use the save file versions. :/
Looks like initializing the AviSynth.dll fails.
Does this happen with all files for you?

Quote:my request to add Match preset / Match preset 2 / Match enhance for QTGMC
probably not happening atm.
Quote:For QTGMC progressive options, if Input Type = 1, 2, or 3, then QTGMC will always be inserted into the script, even if the "Auto" check box is cleared. The only way to remove QTGMC from the script is to enable the "Auto" check box, then change the Input Type back to 0. Expected behavior is on progressive input video, QTGMC will be removed from scipts if "Auto" check box is cleared (even if Input Type is set to 1, 2, or 3 for progressive options).
If you set QTGMC to input type != 0 you tell Hybrid to treat it like any other filter, thus Hybrid will add it.
if you disable 'Auto', deinterlaced switched to 'Yadif - fast'.
-> only way to make this more user friendly would be to:
a. remove 'Input Type' != 0 from the (De-)Interlacer support
b. add QTGMC to the denoise filters where it will only allow input type != 0
-> this will take a while to implement since QTGMC has tons of options

Cu Selur
Reply
#4
I splitted QTGMC into:
- QTGMC Deinterlacer under Deinterlacing (only InputType = 0)
- QTGMC Filter under DeNoise (only InputType > 0)
this should fix the problems you have.
Might cause lots of new problems, since I probably somewhere might have made a typo. Smile

-> send you a link to my current dev via PM for testing.

Cu Selur
Reply
#5
QTGMC with InputType > 0 in denoise filters group looks like logical way to go
Reply
#6
(27.09.2020, 09:09)Selur Wrote: Sadly, no clue what's causing the crash, works fine here and we use the save file versions. :/
Looks like initializing the AviSynth.dll fails.
Does this happen with all files for you?

Yes. Sad

I can run avsViewer64.exe directly. It doesn't crash, but of course it doesn't load anything. Since the regular file output works, it seems there's something weird with just the 64 bit viewer. It generates a .ffindex file in C:\Users\Administrator\AppData\Local\Temp, then crashes. 32 bit viewer works fine.

I know debugger stuff is generally useless, but I did try running it through x64dbg. The logs generate these strings when it crashes:

DebugString: "QObject::disconnect: Unexpected nullptr parameter"
DebugString: "QCoreApplication::postEvent: Unexpected null receiver"

Maybe it's trying to open the wrong file name, or from the wrong location?



(27.09.2020, 09:09)Selur Wrote: probably not happening atm.

At some point hopefully! I see you added them to the QTGMC Vapoursynth options on the denoise tab. Smile



(27.09.2020, 14:19)Selur Wrote: I splitted QTGMC into:
- QTGMC Deinterlacer under Deinterlacing (only InputType = 0)
- QTGMC Filter under DeNoise (only InputType > 0)
this should fix the problems you have.
Might cause lots of new problems, since I probably somewhere might have made a typo. Smile

It did. Wink

For AviSynth, the QTGMC section on the Denoise tab seems to work OK.

However, on the "Deinterlace" tab for AviSynth32/64, no deinterlacing options get inserted into the AviSynth script, regardless of what deinterlacer is selected (including QTGMC), and regardless if the "Overwrite input scan type" is used. It won't work on actual interlaced files, or on interlaced or progressive files with "Overwrite input scan" set to "top field first" or "bottom field first".

Clicking the script button for Vapoursynth shows a popup message, "Couldn't find filters for category: QTGMC". It does seem to work however for the Deinterlacing tab.

For the QTGMC options on the Denoise tab for Vapoursynth, the "Input Type" is missing. (Should be 1, 2 or 3 options available.) Enabling QTGMC here and clicking the script button again shows the "Couldn't find filters for category: QTGMC" message, but, nothing for QTGMC gets inserted into the Vapoursynth script.

I should have made my user name "Worm can opener". Tongue
Reply
#7
Regarding the script preview: try resetting your defaults, works fine here.

Will look into why forcing the deinterlacing by overwriting the scan type doesn't work.
Reply
#8
For me, script preview for Vapoursynth works for Deinterlace tab. QTGMC option on Vapoursynth denoise tab does not.

The reverse is true for AviSynth.

Script preview for AviSynth does not work for any deinterlacer on Deinterlace tab. Interlaced input file, or force deinterlacing does not work. I did try resetting all defaults and it still did not work. (Actually, I always delete the C:\Users\Administrator\AppData\Roaming\hybrid folder before running any new release. I also remove or rename the existing C:\Program Files\Hybrid folder before installing a new version, so a new version is never installed into or on top of an existing version.)
Reply
#9
Both work fine here.
-> I'll send you another link in a few minutes via pm

Cu Selur
Reply
#10
Everything seems fine now, except for my avsViewer64.exe crash.

On September 5, I reported an error in Hybrid (it's still in the official download one) where Hybrid would not switch to the 64 bit viewer in AviSynth64 mode, and give an error, "Cannot load a 64 bit DLL in 32 bit Avisynth". You fixed this. I didn't post back about this, but I distinctly remember running the 64 bit viewer after this fix, and it worked.

So now, it crashes. I just assumed it was this latest build or something, but if I re-install the earlier build where this was fixed, that now crashes too.

I can't find any info on avsViewer64.exe via Internet search. It's not a Hybrid issue, because it crashes if I try loading it outside of Hybrid. Running the exe will load the viewer OK, but when I try to load any script via --input, it now crashes.

I have no idea why, so I guess that's the end of the 64 bit AviSynth viewer on this particular system. It could be some dependency dll got replaced by something I installed, but I have no idea what. It's a hidden needle in the haystack and I have no idea where to look.

Frustrating!

Does it use any particular C++ library that I could maybe try re-installing?



It crashes if I run directly:

[Image: HXF0q1c.png]


If I run it through x64dbg, it doesn't crash, but it doesn't load the video either:

[Image: gysxBCH.png]
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)