This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

A cookie will be stored in your browser regardless of choice to prevent you being asked this question again. You will be able to change your cookie settings at any time using the link in the footer.

[BUG] Various bugs with latest dev build (2020.09.25-21270)
Tried everything I could think of... tried different versions of AviSynth.dll, ffms2.dll, sfc /scannow, chkdsk, reboot, etc. Same crash every time. The GUI can start. If I comment out ffms2.dll it does open the GUI and the command window reports "There is no function named 'FFVideoSource'", if I try to load the 32 bit ffms2.dll it also opens the GUI and the command window reports "Cannot load a 32 bit DLL in 64 bit Avisynth", so it seems the GUI and error checking functions work. The crash must come when either ffms2.dll is loaded or the video file tries to open. It's every video file I've tried, which all work in the 32 bit AviSynth Viewer.

Could it be my desktop size? It's not wide screen but it is color calibrated, which is why I prefer it for photo and video work.

Do you have a Windows 7 x64 or Windows Server 2008 R2 VM to try this on?

I'm working on something right now where AviSynth32 is just way too slow, so I figured I could use the 64 bit version... but this stupid crash in the previewer is now happening! Tongue
To identify whether FFVideoSource is the cuprint, have you tried enabling "Filtering->Misc->Sourcefilter Settings->LibavVideoSource" ?
You can also try "Filtering->Misc->Sourcefilter Settings->Use L-Smash for mp4 input".

Try whether using the latest version from:

Quote:Could it be my desktop size? It's not wide screen but it is color calibrated, which is why I prefer it for photo and video work.
Nope, resolution and calibration of the display have no influence of ffms2.

Also if you can share a small sample of a file this crashes with I can check whether it also crashes here.
Don't have any Windows 7 or Windows Server 2008 R2 VM running anywhere.

Cu Selur
I should have mentioned that. Yes, I tried L-Smash. It still crashes. I suspect it's when it loads the input file. Seems to be any file, mpg as well.

Dang!  Confused

Could be a problem with it running on Win7. Even though I seem to remember it running without crashing before, I could be wrong. I don't trust my memory. Tongue 

Here's a file:

Anyone out there on Win7 x64 who can see if they can preview videos in Hybrid with AviSynth64? Tongue
# loading source: C:\Users\Selur\Desktop\S01E01 - Hired.mp4
#  color sampling YV12@8, matrix: bt601, scantyp: progressive, luminance scale: limited
# current resolution: 852x480
# filtering
return last
works fine here. (same when using LWLibavVideoSource or LSMASHVideoSource)

-> try the other ffms2 version, the one on mediafile is from 2016 and should even work with Windows XP,...

Also check if you have a system wide Avisynth install on your system, may be that is interfering,..?
I tried a bunch of different ffms2 versions, including the 2016 one. No effect.

Only AviSynth on my system is in the Hybrid folder.

This may or may not be the problem:

Here's Dependency Walker for 32 bit avsviewer.exe, which works for me:

[Image: kM0rXtf.jpg]

Here it is for 64 bit avsviewer64.exe, which crashes:

[Image: N9G7ape.jpg]

These 5 Microsoft dll's are in the Hybrid directory for 32 bit:


They are dated 07/16/2015, and are version 10.0.9924.0, except for locale, which is 07/16/2015 and version 10.0.10240.16384

They are NOT in the directory for AviSynth 64 bit. On my system, Dependency Walker shows that they are being linked from the Windows\System32 directory.

The 5 files I have in that directory are dated 04/12/2019, and are all version 10.0.14393.2990.

I tried some different versions of these files (putting them in the Hybrid\64bit\Avisynth folder and making sure Dependency Walker shows that they are being linked to avsviewer64.exe) and it still crashes.

To be sure, can you maybe just send me or post to google drive the 5 files that you have on your system so I can see if that's the issue? You can use Dependency Walker to verify which files avsviewer64 is actually linking and using.

Actually, I'm not sure if that will really have any effect. I suspect you might have some Windows 10 only API calls in avsviewer64.exe. Not sure if there is a way you can check this?

I found this, which may be or may not be relevant:

I know Dependency Walker results can often be misleading, which I suspect is probably the case here.
When looking at 64bit dll you should use 64bit Dependency Walker (
Aside from the dependencies that are in the folder avsViewer64bit does rely on
I would not recommend to replace those in your system.

I suspect that it's not avsViewer64.exe itself that is missing some dependencies, but one of the filters.

-> Check if you can start avsViewer64.exe (double clicking on it, should open it) or do you get an error.

Cu Selur

Attached Files Thumbnail(s)
(That is actually both 64 bit Dependency Walker and 32 bit Dependency Walker in my screenshots. Wink )

Yes, I can just double click avsviewer64.exe and the GUI opens. It also opens if a script loads incorrectly, including if there's a typo in the file name or directory path in the avs script. In that case. the GUI opens and the command window shows -> FFVideoSource: Failed to open 'E:\USER\viewer\non_existent_file.mp4. The script is only trying to load the video, so the only dll being loaded is ffms2.dll. I would tend to think if the crash happens when the dll is loaded, then it would crash at that point. But it tries to load the video, opens the GUI, can't find the video, and returns the error, which is all correct behavior. It does create the cache file: cachefile="E:\USER\viewer\test.ffindex" The 32 bit viewer (which works) creates test.ffindex at 62,703 bytes, while the 64 bit viewer (crashes) creates test.ffindex (for the same file) at 60,761 bytes. So, the crash seems to be happening after it creates the .ffindex then tries to load the video file data to the viewer.

Again, AviSynth64 does work for me and Hybrid creates correct output. Just the 64 bit viewer crashes.

[Image: Z7cRvLG.jpg]
The thing it avsViewer64 seems to work, if it opens the problem can't be missing dependencies of avsViewer64. Wink

So my guess is still that the problem is related with either:
a. access rights (or some virus scanner or similar interfering)
b. ffms2

-> did you test the different ffms2 versions?
I only have Windows Defender running. I tried disabling real time protection but it didn't help.

If ffms2.dll were an issue it seems it would also crash when creating output files. But only the 64 bit viewer crashes.
Problem is:
a. I can't reproduce the issue.
b. Since avsViewer64 starts, it's no dependency issue with avsViewer64

That avsViewer does use slightly different script than the script for the encoding.
Difference it for the preview RGB is used as output color space instead of the color space the encoder needs, but the script from the debug output:
# loading source: E:\USER\fin\test1.mp4
#  color sampling YV12@8, matrix: bt709, scantyp: progressive, luminance scale: limited
# current resolution: 1440x1080
# filtering
# adjust color to RGB24
return last
does work fine here. Sad

-> I have no clue where the issue is,....

Forum Jump:

Users browsing this thread: 1 Guest(s)