This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

A cookie will be stored in your browser regardless of choice to prevent you being asked this question again. You will be able to change your cookie settings at any time using the link in the footer.

Preview uncompressed RGB source doesn't work
#31
Okay, now you switched to Avisynth and your source has 19.18fps?
Looking at the debug output I see the problem:
....
# filtering
# denoising filtering using QTGMC
SourceFiltered = Source
SourceFiltered = SourceFiltered.ConvertToYV24(interlaced=false, matrix="PC.601")
SourceFiltered = SourceFiltered.QTGMC(Preset="Fast", InputType=1, TR2=1, Sharpness=1.0, SourceMatch=0, Lossless=0, ediThreads=2)
SourceFiltered = SourceFiltered.
the 'SourceFiltered = SourceFiltered.' like shouldn't be there,...
Problem is I can't reproduce this here.
I always get:
SourceFiltered = Source
Source = Source.ConvertToYV24(interlaced=true, matrix="PC.601")
Source = Source.AssumeTFF()
Source = Source.QTGMC(Preset="Fast", InputType=0, TR2=0, Sharpness=1.0, SourceMatch=0, Lossless=0, ediThreads=2, PrevGlobals="Reuse")# added PrevGlobals="Reuse" to handle multiple QTGMC instances
SourceFiltered = SourceFiltered.ConvertToYV24(interlaced=true, matrix="PC.601")
SourceFiltered = SourceFiltered.AssumeTFF()
SourceFiltered = SourceFiltered.QTGMC(Preset="Fast", InputType=0, TR2=0, Sharpness=1.0, SourceMatch=0, Lossless=0, ediThreads=2, PrevGlobals="Reuse")# added PrevGlobals="Reuse" to handle multiple QTGMC instances
when using Custom QTGMC in Bob-mode and Avisynth Filter View.
It seems like a portion of the script is missing.
-> I need a detailed step-by-step guide what you do, to reproduce this.

Also you are not using the last dev version I send you a link too,.. (I send you 2020.11.13.1 you used 2020.11.12.1)

Cu Selur
Reply
#32
Crash on another video stream.(Sorry I provided wrong debug file in my previous post).
This time just attempt to activate filter viewer (both Avisynth and Vapoursynth) caused a crash.
Sample video:
https://drive.google.com/file/d/12Lv6Pur...sp=sharing


Attached Files
.zip   HybridDebugOutput.zip (Size: 91,05 KB / Downloads: 6)
Reply
#33
When I open your source here Hybrid by default uses LSMASHSoure
Did you disable Prefer LSMASHSoure over LLibAVSource for mp4/mov'?
With LSMASHSoure the preview works fine, when I disable the option and Hybrid then uses 'LWLibavSource'.
Using FFMpegSource2 the preview works too.
Seems like 'LWLibavSource' crashes while trying to analyze your source. My guess is that it's related to the time codes in the file since the time code count doesn't match the frame count. There are 1759 time codes, but 3517 frames in the source.
Assuming you have a graphic card which supports AVC decoding you can enabled 'Libav hardware decoding' by setting it to a mode > 0, which mode depends on your equipment. This way the hardware decoder is used which will simply ignore the missing time codes. To be sure Hybrid doesn't try to add the broken time codes to the output you should either enable 'Config->Input->Decoding->CFR output' or 'Config->Internals->Ignore all input timecodes' before loading the source.
-> This is not a bug in Hybrid, that is you feeding broken content to Hybrid.
----
Remember that I still need a step-by-step of what you are doing to reproduce the problem from the previous post.

Cu Selur

Ps.: Haven't looked at Avisynth, but the problem is probably the same.
Reply
#34
I did not disable Prefer LSMASHSoure over LLibAVSource for mp4/mov (I even do not have an idea where this option is).
My graphic card doesn't support AVC decoding.
Enabling 'Config->Input->Decoding->CFR output' - doesn't help.
'Config->Internals->Ignore all input timecodes' - "Flter view" sometime shows video, but most of the time it crashes throwing an error.
Attempt just save the video with 'Config->Internals->Ignore all input timecodes' without any filters caused error "vspipe.exe has stopped working"


Attached Files
.zip   Debug _vspipe_error.zip (Size: 90,7 KB / Downloads: 5)
.zip   Debug_CFR_output.zip (Size: 91 KB / Downloads: 3)
.zip   Debug_Ignore_all_ input_ timecodes.zip (Size: 82,75 KB / Downloads: 4)
Reply
#35
vspipe fails since the decoding fo the source fails due to the time codes
CFR and ignoring time codes does not influence the decoding.
Since your graphic card does not support avc decoding you can try the following.
1. open Hybrid
2. set Audio&Video to passthrough
3. enable 'Config->Internals->Ignore all input timecodes'
4. load your source
5. set an output file
6. create a job
7. process the job
8. use the new file, which doesn't have the time code, as input.
(not writing any more details since you don't seem to like them)
Alternatively use mkvtoolnix to create an mkv of your source before processing it with Hybrid.
iirc. mkvtoolnix should either drop the time codes or create new onces.

Cu Selur
Reply
#36
Performed all steps you listed.

1. Used new file as input.
2. Assigned QTGMC filter.
Result - "Filter view" crashed with an error.


Attached Files
.zip   HybridDebugOutput.zip (Size: 115,9 KB / Downloads: 6)
Reply
#37
No clue why 'LWLibavSource' is still used on your end.
You wrote that you did not disable 'Filtering->Vapoursynth->Misc->Input->Prefer LSMASHSource over LWLibAVSource for mp4/mov' thus Hybrid should use LSMASHSource.
No clue,..
-> I'll create a version which will create additional debug output to see what's happening.

--
I also remuxed the file (https://drive.google.com/file/d/1_eJz7xS...sp=sharing) and the remuxed version works fine here with LWLibAVSource.

Cu Selur
Reply
#38
(15.11.2020, 12:22)Selur Wrote: No clue why 'LWLibavSource' is still used on your end.
You wrote that you did not disable 'Filtering->Vapoursynth->Misc->Input->Prefer LSMASHSource over LWLibAVSource for mp4/mov' thus Hybrid should use LSMASHSource.
No clue,..
-> I'll create a version which will create additional debug output to see what's happening.

--
I also remuxed the file (https://drive.google.com/file/d/1_eJz7xS...sp=sharing) and the remuxed version works fine here with LWLibAVSource.

Cu Selur

I checked 'Filtering->Vapoursynth->Misc->Input->Prefer LSMASHSource over LWLibAVSource for mp4/mov' - it's enabled (checked box)
Reply
#39
just to let you know: I filed an issue with one of the authors of LWLibavSource over at github to let them know that there is a problem with LWLibavSource.

Cu Selur
Reply
#40
Quote:I checked 'Filtering->Vapoursynth->Misc->Input->Prefer LSMASHSource over LWLibAVSource for mp4/mov' - it's enabled (checked box)
waiting for a debug output with the version I send you a few minutes ago Smile

Cu Selur
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)