This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

A cookie will be stored in your browser regardless of choice to prevent you being asked this question again. You will be able to change your cookie settings at any time using the link in the footer.

[BUG] rev. 2020.10.11.1 - avsviewer.exe stürzt ab
#1
Moin Selur,

der Avisyth Preview scheint mich nicht zu mögen, siehe Debugoutput.


Gruß
rabiato


Attached Files
.zip   HybridDebugOutput.zip (Size: 35,93 KB / Downloads: 4)
Reply
#2
Ich schick Dir nen Link zur aktuellen dev version, denke das Problem hab ich vor ner Weile gefixed.

Cu Selur
Reply
#3
Danke für die dev, Preview funktioniert wieder, allerdings stürzt jetzt VCEenc ab.


Gruß
rabiato


Attached Files
.zip   HybridDebugOutput.zip (Size: 60,41 KB / Downloads: 3)
Reply
#4
Funktioniert der Avisynth Preview?

Das Skript:
ClearAutoloadDirs()
SetFilterMTMode("DEFAULT_MT_MODE", MT_MULTI_INSTANCE)
LoadPlugin("C:\PROGRA~1\Hybrid\32bit\AVISYN~1\DGDecode.dll")
LoadPlugin("C:\PROGRA~1\Hybrid\32bit\AVISYN~1\RgTools.dll")
LoadPlugin("C:\PROGRA~1\Hybrid\32bit\AVISYN~1\masktools2.dll")
LoadPlugin("C:\PROGRA~1\Hybrid\32bit\AVISYN~1\mvtools2.dll")
LoadPlugin("C:\PROGRA~1\Hybrid\32bit\AVISYN~1\nnedi3.dll")
Import("C:\Program Files\Hybrid\32bit\avisynthPlugins\QTGMC.avsi")
Import("C:\Program Files\Hybrid\32bit\avisynthPlugins\Zs_RF_Shared.avsi")
# loading source: K:\Konvert-Test\Danger Route.VOB
#  color sampling YV12@8, matrix: bt470, scantyp: top field first, luminance scale: limited
MPEG2Source(d2v="K:\Hybrid\2020-11-09@18_17_59_2510.d2v")
# current resolution: 720x576
# deinterlacing
AssumeTFF()
QTGMC(Preset="Fast", ediThreads=2)
SelectEven()
# cropping
Crop(30,0,-30,0)# 660x576
# filtering
# scaling to 720x448
Spline36Resize(720,448)
PreFetch(4)
# setting output fps to 25.000fps
AssumeFPS(25,1)
#  output: color sampling YV12@8, matrix: bt470, scantyp: progressive, luminance scale: limited
return last
sieht richtig aus.

Der Aufruf sieht okay aus.
Zeigt:
"C:\Program Files\Hybrid\32bit\ffmpeg.exe" -y -noautorotate -nostdin -threads 8 -i "K:\Hybrid\encodingTempSynthSkript_2020-11-09@18_17_59_2510.avs" -an -sn -vf  scale=out_range=tv -pix_fmt yuv420p -vsync 0  -f yuv4mpegpipe - | "C:\Program Files\Hybrid\64bit\VCEEncC.exe" --y4m -i - --codec h264 --vbr 2500 --max-bitrate 2500 --pre-analysis quarter --vbaq --ref 16 --bframes 3 --b-pyramid --motion-est q-pel --profile High --level auto --vbv-bufsize 20000 --slices 1 --sar 1:1 --fps 25.000 --output-file "K:\Hybrid\Danger Route_2020-11-09@18_17_59_2510_05.264"
-> irgendwelche Fehler, wenn Du den Aufruf in Windows Eingabeaufforderung machst?

Cu Selur
Reply
#5
Ich erhalte eine Fehlermeldung: 



C:\Program Files\Hybrid\32bit\ffmpeg.exe" -y -noautorotate -nostdin -threads 8 -i "K:\Hybrid\encodingTempSynthSkript_2020-11-09@18_17_59_2510.avs" -an -sn -vf  scale=out_range=tv -pix_fmt yuv420p -vsync 0  -f yuv4mpegpipe - | "C:\Program Files\Hybrid\64bit\VCEEncC.exe" --y4m -i - --codec h264 --vbr 2500 --max-bitrate 2500 --pre-analysis quarter --vbaq --ref 16 --bframes 3 --b-pyramid --motion-est q-pel --profile High --level auto --vbv-bufsize 20000 --slices 1 --sar 1:1 --fps 25.000 --output-file "K:\Hybrid\Danger Route_2020-11-09@18_17_59_2510_05.264"
Error: Unknown option: quarter

Did you mean option(s) below?
  --tier
ffmpeg version N-98737-g8a31850ebf-g392a2d0790+3 Copyright (c) 2000-2020 the FFmpeg developers
  built with gcc 10.2.0 (Rev1, Built by MSYS2 project)
  configuration:  --cc='ccache gcc' --cxx='ccache g++' --disable-autodetect --enable-amf --enable-bzlib --enable-cuda --enable-cuvid --enable-d3d11va --enable-dxva2 --enable-iconv --enable-lzma --enable-nvenc --enable-zlib --enable-sdl2 --enable-ffnvcodec --enable-nvdec --enable-cuda-llvm --enable-libmp3lame --enable-libopus --enable-libvorbis --enable-libvpx --enable-libx264 --enable-libx265 --enable-libdav1d --disable-debug --enable-fontconfig --enable-libass --enable-libbluray --enable-libfreetype --enable-libmfx --enable-libmysofa --enable-libopencore-amrnb --enable-libopencore-amrwb --enable-libopenjpeg --enable-libsnappy --enable-libsoxr --enable-libspeex --enable-libtheora --enable-libtwolame --enable-libvidstab --enable-libvo-amrwbenc --enable-libwavpack --enable-libwebp --enable-libxml2 --enable-libzimg --enable-libshine --enable-gpl --enable-avisynth --enable-libxvid --enable-libaom --enable-libopenmpt --enable-version3 --enable-libkvazaar --enable-libzmq --enable-vapoursynth --enable-librav1e --enable-mbedtls --extra-cflags=-DLIBTWOLAME_STATIC --extra-libs=-lstdc++ --extra-cflags=-DZMQ_STATIC --extra-cflags=-DLIBXML_STATIC --extra-libs=-liconv --extra-cflags=-DKVZ_STATIC_LIB
  libavutil      56. 58.100 / 56. 58.100
  libavcodec     58.100.100 / 58.100.100
  libavformat    58. 51.100 / 58. 51.100
  libavdevice    58. 11.101 / 58. 11.101
  libavfilter     7. 87.100 /  7. 87.100
  libswscale      5.  8.100 /  5.  8.100
  libswresample   3.  8.100 /  3.  8.100
  libpostproc    55.  8.100 / 55.  8.100
Input #0, avisynth, from 'K:\Hybrid\encodingTempSynthSkript_2020-11-09@18_17_59_2510.avs':
  Duration: 01:32:21.52, start: 0.000000, bitrate: 0 kb/s
    Stream #0:0: Video: rawvideo (I420 / 0x30323449), yuv420p, 720x448, 25 fps, 25 tbr, 25 tbn, 25 tbc
Stream mapping:
  Stream #0:0 -> #0:0 (rawvideo (native) -> wrapped_avframe (native))
Output #0, yuv4mpegpipe, to 'pipe:':
  Metadata:
    encoder         : Lavf58.51.100
    Stream #0:0: Video: wrapped_avframe, yuv420p, 720x448, q=2-31, 200 kb/s, 25 fps, 25 tbn, 25 tbc
    Metadata:
      encoder         : Lavc58.100.100 wrapped_avframe
av_interleaved_write_frame(): Invalid argument
Error writing trailer of pipe:: Invalid argument
frame=    1 fps=0.0 q=-0.0 Lsize=     473kB time=00:00:00.04 bitrate=96780.8kbits/s speed=3.76x
video:0kB audio:0kB subtitle:0kB other streams:0kB global headers:0kB muxing overhead: 118503.921875%
Conversion failed!
Reply
#6
Okay, scheint als ob sich die Parameter von VCEEncC geändert zu haben.
Bei "VCEEncC --help" gibt es '--pre-analysis' und '--vbaq' nicht mehr.
Wenn ich daran denke kann ich versuchen nächstes Wochenende drauf schauen ob ich es schaffe den kompletten Support für VCEEnc neu schreiben.
Falls aktuelle VCEEncC Versionen auf meinem Laptop noch laufen. (Einziger Windows Rechner mit Intel CPU die VCE unterstützt den ich habe.)

-> aktuell würde ich empfehlen, tausch die VCEEncC.exe mit einer aus die in der letzten Hybrid Version war die noch lief.

Cu Selur
Reply
#7
Ich habe mal ein bisschen herumprobiert, die höchste VCEEncC Version welche bei mir mit Hybrid funktioniert ist 3.05, jede höhere Version stürzt trotz neuester Radeon-Treiber ab.

Apropos neue Versionen, VCEEncC hat jetzt nette Funktionen: Deinterlace, Denoise, Sharpen usw., gibt es Chance auf Implementierung?


Gruß
rabiato
Reply
#8
Mift, im Kopf VCE und QSV durcheinander gebracht.
Das macht die Sache komplizierter, da die einzige AMD Grafikkarte bei mir im VM server steckt und die vermutlich auch so alt ist, dass die mit VCEEnc nicht geht.

-> ich werde mich am WE mal dransetzen und schauen was ich da 'blind' zusammen gebastelt bekomme.

Cu Selur
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)