This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

A cookie will be stored in your browser regardless of choice to prevent you being asked this question again. You will be able to change your cookie settings at any time using the link in the footer.

*.aac was not created!
#1
Quote:Crashed encoding audio to AAC using neroaacenc.
This occured when *.mkv file contain audio in
Quote:Codec ID : A_AAC/MPEG2/LC
When *.mkv file contain audio in
Quote:Codec ID : A_AAC-2
(MPEG4 AAC)
encoding is finished without error, but in the "Job" tab I see line:
Quote:encoding audio to aac using ffmpeg
, when checked
Quote:enable to use NeroAACEnc instead of libav's aac encoder


Attached Files
.zip   HybridDebugOutput.zip (Size: 94,64 KB / Downloads: 4)
Reply
#2
Don't see any direct problem.
Does calling:
"C:\Program Files\Hybrid\64bit\ffmpeg.exe" -y -threads 12 -nostdin -i "C:\Windows\Temp\iId_5_aid_0_DELAY_-53ms_2021-01-10@23_06_59_6010_01.aac" -ac 6 -ar 48000 -acodec pcm_s16le -f wav NUL
show any errors?
If not does calling:
"C:\Program Files\Hybrid\64bit\ffmpeg.exe" -y -threads 12 -loglevel fatal -nostdin -i "C:\Windows\Temp\iId_5_aid_0_DELAY_-53ms_2021-01-10@23_06_59_6010_01.aac" -ac 6 -ar 48000 -acodec pcm_s16le -f wav - | "C:\Program Files (x86)\NeroAACCodec\win32\neroAacEnc.exe"  -q 0.75 -lc -ignorelength -if - -of "C:\Windows\Temp\iId_5_aid_0_2021-01-10@23_06_59_6010_02.aac"
show any errors?

Using:
ffmpeg -y -threads 8 -loglevel fatal -nostdin -i "E:\Temp\iId_3_aid_1_DELAY_-53ms_2021-01-10@20_48_29_7910_01.ac3" -ac 6 -ar 48000 -acodec pcm_s16le -f wav - | neroAacEnc  -q 0.75 -lc -ignorelength -if - -of "E:\Temp\iId_3_aid_1_DELAY_-53ms_2021-01-10@20_48_29_7910_02.aac"
works fine here, my guess is that it's a problem with the decoding of the source.

Cu Selur

Ps.: Only real difference that is I see is that you are using the Windows/Temp-folder.
Reply
#3
(10.01.2021, 21:45)Selur Wrote: Don't see any direct problem.
Does calling:
"C:\Program Files\Hybrid\64bit\ffmpeg.exe" -y -threads 12 -nostdin -i "C:\Windows\Temp\iId_5_aid_0_DELAY_-53ms_2021-01-10@23_06_59_6010_01.aac" -ac 6 -ar 48000 -acodec pcm_s16le -f wav NUL
show any errors?

Cu Selur

Quote:Error while decoding stream #0:0: Invalid data found when processing input
[abuffer @ 000001a614b8e680] Value inf for parameter 'time_base' out of range [0 - 2.14748e+09]
Last message repeated 3 times
[abuffer @ 000001a614b8e680] Error setting option time_base to value 1/0.
[graph_0_in_0_0 @ 000001a61303a500] Error applying options to the filter.
Error reinitializing filters!
Error while filtering: Result too large
Finishing stream 0:0 without any data written to it.
[abuffer @ 000001a614b8e2c0] Value inf for parameter 'time_base' out of range [0 - 2.14748e+09]
Last message repeated 3 times
[abuffer @ 000001a614b8e2c0] Error setting option time_base to value 1/0.
[graph_0_in_0_0 @ 000001a614943280] Error applying options to the filter.
Error configuring filter graph


This line
Quote:encoding audio to aac using ffmpeg
is right?
Reply
#4
Okay, it's a problem with ffmpeg decoding the extracted audio.
Hybrid used:
"C:\Program Files\Hybrid\64bit\ffmpeg.exe" -y -threads 12 -i "H:\!_gotovo\no\Jessie J Ariana Grande [iHeartRadio Jingle Ball 2014 (N).mkv" -map 0:1 -vn -sn -acodec copy -map_metadata -1 -metadata encoding_tool="Hybrid 2020.12.13.1" "C:\Windows\Temp\iId_5_aid_0_DELAY_-53ms_2021-01-10@23_06_59_6010_01.aac"
to extract the audio.
And I don't see any error in the debug output for that:
ffmpeg version N-100400-g5f7dc836ce-gd76469378d+4 Copyright (c) 2000-2020 the FFmpeg developers
  built with gcc 10.2.0 (Rev5, Built by MSYS2 project)
  configuration:  --pkg-config=pkgconf --cc='ccache gcc' --cxx='ccache g++' --disable-autodetect --enable-amf --enable-bzlib --enable-cuda --enable-cuvid --enable-d3d11va --enable-dxva2 --enable-iconv --enable-lzma --enable-nvenc --enable-zlib --enable-sdl2 --enable-ffnvcodec --enable-nvdec --enable-cuda-llvm --enable-libmp3lame --enable-libopus --enable-libvorbis --enable-libvpx --enable-libx264 --enable-libx265 --enable-libdav1d --disable-debug --enable-fontconfig --enable-libass --enable-libbluray --enable-libfreetype --enable-libmfx --enable-libmysofa --enable-libopencore-amrnb --enable-libopencore-amrwb --enable-libopenjpeg --enable-libsnappy --enable-libsoxr --enable-libspeex --enable-libtheora --enable-libtwolame --enable-libvidstab --enable-libvo-amrwbenc --enable-libwebp --enable-libxml2 --enable-libzimg --enable-libshine --enable-gpl --enable-avisynth --enable-libxvid --enable-libaom --enable-libopenmpt --enable-version3 --enable-libsvthevc --enable-libsvtav1 --enable-libkvazaar --enable-libzmq --enable-libvmaf --enable-vapoursynth --disable-libdavs2 --enable-librav1e --enable-mbedtls --extra-cflags=-DLIBTWOLAME_STATIC --extra-libs=-lstdc++ --extra-cflags=-DZMQ_STATIC --extra-cflags=-DLIBXML_STATIC --extra-libs=-liconv --disable-w32threads --extra-cflags=-DKVZ_STATIC_LIB
  libavutil      56. 62.100 / 56. 62.100
  libavcodec     58.115.102 / 58.115.102
  libavformat    58. 65.100 / 58. 65.100
  libavdevice    58. 11.103 / 58. 11.103
  libavfilter     7. 93.100 /  7. 93.100
  libswscale      5.  8.100 /  5.  8.100
  libswresample   3.  8.100 /  3.  8.100
  libpostproc    55.  8.100 / 55.  8.100

Input #0, matroska,webm, from 'H:\!_gotovo\no\Jessie J Ariana Grande [iHeartRadio Jingle Ball 2014 (N).mkv':
  Metadata:
    encoder         : TMPGEnc MPEG Smart Renderer 5 Trial Version 5.0.21.27
    creation_time   : 2019-11-10T23:17:33.976000Z
  Duration: 00:03:20.79, start: 0.000000, bitrate: 8608 kb/s
    Stream #0:0: Video: h264 (High), yuv420p(tv, bt709, progressive), 1280x720 [SAR 1:1 DAR 16:9], 29.97 fps, 29.97 tbr, 1k tbn, 59.94 tbc (default)
    Stream #0:1: Audio: aac (LC), 48000 Hz, 5.1, fltp (default)

Output #0, adts, to 'C:\Windows\Temp\iId_5_aid_0_DELAY_-53ms_2021-01-10@23_06_59_6010_01.aac':
  Metadata:
    encoding_tool   : "Hybrid 2020.12.13.1"
    encoder         : Lavf58.65.100
    Stream #0:0: Audio: aac (LC), 48000 Hz, 5.1, fltp (default)
Stream mapping:
  Stream #0:1 -> #0:0 (copy)
Press [q] to stop, [?] for help

size=   15751kB time=00:03:20.76 bitrate= 642.7kbits/s speed=1.44e+03x    
video:0kB audio:15687kB subtitle:0kB other streams:0kB global headers:0kB muxing overhead: 0.410153%
finished after 00:00:00.256
created C:\Windows\Temp\iId_5_aid_0_DELAY_-53ms_2021-01-10@23_06_59_6010_01.aac (15.382 MB)
Problem is, if ffmpeg can't decode the extracted audio I can't do anything about it.

Quote:This line
Quote:encoding audio to aac using ffmpeg
is right?
If ffmpeg is used: yes.
Doesn't appear in the debug output.

Cu Selur
Reply
#5
Quote:If ffmpeg is used: yes.
Doesn't appear in the debug output.
Now checked
Quote:enable to use NeroAACEnc


Attached Files
.zip   HybridDebugOutput.zip (Size: 95,63 KB / Downloads: 4)
Reply
#6
No clue what you are trying to tell me with that. Huh
That debug output doesn't show any errors and reencoding seems to have worked fine using:
"C:\Program Files\Hybrid\64bit\ffmpeg.exe" -y -threads 12 -loglevel fatal -nostdin -i "C:\Windows\Temp\iId_5_aid_0_DELAY_-53ms_2021-01-10@23_06_59_6010_01.aac" -ac 6 -ar 48000 -acodec pcm_s16le -f wav -  | "C:\Program Files (x86)\NeroAACCodec\win32\neroAacEnc.exe"  -q 0.75 -lc -ignorelength -if - -of "C:\Windows\Temp\iId_5_aid_0_2021-01-10@23_06_59_6010_02.aac"
Since you used another input file this time ("H:\!-Clips\80-90\Yello & Stina Nordenstam - To The Sea 1997 (N).mkv") it looks like the issue is with your previous input file ("H:\!_gotovo\no\Jessie J Ariana Grande [iHeartRadio Jingle Ball 2014 (N).mkv").
So this isn't a bug in Hybrid but from the looks of it a broken source.
You can try whether remuxing with mkvtoolnix can fix the source, but atm. it doesn't seem like there's anything I can do to help.

Cu Selur
Reply
#7
Again using another source "Talk Talk - Such A Shame 1984) (N) (1)" remuxed with last version mkvtoolnix.
Again seening line
Quote:encoding audio to aac using ffmpeg


Attached Files
.zip   HybridDebugOutput.zip (Size: 100,87 KB / Downloads: 1)
Reply
#8
according to the debug output neroaacenc is used but fails again.
No clue why you see 'encoding audio to aac using ffmpeg', might be a bug in the minimizing call, you can check the used calls when disabling 'Minimize job command lines'.
Since the encoding still doesn't work even after mkvtoolnix remuxing I can't help with that file.
To me that file simply seems to be broken or not supported by libav thus Hybrid can't handle it.

If you share your 'autosavedJobs.xml' form your settings folder which contains a job where the 'encoding audio to aac using ffmpeg-glitch happens I can look at it today after work.


Cu Selur
Reply
#9
(11.01.2021, 06:16)Selur Wrote: If you share your 'autosavedJobs.xml' form your settings folder which contains a job where the 'encoding audio to aac using ffmpeg-glitch happens I can look at it today after work.


Cu Selur


Attached Files
.zip   autosavedJobs.zip (Size: 2,41 KB / Downloads: 1)
Reply
#10
Okay, I see the cause of the glitch.
Due to your settings Hybrid:
1. encodes the audio (ffmpeg -> neroAACEnc)
2. cuts the audio (using ffmpeg)
and the cutting step is wrongly shown as 'encoding audio to aac using ffmpeg', while it should show 'cutting audio using ffmpeg'.
-> small glitch, not related to the encoding/decoding problem, will fix later.

Cu Selur
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)