This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

A cookie will be stored in your browser regardless of choice to prevent you being asked this question again. You will be able to change your cookie settings at any time using the link in the footer.

Saving Configuration for all settings
#11
(19.02.2021, 07:40)Selur Wrote: Yes, a Global Profile should contain all settings so if you apply an x264 preset afterwards it will change the settings.

Cu Selur

I think something is not right.
My workflow that gives me a problem:
Starting Hybrid, loading video file, changing all Filtering settings, X264 settings, going back to X264/Base/Restriction Setting, changing Preset from None to Medium, pressing corresponding arrow/applying medium. Go to Configuration, Configuration Save, saving under new name. Going to Config/Global Profile, press +, saving Global profile under new name. Closing/restarting Hybrid, going to X264 under Configuration choosing last saved configuration profile, applying, pressing Medium, pressing arrow/applying. Going to Config/Global Profile, applying profile. Loading video file. Going back to X264 to check Frames settings, they all changed. Need to set them again.

Every time changing Preset from none to medium, arrow/applying changes Frames settings, no way to save it.
Reply
#12
Quote:My workflow that gives me a problem:
Starting Hybrid, loading video file, changing all Filtering settings, X264 settings, going back to X264/Base/Restriction Setting, changing Preset from None to Medium, pressing corresponding arrow/applying medium. Go to Configuration, Configuration Save, saving under new name. Going to Config/Global Profile, press +, saving Global profile under new name. Closing/restarting Hybrid, going to X264 under Configuration choosing last saved configuration profile, applying, pressing Medium, pressing arrow/applying. Going to Config/Global Profile, applying profile. Loading video file. Going back to X264 to check Frames settings, they all changed. Need to set them again.
Okay, that is wrong.
If you want to use a global profile with 'medium' preset, you would:
  • Start Hybrid
  • Appliy medium preset (set 'x264->Base->Restriction Settings->Preset' to 'medium' , press 'x264->Base->Restriction Settings->Preset->Apply Preset')
    Command line changed to:
    x264 --preset veryfast --pass 1 --bitrate 1500 --profile high --level 4.1 --sync-lookahead 24 --rc-lookahead 40 --qpmax 51 --weightp 2 --sar 1:1 --qpfile GENERATED_QP_FILE --non-deterministic --stats "PATH TO THE .stats FILE" --demuxer raw --input-res 48x48 --input-csp i420 --input-range tv --input-depth 8 --fps 25/1 --output-depth 8 --output NUL -

    x264 --pass 2 --bitrate 1500 --profile high --level 4.1 --sync-lookahead 24 --qpmax 51 --vbv-maxrate 62500 --vbv-bufsize 78125 --sar 1:1 --qpfile GENERATED_QP_FILE --non-deterministic --stats "PATH TO THE .stats FILE" --demuxer raw --input-res 48x48 --input-csp i420 --input-range tv --input-depth 8 --fps 25/1 --output-depth 8 --output OUTPUTFILE
  • Save a Globla Profile (Config->Profiles->Global profile->Save global profile)
Then you can close Hybrid.
After that you can:
  • start Hybrid
  • Apply the global global profile (select the profile under 'Config->Profiles->Global profile->Name' and apply the profile 'Config->Profiles->Global profile->Apply global profile')

This way all the setting that were saved in the profile are loaded and x264 settings are again:
x264 --preset veryfast --pass 1 --bitrate 1500 --profile high --level 4.1 --sync-lookahead 24 --rc-lookahead 40 --qpmax 51 --weightp 2 --sar 1:1 --qpfile GENERATED_QP_FILE --non-deterministic --stats "PATH TO THE .stats FILE" --demuxer raw --input-res 48x48 --input-csp i420 --input-range tv --input-depth 8 --fps 25/1 --output-depth 8 --output NUL -

x264 --pass 2 --bitrate 1500 --profile high --level 4.1 --sync-lookahead 24 --qpmax 51 --vbv-maxrate 62500 --vbv-bufsize 78125 --sar 1:1 --qpfile GENERATED_QP_FILE --non-deterministic --stats "PATH TO THE .stats FILE" --demuxer raw --input-res 48x48 --input-csp i420 --input-range tv --input-depth 8 --fps 25/1 --output-depth 8 --output OUTPUTFILE
(Filtering&Co settings are also adjusted to the values before saving the global profile)


My guess is that you simply might want to enable 'Config->Profiles->Auto save', this way Hybrid will remember all the settings your did before closing Hybrid and restart with those settings.

Cu Selur
Reply
#13
(19.02.2021, 19:13)Selur Wrote:
Quote:My workflow that gives me a problem:
Starting Hybrid, loading video file, changing all Filtering settings, X264 settings, going back to X264/Base/Restriction Setting, changing Preset from None to Medium, pressing corresponding arrow/applying medium. Go to Configuration, Configuration Save, saving under new name. Going to Config/Global Profile, press +, saving Global profile under new name. Closing/restarting Hybrid, going to X264 under Configuration choosing last saved configuration profile, applying, pressing Medium, pressing arrow/applying. Going to Config/Global Profile, applying profile. Loading video file. Going back to X264 to check Frames settings, they all changed. Need to set them again.
Okay, that is wrong.
If you want to use a global profile with 'medium' preset, you would:
  • Start Hybrid
  • Appliy medium preset (set 'x264->Base->Restriction Settings->Preset' to 'medium' , press 'x264->Base->Restriction Settings->Preset->Apply Preset')
    Command line changed to:
    x264 --preset veryfast --pass 1 --bitrate 1500 --profile high --level 4.1 --sync-lookahead 24 --rc-lookahead 40 --qpmax 51 --weightp 2 --sar 1:1 --qpfile GENERATED_QP_FILE --non-deterministic --stats "PATH TO THE .stats FILE" --demuxer raw --input-res 48x48 --input-csp i420 --input-range tv --input-depth 8 --fps 25/1 --output-depth 8 --output NUL -x264 --pass 2 --bitrate 1500 --profile high --level 4.1 --sync-lookahead 24 --qpmax 51 --vbv-maxrate 62500 --vbv-bufsize 78125 --sar 1:1 --qpfile GENERATED_QP_FILE --non-deterministic --stats "PATH TO THE .stats FILE" --demuxer raw --input-res 48x48 --input-csp i420 --input-range tv --input-depth 8 --fps 25/1 --output-depth 8 --output OUTPUTFILE
  • Save a Globla Profile (Config->Profiles->Global profile->Save global profile)
Then you can close Hybrid.
After that you can:
  • start Hybrid
  • Apply the global global profile (select the profile under 'Config->Profiles->Global profile->Name' and apply the profile  'Config->Profiles->Global profile->Apply global profile')

This way all the setting that were saved in the profile are loaded and x264 settings are again:
x264 --preset veryfast --pass 1 --bitrate 1500 --profile high --level 4.1 --sync-lookahead 24 --rc-lookahead 40 --qpmax 51 --weightp 2 --sar 1:1 --qpfile GENERATED_QP_FILE --non-deterministic --stats "PATH TO THE .stats FILE" --demuxer raw --input-res 48x48 --input-csp i420 --input-range tv --input-depth 8 --fps 25/1 --output-depth 8 --output NUL -

x264 --pass 2 --bitrate 1500 --profile high --level 4.1 --sync-lookahead 24 --qpmax 51 --vbv-maxrate 62500 --vbv-bufsize 78125 --sar 1:1 --qpfile GENERATED_QP_FILE --non-deterministic --stats "PATH TO THE .stats FILE" --demuxer raw --input-res 48x48 --input-csp i420 --input-range tv --input-depth 8 --fps 25/1 --output-depth 8 --output OUTPUTFILE
(Filtering&Co settings are also adjusted to the values before saving the global profile)


My guess is that you simply might want to enable 'Config->Profiles->Auto save', this way Hybrid will remember all the settings your did before closing Hybrid and restart with those settings.

Cu Selur

It works as you showed, but from the default Configuration: X264 Hybrid Default.
 
But if change settings, for example 264>Frame changing Min/Max GOP, when applying medium preset it changes the values.
 
Can you try this sequence to set the following?
·       Start Hybrid, apply default Configuration: X264 Hybrid Default.
·       X264>Base> Set encoding mode to CRF 1-pass, Hardware (mark-up box) – BluRay/AVCHD
·       Apply medium preset (set 'x264->Base->Restriction Settings->Preset' to 'medium' , press 'x264->Base->Restriction Settings->Preset->Apply Preset')
·       Go to X264>Frames, Setting GOP Size Min = 1, Max = 50.
·       Save configuration under new name.
·       Save a Global Profile (Config->Profiles->Global profile->Save global profile)

Settings I have:
x264 --crf 18.00 --profile high --level 4.1 --bluray-compat --keyint 50 --min-keyint 1 --b-pyramid strict --sync-lookahead 1 --slices 4 --qpmax 51 --mvrange 511 --weightp 1 --vbv-maxrate 40000 --vbv-bufsize 30000 --nal-hrd cbr --sar 1:1 --qpfile GENERATED_QP_FILE --non-deterministic --range tv --colormatrix bt709 --demuxer raw --input-res 1280x720 --input-csp i420 --input-range tv --input-depth 8 --fps 25/1 --output-depth 8 --output OUTPUTFILE –
 
Close Hybrid, Strat Hybrid, apply Global Profile.
 
Settings after applying Global profile (they are different):
x264 --crf 18.00 --profile high --level 4.1 --bluray-compat --keyint 25 --min-keyint 1 --b-pyramid strict --sync-lookahead 1 --rc-lookahead 12 --slices 4 --qpmax 51 --mvrange 511 --weightp 1 --vbv-maxrate 40000 --vbv-bufsize 30000 --nal-hrd cbr --sar 1:1 --qpfile GENERATED_QP_FILE --non-deterministic --range tv --colormatrix bt709 --demuxer raw --input-res 1280x720 --input-csp i420 --input-range tv --input-depth 8 --fps 25/1 --output-depth 8 --output OUTPUTFILE –
 
 
They are different:
X264>Frames, Max GOP = 25 (instead of 50), no way to change it 50, the values do not go above 25. And X264>Base>Restriction Settings->Preset-None, not Medium.
 
Preset changing to Medium, Applying, settings change to (another different combination):
x264 --crf 18.00 --profile high --level 4.1 --bluray-compat --keyint 25 --b-pyramid strict --sync-lookahead 1 --rc-lookahead 25 --slices 4 --qpmax 51 --mvrange 511 --weightp 1 --vbv-maxrate 40000 --vbv-bufsize 30000 --nal-hrd cbr --sar 1:1 --qpfile GENERATED_QP_FILE --non-deterministic --range tv --colormatrix bt709 --demuxer raw --input-res 1280x720 --input-csp i420 --input-range tv --input-depth 8 --fps 25/1 --output-depth 8 --output OUTPUTFILE -
 
Still does not allow to change Max GOP to 50fps.
 
What I am doing wrong?

(21.02.2021, 05:40)Rokoko33 Wrote:
(19.02.2021, 19:13)Selur Wrote:
Quote:My workflow that gives me a problem:
Starting Hybrid, loading video file, changing all Filtering settings, X264 settings, going back to X264/Base/Restriction Setting, changing Preset from None to Medium, pressing corresponding arrow/applying medium. Go to Configuration, Configuration Save, saving under new name. Going to Config/Global Profile, press +, saving Global profile under new name. Closing/restarting Hybrid, going to X264 under Configuration choosing last saved configuration profile, applying, pressing Medium, pressing arrow/applying. Going to Config/Global Profile, applying profile. Loading video file. Going back to X264 to check Frames settings, they all changed. Need to set them again.
Okay, that is wrong.
If you want to use a global profile with 'medium' preset, you would:
  • Start Hybrid
  • Appliy medium preset (set 'x264->Base->Restriction Settings->Preset' to 'medium' , press 'x264->Base->Restriction Settings->Preset->Apply Preset')
    Command line changed to:
    x264 --preset veryfast --pass 1 --bitrate 1500 --profile high --level 4.1 --sync-lookahead 24 --rc-lookahead 40 --qpmax 51 --weightp 2 --sar 1:1 --qpfile GENERATED_QP_FILE --non-deterministic --stats "PATH TO THE .stats FILE" --demuxer raw --input-res 48x48 --input-csp i420 --input-range tv --input-depth 8 --fps 25/1 --output-depth 8 --output NUL -x264 --pass 2 --bitrate 1500 --profile high --level 4.1 --sync-lookahead 24 --qpmax 51 --vbv-maxrate 62500 --vbv-bufsize 78125 --sar 1:1 --qpfile GENERATED_QP_FILE --non-deterministic --stats "PATH TO THE .stats FILE" --demuxer raw --input-res 48x48 --input-csp i420 --input-range tv --input-depth 8 --fps 25/1 --output-depth 8 --output OUTPUTFILE
  • Save a Globla Profile (Config->Profiles->Global profile->Save global profile)
Then you can close Hybrid.
After that you can:
  • start Hybrid
  • Apply the global global profile (select the profile under 'Config->Profiles->Global profile->Name' and apply the profile  'Config->Profiles->Global profile->Apply global profile')

This way all the setting that were saved in the profile are loaded and x264 settings are again:
x264 --preset veryfast --pass 1 --bitrate 1500 --profile high --level 4.1 --sync-lookahead 24 --rc-lookahead 40 --qpmax 51 --weightp 2 --sar 1:1 --qpfile GENERATED_QP_FILE --non-deterministic --stats "PATH TO THE .stats FILE" --demuxer raw --input-res 48x48 --input-csp i420 --input-range tv --input-depth 8 --fps 25/1 --output-depth 8 --output NUL -

x264 --pass 2 --bitrate 1500 --profile high --level 4.1 --sync-lookahead 24 --qpmax 51 --vbv-maxrate 62500 --vbv-bufsize 78125 --sar 1:1 --qpfile GENERATED_QP_FILE --non-deterministic --stats "PATH TO THE .stats FILE" --demuxer raw --input-res 48x48 --input-csp i420 --input-range tv --input-depth 8 --fps 25/1 --output-depth 8 --output OUTPUTFILE
(Filtering&Co settings are also adjusted to the values before saving the global profile)


My guess is that you simply might want to enable 'Config->Profiles->Auto save', this way Hybrid will remember all the settings your did before closing Hybrid and restart with those settings.

Cu Selur

It works as you showed, but from the default Configuration: X264 Hybrid Default.
 
But if change settings, for example 264>Frame changing Min/Max GOP, when applying medium preset it changes the values.
 
Can you try this sequence to set the following?
·       Start Hybrid, apply default Configuration: X264 Hybrid Default.
·       X264>Base> Set encoding mode to CRF 1-pass, Hardware (mark-up box) – BluRay/AVCHD
·       Apply medium preset (set 'x264->Base->Restriction Settings->Preset' to 'medium' , press 'x264->Base->Restriction Settings->Preset->Apply Preset')
·       Go to X264>Frames, Setting GOP Size Min = 1, Max = 50.
·       Save configuration under new name.
·       Save a Global Profile (Config->Profiles->Global profile->Save global profile)

Settings I have:
x264 --crf 18.00 --profile high --level 4.1 --bluray-compat --keyint 50 --min-keyint 1 --b-pyramid strict --sync-lookahead 1 --slices 4 --qpmax 51 --mvrange 511 --weightp 1 --vbv-maxrate 40000 --vbv-bufsize 30000 --nal-hrd cbr --sar 1:1 --qpfile GENERATED_QP_FILE --non-deterministic --range tv --colormatrix bt709 --demuxer raw --input-res 1280x720 --input-csp i420 --input-range tv --input-depth 8 --fps 25/1 --output-depth 8 --output OUTPUTFILE –
 
Close Hybrid, Strat Hybrid, apply Global Profile.
 
Settings after applying Global profile (they are different):
x264 --crf 18.00 --profile high --level 4.1 --bluray-compat --keyint 25 --min-keyint 1 --b-pyramid strict --sync-lookahead 1 --rc-lookahead 12 --slices 4 --qpmax 51 --mvrange 511 --weightp 1 --vbv-maxrate 40000 --vbv-bufsize 30000 --nal-hrd cbr --sar 1:1 --qpfile GENERATED_QP_FILE --non-deterministic --range tv --colormatrix bt709 --demuxer raw --input-res 1280x720 --input-csp i420 --input-range tv --input-depth 8 --fps 25/1 --output-depth 8 --output OUTPUTFILE –
 
 
They are different:
X264>Frames, Max GOP = 25 (instead of 50), no way to change it 50, the values do not go above 25. And X264>Base>Restriction Settings->Preset-None, not Medium.
 
Preset changing to Medium, Applying, settings change to (another different combination):
x264 --crf 18.00 --profile high --level 4.1 --bluray-compat --keyint 25 --b-pyramid strict --sync-lookahead 1 --rc-lookahead 25 --slices 4 --qpmax 51 --mvrange 511 --weightp 1 --vbv-maxrate 40000 --vbv-bufsize 30000 --nal-hrd cbr --sar 1:1 --qpfile GENERATED_QP_FILE --non-deterministic --range tv --colormatrix bt709 --demuxer raw --input-res 1280x720 --input-csp i420 --input-range tv --input-depth 8 --fps 25/1 --output-depth 8 --output OUTPUTFILE -
 
Still does not allow to change Max GOP to 50fps.
 
What I am doing wrong?
Also you mentioned as an option to enable 'Config->Profiles->Auto save', this way Hybrid will remember all the settings. It looks like does not work either. After restarting Hybrid the Preset is None, settings show accordingly: x264 --preset fast -. If I press/apply Medium, settings change, but X264>Frames Min/Max GOP values change to defaults. If I change them, the settings window shows : x264 --preset fast -. But Preset stays at Medium. It all jumping back and forth.
Reply
#14
Quote:But if change settings, for example 264>Frame changing Min/Max GOP, when applying medium preset it changes the values.
Yes, medium preset changes all to the x264 defaults.

Quote:Can you try this sequence to set the following?
· Start Hybrid, apply default Configuration: X264 Hybrid Default.
· X264>Base> Set encoding mode to CRF 1-pass, Hardware (mark-up box) – BluRay/AVCHD
· Apply medium preset (set 'x264->Base->Restriction Settings->Preset' to 'medium' , press 'x264->Base->Restriction Settings->Preset->Apply Preset')
· Go to X264>Frames, Setting GOP Size Min = 1, Max = 50.
· Save configuration under new name.
· Save a Global Profile (Config->Profiles->Global profile->Save global profile)

Okay, I did:
  • Start Hybrid
  • Set Hybrids default x264 settings (Apply 'x264->Configuration->x264 Hybrid defaul')
  • Set "x264->Base->General Settings->Encoding mode" to "constant rate factor (1-pass)"
  • Enable '264->Base->Restriction Settings->Hardware'
  • Select '264->Base->Restriction Settings->Hardware->Blu-ray/AVCHD'
  • Enable 'x264->Base->Restriction Settings->Preset' to 'medium'
  • Apply the preset ('x264->Base->Restriction Settings->Preset->Apply Preset')
  • Command line now is:
    x264 --crf 18.00 --profile high --level 4.1 --bluray-compat --keyint 50 --b-pyramid strict --sync-lookahead 1 --slices 4 --qpmax 51 --mvrange 511 --weightp 1 --vbv-maxrate 40000 --vbv-bufsize 30000 --nal-hrd cbr --sar 1:1 --qpfile GENERATED_QP_FILE --non-deterministic --range tv --colormatrix bt470bg --demuxer raw --input-res 48x48 --input-csp i420 --input-range tv --input-depth 8 --fps 25/1 --output-depth 8 --output OUTPUTFILE -
  • Set 'x264->Frames->General Frame Settings->GOP size min/max' to '1/50' (only min needed to be changed'
  • Command line now is:
    x264 --crf 18.00 --profile high --level 4.1 --bluray-compat --keyint 50 --min-keyint 1 --b-pyramid strict --sync-lookahead 1 --slices 4 --qpmax 51 --mvrange 511 --weightp 1 --vbv-maxrate 40000 --vbv-bufsize 30000 --nal-hrd cbr --sar 1:1 --qpfile GENERATED_QP_FILE --non-deterministic --range tv --colormatrix bt470bg --demuxer raw --input-res 48x48 --input-csp i420 --input-range tv --input-depth 8 --fps 25/1 --output-depth 8 --output OUTPUTFILE -
  • Save a Global Profile (Config->Profiles->Global profile->Save global profile)
  • Closed Hybrid
  • Started Hybrid
  • Apply the Global Profile (Config->Profiles->Global profile->Aplly global profile)
I then looked at the x264 Configuration and it shows:
x264 --crf 18.00 --profile high --level 4.1 --bluray-compat --keyint 50 --min-keyint 1 --b-pyramid strict --sync-lookahead 1 --rc-lookahead 25 --slices 4 --qpmax 51 --mvrange 511 --weightp 1 --vbv-maxrate 40000 --vbv-bufsize 30000 --nal-hrd cbr --sar 1:1 --qpfile GENERATED_QP_FILE --non-deterministic --range tv --colormatrix bt470bg --demuxer raw --input-res 48x48 --input-csp i420 --input-range tv --input-depth 8 --fps 25/1 --output-depth 8 --output OUTPUTFILE -

I also tried;
  • Start Hybrid
  • Reset and restart Hybrid ('Config->Reset->Defaults->All->Reset selected')
  • Set Hybrids default x264 settings (Apply 'x264->Configuration->x264 Hybrid defaul')
  • Set "x264->Base->General Settings->Encoding mode" to "constant rate factor (1-pass)"
  • Enable '264->Base->Restriction Settings->Hardware'
  • Select '264->Base->Restriction Settings->Hardware->Blu-ray/AVCHD'
  • Enable 'x264->Base->Restriction Settings->Preset' to 'medium'
  • Apply the preset ('x264->Base->Restriction Settings->Preset->Apply Preset')
  • Command line now is:
    x264 --crf 18.00 --profile high --level 4.1 --bluray-compat --keyint 50 --min-keyint 1 --b-pyramid strict --sync-lookahead 1 --slices 4 --qpmax 51 --mvrange 511 --weightp 1 --vbv-maxrate 40000 --vbv-bufsize 30000 --nal-hrd cbr --sar 1:1 --qpfile GENERATED_QP_FILE --non-deterministic --range tv --colormatrix bt470bg --demuxer raw --input-res 48x48 --input-csp i420 --input-range tv --input-depth 8 --fps 25/1 --output-depth 8 --output OUTPUTFILE -
  • Save a Global Profile (Config->Profiles->Global profile->Save global profile)
  • Closed Hybrid
  • Started Hybrid
  • Apply the Global Profile (Config->Profiles->Global profile->Aplly global profile)
I then looked at the x264 Configuration and it shows:
x264 --crf 18.00 --profile high --level 4.1 --bluray-compat --keyint 50 --min-keyint 1 --b-pyramid strict --sync-lookahead 1 --rc-lookahead 25 --slices 4 --qpmax 51 --mvrange 511 --weightp 1 --vbv-maxrate 40000 --vbv-bufsize 30000 --nal-hrd cbr --sar 1:1 --qpfile GENERATED_QP_FILE --non-deterministic --range tv --colormatrix bt470bg --demuxer raw --input-res 48x48 --input-csp i420 --input-range tv --input-depth 8 --fps 25/1 --output-depth 8 --output OUTPUTFILE -

Quote:They are different:
X264>Frames, Max GOP = 25 (instead of 50), no way to change it 50 the values do not go above 25.
Okay, that should not be. And is not the case here.
Looking at code to when Hybrid changes the max allowed gop size:
int bitrate = model->intValue(QString("bitrate"));
  int gopMax = model->intValue(QString("gopMaximum")); //gopMaximum is the keyint value
  int max;
  if (hardware == QString("Blu-ray/AVCHD")) {
    if (bitrate <= 15000) {
      max = (2 * gopMax < 1) ? 1 : 2 * int(model->doubleValue(QString("videoFramerate")) + 0.5); // 2 sec GOP
    } else {
      max = (gopMax < 1) ? 1 : int(model->doubleValue(QString("videoFramerate")) + 0.5); // 1 sec GOP
    }
  } else if (hardware == QString("AVC-Intra")) {
    max = 1;
  } else {
    max = 10000;
  }
  this->doSet(model, QString("gopMaximum"), MAXIMUM, QVariant(max));  //gopMaximum is the keyint value
So the restriction to '1-sec gop' should only be set by Hybrid if the bit rate is > 15000 kbit/s.


Quote:And X264>Base>Restriction Settings->Preset-None, not Medium.
Like I wrote before the preset setting in the drop-down is not saved since it it's not a strict restriction but something that get's applied. So this is as intended.

Quote:Also you mentioned as an option to enable 'Config->Profiles->Auto save', this way Hybrid will remember all the settings. It looks like does not work either. After restarting Hybrid the Preset is None, settings show accordingly: x264 --preset fast -. If I press/apply Medium, settings change, but X264>Frames Min/Max GOP values change to defaults. If I change them, the settings window shows : x264 --preset fast -. But Preset stays at Medium. It all jumping back and forth.
The preset selection is NOT saved, since it caused to much confusion with users, that setting only does something when 'Apply preset' is used.
No clue what you are doing, I again need details, to try to reproduce what you are doing.
My guess is that you changed some setting that is influencing Hybrids settings. May be it helps to reset the Hybrid defaults ('Config->Reset->Defaults->All->Reset selected').

Sadly unless I can reproduce what your are doing I can't fix a potential bug.


Cu Selur

Ps.: Please do not reply inside quotes, it really is annoying having to read through quotes to see whether you added something to them.
Reply
#15
(21.02.2021, 10:03)Selur Wrote:
Quote:But if change settings, for example 264>Frame changing Min/Max GOP, when applying medium preset it changes the values.
Yes, medium preset changes all to the x264 defaults.

Quote:Can you try this sequence to set the following?
·      Start Hybrid, apply default Configuration: X264 Hybrid Default.
·      X264>Base> Set encoding mode to CRF 1-pass, Hardware (mark-up box) – BluRay/AVCHD
·      Apply medium preset (set 'x264->Base->Restriction Settings->Preset' to 'medium' , press 'x264->Base->Restriction Settings->Preset->Apply Preset')
·      Go to X264>Frames, Setting GOP Size Min = 1, Max = 50.
·      Save configuration under new name.
·      Save a Global Profile (Config->Profiles->Global profile->Save global profile)

Okay, I did:
  • Start Hybrid
  • Set Hybrids default x264 settings (Apply 'x264->Configuration->x264 Hybrid defaul')
  • Set "x264->Base->General Settings->Encoding mode" to "constant rate factor (1-pass)"
  • Enable '264->Base->Restriction Settings->Hardware'
  • Select '264->Base->Restriction Settings->Hardware->Blu-ray/AVCHD'
  • Enable 'x264->Base->Restriction Settings->Preset' to 'medium'
  • Apply the preset ('x264->Base->Restriction Settings->Preset->Apply Preset')
  • Command line now is:
    x264 --crf 18.00 --profile high --level 4.1 --bluray-compat --keyint 50 --b-pyramid strict --sync-lookahead 1 --slices 4 --qpmax 51 --mvrange 511 --weightp 1 --vbv-maxrate 40000 --vbv-bufsize 30000 --nal-hrd cbr --sar 1:1 --qpfile GENERATED_QP_FILE --non-deterministic --range tv --colormatrix bt470bg --demuxer raw --input-res 48x48 --input-csp i420 --input-range tv --input-depth 8 --fps 25/1 --output-depth 8 --output OUTPUTFILE -
  • Set 'x264->Frames->General Frame Settings->GOP size min/max' to '1/50' (only min needed to be changed'
  • Command line now is:
    x264 --crf 18.00 --profile high --level 4.1 --bluray-compat --keyint 50 --min-keyint 1 --b-pyramid strict --sync-lookahead 1 --slices 4 --qpmax 51 --mvrange 511 --weightp 1 --vbv-maxrate 40000 --vbv-bufsize 30000 --nal-hrd cbr --sar 1:1 --qpfile GENERATED_QP_FILE --non-deterministic --range tv --colormatrix bt470bg --demuxer raw --input-res 48x48 --input-csp i420 --input-range tv --input-depth 8 --fps 25/1 --output-depth 8 --output OUTPUTFILE -
  • Save a Global Profile (Config->Profiles->Global profile->Save global profile)
  • Closed Hybrid
  • Started Hybrid
  • Apply the Global Profile  (Config->Profiles->Global profile->Aplly global profile)
I then looked at the x264 Configuration and it shows:
x264 --crf 18.00 --profile high --level 4.1 --bluray-compat --keyint 50 --min-keyint 1 --b-pyramid strict --sync-lookahead 1 --rc-lookahead 25 --slices 4 --qpmax 51 --mvrange 511 --weightp 1 --vbv-maxrate 40000 --vbv-bufsize 30000 --nal-hrd cbr --sar 1:1 --qpfile GENERATED_QP_FILE --non-deterministic --range tv --colormatrix bt470bg --demuxer raw --input-res 48x48 --input-csp i420 --input-range tv --input-depth 8 --fps 25/1 --output-depth 8 --output OUTPUTFILE -

I also tried;
  • Start Hybrid
  • Reset and restart Hybrid ('Config->Reset->Defaults->All->Reset selected')
  • Set Hybrids default x264 settings (Apply 'x264->Configuration->x264 Hybrid defaul')
  • Set "x264->Base->General Settings->Encoding mode" to "constant rate factor (1-pass)"
  • Enable '264->Base->Restriction Settings->Hardware'
  • Select '264->Base->Restriction Settings->Hardware->Blu-ray/AVCHD'
  • Enable 'x264->Base->Restriction Settings->Preset' to 'medium'
  • Apply the preset ('x264->Base->Restriction Settings->Preset->Apply Preset')
  • Command line now is:
    x264 --crf 18.00 --profile high --level 4.1 --bluray-compat --keyint 50 --min-keyint 1 --b-pyramid strict --sync-lookahead 1 --slices 4 --qpmax 51 --mvrange 511 --weightp 1 --vbv-maxrate 40000 --vbv-bufsize 30000 --nal-hrd cbr --sar 1:1 --qpfile GENERATED_QP_FILE --non-deterministic --range tv --colormatrix bt470bg --demuxer raw --input-res 48x48 --input-csp i420 --input-range tv --input-depth 8 --fps 25/1 --output-depth 8 --output OUTPUTFILE -
  • Save a Global Profile (Config->Profiles->Global profile->Save global profile)
  • Closed Hybrid
  • Started Hybrid
  • Apply the Global Profile  (Config->Profiles->Global profile->Aplly global profile)
I then looked at the x264 Configuration and it shows:
x264 --crf 18.00 --profile high --level 4.1 --bluray-compat --keyint 50 --min-keyint 1 --b-pyramid strict --sync-lookahead 1 --rc-lookahead 25 --slices 4 --qpmax 51 --mvrange 511 --weightp 1 --vbv-maxrate 40000 --vbv-bufsize 30000 --nal-hrd cbr --sar 1:1 --qpfile GENERATED_QP_FILE --non-deterministic --range tv --colormatrix bt470bg --demuxer raw --input-res 48x48 --input-csp i420 --input-range tv --input-depth 8 --fps 25/1 --output-depth 8 --output OUTPUTFILE -

Quote:They are different:
X264>Frames, Max GOP = 25 (instead of 50), no way to change it 50 the values do not go above 25.
Okay, that should not be. And is not the case here.
Looking at code to when Hybrid changes the max allowed gop size:
  int bitrate = model->intValue(QString("bitrate"));
  int gopMax = model->intValue(QString("gopMaximum")); //gopMaximum is the keyint value
  int max;
  if (hardware == QString("Blu-ray/AVCHD")) {
    if (bitrate <= 15000) {
      max = (2 * gopMax < 1) ? 1 : 2 * int(model->doubleValue(QString("videoFramerate")) + 0.5); // 2 sec GOP
    } else {
      max = (gopMax < 1) ? 1 : int(model->doubleValue(QString("videoFramerate")) + 0.5); // 1 sec GOP
    }
  } else if (hardware == QString("AVC-Intra")) {
    max = 1;
  } else {
    max = 10000;
  }
  this->doSet(model, QString("gopMaximum"), MAXIMUM, QVariant(max));  //gopMaximum is the keyint value
So the restriction to '1-sec gop' should only be set by Hybrid if the bit rate is > 15000 kbit/s.


Quote:And X264>Base>Restriction Settings->Preset-None, not Medium.
Like I wrote before the preset setting in the drop-down is not saved since it it's not a strict restriction but something that get's applied. So this is as intended.

Quote:Also you mentioned as an option to enable 'Config->Profiles->Auto save', this way Hybrid will remember all the settings. It looks like does not work either. After restarting Hybrid the Preset is None, settings show accordingly: x264 --preset fast -. If I press/apply Medium, settings change, but X264>Frames Min/Max GOP values change to defaults. If I change them, the settings window shows : x264 --preset fast -. But Preset stays at Medium. It all jumping back and forth.
The preset selection is NOT saved, since it caused to much confusion with users, that setting only does something when 'Apply preset' is used.
No clue what you are doing, I again need details, to try to reproduce what you are doing.
My guess is that you changed some setting that is influencing Hybrids settings. May be it helps to reset the Hybrid defaults ('Config->Reset->Defaults->All->Reset selected').

Sadly unless I can reproduce what your are doing I can't fix a potential bug.


Cu Selur

Ps.: Please do not reply inside quotes, it really is annoying having to read through quotes to see whether you added something to them.
Reply
#16
Quote:It tells again that all x264->Base->Restriction Settings have to be set first (including Medium), before General settings, before going in to X264>Frames and etc.
That is correct it doesn't make sense otherwise, since the restiction settings change the other settings so that they respect the restiction.


The problem is the command line where "--bitrate 22500 --profile high --level 4.1 --bluray-compat --keyint 50" is used.
Hybrid should automatically restrict the key int there again.
-> will fix.
If the bitrate > 22500 2sec gop is not allowed.

Cu Selur
Reply
#17
Selur, I appreciate your efforts trying to resolve the issue I have.
Still problems with Max GOP value setting.
 
This is what I did:
Uninstalled Hybrid, cleaned registry, Installed Hybrid.
Showing step by step:
  •  Start Hybrid
  • x264->Base->General Settings-> changing Bitrate from 1500kbps (default value) to 22500kbps (now the restriction to '1-sec gop' is OK to be set).
  • Enable '264->Base->Restriction Settings->Hardware'
  • Select '264->Base->Restriction Settings->Hardware->Blu-ray/AVCHD'
 
Command line now is:
x264 --preset veryfast --pass 1 --bitrate 22500 --profile high --level 4.1 --bluray-compat --keyint 25 --b-pyramid strict --direct auto --b-adapt 0 --sync-lookahead 12 --qcomp 0.50 --rc-lookahead 40 --slices 4 --qpmax 51 --mvrange 511 --aq-mode 0 --nal-hrd cbr --sar 1:1 --qpfile GENERATED_QP_FILE --non-deterministic --range tv --stats "PATH TO THE .stats FILE" --demuxer raw --input-res 48x48 --input-csp i420 --input-range tv --input-depth 8 --fps 25/1 --output-depth 8 --output NUL -
 
x264 --preset veryfast --pass 2 --bitrate 22500 --profile high --level 4.1 --bluray-compat --ref 3 --keyint 25 --b-pyramid strict --direct auto --b-adapt 0 --sync-lookahead 12 --qcomp 0.50 --rc-lookahead 40 --slices 4 --qpmax 51 --partitions i4x4,p8x8,b8x8 --no-fast-pskip --mvrange 511 --subme 5 --aq-mode 0 --vbv-maxrate 40000 --vbv-bufsize 30000 --nal-hrd cbr --sar 1:1 --qpfile GENERATED_QP_FILE --non-deterministic --range tv --colormatrix bt470bg --stats "PATH TO THE .stats FILE" --demuxer raw --input-res 48x48 --input-csp i420 --input-range tv --input-depth 8 --fps 25/1 --output-depth 8 --output OUTPUTFILE -
 
  • x264->Frames-> General Frame Settings->GOP size min/max, Max value = 25, does not allow to change to any value above 25.
 
I thought the the sequence is the key, a problem happens when the bitrate is set before setting  x264->Base->Restriction Settings->Hardware->Blu-ray/AVCHD, it still keeps the default bitrate values (1500kps in this case, even the Command Line shows: bitrate 22500) and does not allow to set the restriction to '1-sec gop.
 
I changed the sequence, set Restriction Settings->Hardware->Blu-ray/AVCHD' first, before changing the bitrate, it worked correctly:
  • Start Hybrid
  • Enable '264->Base->Restriction Settings->Hardware'
  • Select '264->Base->Restriction Settings->Hardware->Blu-ray/AVCHD'
 
It already changes from keyint 25 to keyint 50:
Command Line:
x264 --preset veryfast --pass 1 --bitrate 1500 --profile high --level 4.1 --bluray-compat --keyint 50 --b-pyramid strict --direct auto --b-adapt 0 --sync-lookahead 1 --qcomp 0.50 --rc-lookahead 40 --slices 4 --qpmax 51 --mvrange 511 --aq-mode 0 --nal-hrd cbr --sar 1:1 --qpfile GENERATED_QP_FILE --non-deterministic --range tv --stats "PATH TO THE .stats FILE" --demuxer raw --input-res 48x48 --input-csp i420 --input-range tv --input-depth 8 --fps 25/1 --output-depth 8 --output NUL -
 
x264 --preset veryfast --pass 2 --bitrate 1500 --profile high --level 4.1 --bluray-compat --ref 3 --keyint 50 --b-pyramid strict --direct auto --b-adapt 0 --sync-lookahead 1 --qcomp 0.50 --rc-lookahead 40 --slices 4 --qpmax 51 --partitions i4x4,p8x8,b8x8 --no-fast-pskip --mvrange 511 --subme 5 --aq-mode 0 --vbv-maxrate 40000 --vbv-bufsize 30000 --nal-hrd cbr --sar 1:1 --qpfile GENERATED_QP_FILE --non-deterministic --range tv --colormatrix bt470bg --stats "PATH TO THE .stats FILE" --demuxer raw --input-res 48x48 --input-csp i420 --input-range tv --input-depth 8 --fps 25/1 --output-depth 8 --output OUTPUTFILE -
 
Now I can change Max GOP value, actually under x264->Frames-> General Frame Settings->GOP size max is already set/shows 50. 
 
Next step:
  • Enable 'x264->Base->Restriction Settings->Preset' to 'medium'
  • Apply the preset ('x264->Base->Restriction Settings->Preset->Apply Preset')
 
 
Command Line:
x264 --preset veryfast --pass 1 --bitrate 1500 --profile high --level 4.1 --bluray-compat --keyint 50 --b-pyramid strict --sync-lookahead 1 --rc-lookahead 40 --slices 4 --qpmax 51 --mvrange 511 --nal-hrd cbr --sar 1:1 --qpfile GENERATED_QP_FILE --non-deterministic --range tv --stats "PATH TO THE .stats FILE" --demuxer raw --input-res 48x48 --input-csp i420 --input-range tv --input-depth 8 --fps 25/1 --output-depth 8 --output NUL -
 
x264 --pass 2 --bitrate 1500 --profile high --level 4.1 --bluray-compat --keyint 50 --b-pyramid strict --sync-lookahead 1 --slices 4 --qpmax 51 --mvrange 511 --weightp 1 --vbv-maxrate 40000 --vbv-bufsize 30000 --nal-hrd cbr --sar 1:1 --qpfile GENERATED_QP_FILE --non-deterministic --range tv --colormatrix bt470bg --stats "PATH TO THE .stats FILE" --demuxer raw --input-res 48x48 --input-csp i420 --input-range tv --input-depth 8 --fps 25/1 --output-depth 8 --output OUTPUTFILE -
 
As you can see, applying Medium changed the Bitrate to default value 1500kbps.
 
  • x264->Frames-> General Frame Settings-> just checking GOP size, Max value remains the same 50. But again, the bitrate is changed to 1500kbps. From 22500 set before.
 
Going back to:
  • x264->Base->General Settings-> changing Bitrate from 1500kbps to 22500kbps
 
Command Line, now is OK:
x264 --preset veryfast --pass 1 --bitrate 22500 --profile high --level 4.1 --bluray-compat --keyint 50 --b-pyramid strict --sync-lookahead 1 --rc-lookahead 40 --slices 4 --qpmax 51 --mvrange 511 --nal-hrd cbr --sar 1:1 --qpfile GENERATED_QP_FILE --non-deterministic --range tv --stats "PATH TO THE .stats FILE" --demuxer raw --input-res 48x48 --input-csp i420 --input-range tv --input-depth 8 --fps 25/1 --output-depth 8 --output NUL -
 
x264 --pass 2 --bitrate 22500 --profile high --level 4.1 --bluray-compat --keyint 50 --b-pyramid strict --sync-lookahead 1 --slices 4 --qpmax 51 --mvrange 511 --weightp 1 --vbv-maxrate 40000 --vbv-bufsize 30000 --nal-hrd cbr --sar 1:1 --qpfile GENERATED_QP_FILE --non-deterministic --range tv --colormatrix bt470bg --stats "PATH TO THE .stats FILE" --demuxer raw --input-res 48x48 --input-csp i420 --input-range tv --input-depth 8 --fps 25/1 --output-depth 8 --output OUTPUTFILE –
 
Now is OK.
It tells again that all x264->Base->Restriction Settings have to be set first (including Medium), before General settings, before going in to X264>Frames and etc.
 
Checking this idea:
  • Start Hybrid
  • Enable '264->Base->Restriction Settings->Hardware'
  • Select '264->Base->Restriction Settings->Hardware->Blu-ray/AVCHD'
  • Enable 'x264->Base->Restriction Settings->Preset' to 'medium'
  • Apply the preset ('x264->Base->Restriction Settings->Preset->Apply Preset')
 
Command Line:
x264 --preset veryfast --pass 1 --bitrate 1500 --profile high --level 4.1 --bluray-compat --keyint 50 --b-pyramid strict --sync-lookahead 12 --rc-lookahead 40 --slices 4 --qpmax 51 --mvrange 511 --nal-hrd cbr --sar 1:1 --qpfile GENERATED_QP_FILE --non-deterministic --range tv --stats "PATH TO THE .stats FILE" --demuxer raw --input-res 48x48 --input-csp i420 --input-range tv --input-depth 8 --fps 25/1 --output-depth 8 --output NUL -
 
x264 --pass 2 --bitrate 1500 --profile high --level 4.1 --bluray-compat --keyint 50 --b-pyramid strict --sync-lookahead 12 --slices 4 --qpmax 51 --mvrange 511 --weightp 1 --vbv-maxrate 40000 --vbv-bufsize 30000 --nal-hrd cbr --sar 1:1 --qpfile GENERATED_QP_FILE --non-deterministic --range tv --colormatrix bt470bg --stats "PATH TO THE .stats FILE" --demuxer raw --input-res 48x48 --input-csp i420 --input-range tv --input-depth 8 --fps 25/1 --output-depth 8 --output OUTPUTFILE -
 
  • x264->Base->General Settings-> changing Bitrate from 1500kbps to 22500kbps
  • x264->Frames-> General Frame Settings-> just checking GOP size, Max value remains the same 50. All good.
 
Command Line now is correct:
x264 --preset veryfast --pass 1 --bitrate 22500 --profile high --level 4.1 --bluray-compat --keyint 50 --b-pyramid strict --sync-lookahead 12 --rc-lookahead 40 --slices 4 --qpmax 51 --mvrange 511 --nal-hrd cbr --sar 1:1 --qpfile GENERATED_QP_FILE --non-deterministic --range tv --stats "PATH TO THE .stats FILE" --demuxer raw --input-res 48x48 --input-csp i420 --input-range tv --input-depth 8 --fps 25/1 --output-depth 8 --output NUL -
 
x264 --pass 2 --bitrate 22500 --profile high --level 4.1 --bluray-compat --keyint 50 --b-pyramid strict --sync-lookahead 12 --slices 4 --qpmax 51 --mvrange 511 --weightp 1 --vbv-maxrate 40000 --vbv-bufsize 30000 --nal-hrd cbr --sar 1:1 --qpfile GENERATED_QP_FILE --non-deterministic --range tv --colormatrix bt470bg --stats "PATH TO THE .stats FILE" --demuxer raw --input-res 48x48 --input-csp i420 --input-range tv --input-depth 8 --fps 25/1 --output-depth 8 --output OUTPUTFILE -
 
  • Save a Global Profile (Config->Profiles->Global profile->Save global profile)
  • Closed Hybrid
  • Started Hybrid
  • Apply the Global Profile (Config->Profiles->Global profile->Aplly global profile)
 
 
Command Line now is:
x264 --preset veryfast --pass 1 --bitrate 22500 --profile high --level 4.1 --bluray-compat --keyint 25 --b-pyramid strict --sync-lookahead 12 --rc-lookahead 25 --slices 4 --qpmax 51 --mvrange 511 --nal-hrd cbr --sar 1:1 --qpfile GENERATED_QP_FILE --non-deterministic --range tv --stats "PATH TO THE .stats FILE" --demuxer raw --input-res 48x48 --input-csp i420 --input-range tv --input-depth 8 --fps 25/1 --output-depth 8 --output NUL -
 
x264 --pass 2 --bitrate 22500 --profile high --level 4.1 --bluray-compat --keyint 25 --b-pyramid strict --sync-lookahead 12 --rc-lookahead 25 --slices 4 --qpmax 51 --mvrange 511 --weightp 1 --vbv-maxrate 40000 --vbv-bufsize 30000 --nal-hrd cbr --sar 1:1 --qpfile GENERATED_QP_FILE --non-deterministic --range tv --colormatrix bt470bg --stats "PATH TO THE .stats FILE" --demuxer raw --input-res 48x48 --input-csp i420 --input-range tv --input-depth 8 --fps 25/1 --output-depth 8 --output OUTPUTFILE -
 
 
Now is the problem:
  • x264->Frames-> General Frame Settings-> just checking GOP size, Max value is changed back to 25, cant be changed, Command Line shows accordingly.
The Command Line shows that Medium is applied:
x264 --pass 2
 
But anyway applying Medium again. It does not change the Command Line, it also does not allow to change up Max GOP from 25.
 
 
This is what I learned:
All x264->Base->Restriction Settings have to be set first (including Medium), before General settings, before going in to X264>Frames and etc.
 
But it still does not allow to properly save/store Global Profile.
After restarting Hybrid values are changed.
That problem still there.
Reply
#18
Quote:It tells again that all x264->Base->Restriction Settings have to be set first (including Medium), before General settings, before going in to X264>Frames and etc.
That is correct it doesn't make sense otherwise, since the restiction settings change the other settings so that they respect the restiction.


The problem is the command line where "--bitrate 22500 --profile high --level 4.1 --bluray-compat --keyint 50" is used.
Hybrid should automatically restrict the keyint to 25 there again.
-> will send you a link to a dev version (via PM) which fixes that in a 15min.


Cu Selur
Reply
#19
Now it works, but need to follow some sequence when applying settings.
 
A file that I want to process with Hybrid is 720x576 25i lossless HuffYUV (VHS PAL capture with VirtualDub).  I need to deinterlace it, encode with X264 as 50fps with max GOP = 50 at 22500kbps.
 
 
After starting Hybrid, in order to change/set x264->Frames-> General Frame Settings-> Max GOP size value to 50, an actual video file has to be loaded and the Deinterlacer QTGMC and Bob are enabled. It has to be done before trying to change Max GOP size.
 
If video file is not loaded, even the Deinterlacer QTGMC and Bob are enabled, file that goes in to H264 for encoding will be 50fps, but looks like Hybrid does not know about it before the file is loaded/open. Command Line shows that Min GOP is restricted to 25 (keyint 25).
 
And only after loading a video file, it becomes possible to change Max GOP value to 50.
 
An initial working sequence has to be as follows:
·       Starting Hybrid
·       Loading/Opening video file
·       Enable '264->Base->Restriction Settings->Hardware'
·       Select '264->Base->Restriction Settings->Hardware->Blu-ray/AVCHD'
·       Enable 'x264->Base->Restriction Settings->Preset' to 'medium'
·       Apply the preset ('x264->Base->Restriction Settings->Preset->Apply Preset')
·       Apply Filtering->Deinterlace>Preset>enable Bob
Now is OK to change Bitrate:
·       'x264->Base->General Settings>Bitrate set to 22500kbps.
 
(If Bitrate is set to 22500kbs before Bob is enabled, the Max GOPP value will be restricted to 25, in the Command Line keyint value changed from 50 to 25. )
 
Command Line:
x264 --preset veryfast --pass 1 --bitrate 22500 --profile high --level 4.1 --bluray-compat --keyint 50 --b-pyramid strict --sync-lookahead 12 --rc-lookahead 25 --slices 4 --mvrange 511 --nal-hrd cbr --sar 1:1 --qpfile GENERATED_QP_FILE --non-deterministic --range tv --stats "PATH TO THE .stats FILE" --demuxer raw --input-res 1280x720 --input-csp i420 --input-range tv --input-depth 8 --fps 50/1 --output-depth 8 --output NUL -
 
x264 --pass 2 --bitrate 22500 --profile high --level 4.1 --bluray-compat --keyint 50 --b-pyramid strict --sync-lookahead 12 --rc-lookahead 25 --slices 4 --mvrange 511 --weightp 1 --vbv-maxrate 40000 --vbv-bufsize 30000 --nal-hrd cbr --sar 1:1 --qpfile GENERATED_QP_FILE --non-deterministic --range tv --colormatrix bt470bg --stats "PATH TO THE .stats FILE" --demuxer raw --input-res 1280x720 --input-csp i420 --input-range tv --input-depth 8 --fps 50/1 --output-depth 8 --output OUTPUTFILE –
 
·       Save a Global Profile (Config->Profiles->Global profile->Save global profile)
·       Close Hybrid
·       Start Hybrid
·       Apply the Global Profile (Config->Profiles->Global profile->Aplly global profile)
 
Since video file was not open yet, the Max GOP value will be restricted to 25.
Global Profile did not set this parameter (the video file has to be opened in order to set Max GOP to 50).
 
·       Loading/Opening video file
 
Now the Max GOP can be set either manually:
 
·       x264->Frames-> General Frame Settings-> GOP size, set Max value to 50.
 
Or by applying saved configuration, if there is saved configuration:
 
·       x264->Configuration> Configuration Select>Configuration Apply
 
Command Line (same as before closing Hybrid):
x264 --preset veryfast --pass 1 --bitrate 22500 --profile high --level 4.1 --bluray-compat --keyint 50 --b-pyramid strict --sync-lookahead 12 --rc-lookahead 25 --slices 4 --mvrange 511 --nal-hrd cbr --sar 1:1 --qpfile GENERATED_QP_FILE --non-deterministic --range tv --stats "PATH TO THE .stats FILE" --demuxer raw --input-res 1280x720 --input-csp i420 --input-range tv --input-depth 8 --fps 50/1 --output-depth 8 --output NUL -
 
x264 --pass 2 --bitrate 22500 --profile high --level 4.1 --bluray-compat --keyint 50 --b-pyramid strict --sync-lookahead 12 --rc-lookahead 25 --slices 4 --mvrange 511 --weightp 1 --vbv-maxrate 40000 --vbv-bufsize 30000 --nal-hrd cbr --sar 1:1 --qpfile GENERATED_QP_FILE --non-deterministic --range tv --colormatrix bt470bg --stats "PATH TO THE .stats FILE" --demuxer raw --input-res 1280x720 --input-csp i420 --input-range tv --input-depth 8 --fps 50/1 --output-depth 8 --output OUTPUTFILE -
 
The Command Line is same as before without even applying Medium.
But we know that Medium cannot be saved under x264->Configuration or Global Profile.
Let’s try to apply Medium.
 
·       Enable 'x264->Base->Restriction Settings->Preset' to 'medium'
 
No changes, Command Line shows the same.
 
Looks like Medium was saved somehow under Configuration.
 
 
The problem was that the Global Profile (after closing/starting Hybrid) has to be applied with no video loaded, the Max GOP values will not be allowed and applied properly.
 
This effect and the problem with the command line (that you fixed on 2021.02.21) combined together resulted in bizarre Hybrid behavior that I had trying to save configurations.
It is all good now, just need to follow the sequence when applying settings.
Reply
#20
Selur, looks like the problem still there.
The problem happens trying to apply saved Configuration settings and applying Preset Medium.
 
I narrowed it down, only few settings have to be changed and applying Preset Medium in order to catch this issue. Just please follow few steps:
 
·       Start Hybrid (after fresh install)
·       Open Video file
·       X264>Base>Configuration>choosing, applying “H264 Hybrid Default” (For some reason need to click Configuration Apply arrow twice in order to stop data changing in the Command Line window. After second click it was changed).
·       Enable '264->Base->Restriction Settings->Hardware'
·       Select '264->Base->Restriction Settings->Hardware->Blu-ray/AVCHD'
·       X264>Frames>Max Number of Reference Frames – setting slider to 5
 
Command Line:
x264 --preset veryfast --pass 1 --bitrate 1500 --profile high --level 4.1 --bluray-compat --keyint 50 --min-keyint 1 --b-pyramid strict --direct auto --b-adapt 0 --sync-lookahead 1 --qcomp 0.50 --rc-lookahead 40 --slices 4 --qpmax 51 --mvrange 511 --aq-mode 0 --nal-hrd cbr --sar 1:1 --qpfile GENERATED_QP_FILE --non-deterministic --range tv --stats "PATH TO THE .stats FILE" --demuxer raw --input-res 1280x720 --input-csp i420 --input-range tv --input-depth 8 --fps 25/1 --output-depth 8 --output NUL -
 
x264 --preset veryfast --pass 2 --bitrate 1500 --profile high --level 4.1 --bluray-compat --ref 5 --keyint 50 --min-keyint 1 --b-pyramid strict --direct auto --b-adapt 0 --sync-lookahead 1 --qcomp 0.50 --rc-lookahead 40 --slices 4 --qpmax 51 --partitions i4x4,p8x8,b8x8 --no-fast-pskip --mvrange 511 --subme 5 --aq-mode 0 --vbv-maxrate 40000 --vbv-bufsize 30000 --nal-hrd cbr --sar 1:1 --qpfile GENERATED_QP_FILE --non-deterministic --range tv --colormatrix bt470bg --stats "PATH TO THE .stats FILE" --demuxer raw --input-res 1280x720 --input-csp i420 --input-range tv --input-depth 8 --fps 25/1 --output-depth 8 --output OUTPUTFILE –
 
·       Saving as new Configuration preset under new .hml file name.
·       Close Hybrid
 
·       Start Hybrid
·       Open same Video file
 
Command Line:
x264 --preset veryfast --pass 1 --bitrate 1500 --profile high --level 4.1 --direct auto --b-adapt 0 --sync-lookahead 12 --qcomp 0.50 --rc-lookahead 40 --qpmax 51 --aq-mode 0 --sar 1:1 --qpfile GENERATED_QP_FILE --non-deterministic --range tv --stats "PATH TO THE .stats FILE" --demuxer raw --input-res 720x576 --input-csp i420 --input-range tv --input-depth 8 --fps 25/1 --output-depth 8 --output NUL -
 
x264 --preset veryfast --pass 2 --bitrate 1500 --profile high --level 4.1 --ref 3 --direct auto --b-adapt 0 --sync-lookahead 12 --qcomp 0.50 --rc-lookahead 40 --qpmax 51 --partitions i4x4,p8x8,b8x8 --no-fast-pskip --subme 5 --aq-mode 0 --vbv-maxrate 62500 --vbv-bufsize 78125 --sar 1:1 --qpfile GENERATED_QP_FILE --non-deterministic --range tv --colormatrix bt470bg --stats "PATH TO THE .stats FILE" --demuxer raw --input-res 720x576 --input-csp i420 --input-range tv --input-depth 8 --fps 25/1 --output-depth 8 --output OUTPUTFILE -
 
·       Applying before saved Configuration, a click on Configuration Apply arrow:
[font="Calibri", sans-serif] [/font]
Command Line:
x264 --preset veryfast --pass 1 --bitrate 1500 --profile high --level 4.1 --bluray-compat --keyint 50 --min-keyint 1 --b-pyramid strict --direct auto --b-adapt 0 --sync-lookahead 1 --qcomp 0.50 --rc-lookahead 25 --slices 4 --qpmax 51 --mvrange 511 --aq-mode 0 --nal-hrd cbr --sar 1:1 --qpfile GENERATED_QP_FILE --non-deterministic --range tv --stats "PATH TO THE .stats FILE" --demuxer raw --input-res 1280x720 --input-csp i420 --input-range tv --input-depth 8 --fps 25/1 --output-depth 8 --output NUL -
 
x264 --preset veryfast --pass 2 --bitrate 1500 --profile high --level 4.1 --bluray-compat --ref 5 --keyint 50 --min-keyint 1 --b-pyramid strict --direct auto --b-adapt 0 --sync-lookahead 1 --qcomp 0.50 --rc-lookahead 25 --slices 4 --qpmax 51 --partitions i4x4,p8x8,b8x8 --no-fast-pskip --mvrange 511 --subme 5 --aq-mode 0 --vbv-maxrate 40000 --vbv-bufsize 30000 --nal-hrd cbr --sar 1:1 --qpfile GENERATED_QP_FILE --non-deterministic --range tv --colormatrix bt470bg --stats "PATH TO THE .stats FILE" --demuxer raw --input-res 1280x720 --input-csp i420 --input-range tv --input-depth 8 --fps 25/1 --output-depth 8 --output OUTPUTFILE –
 
For some reason Command Line shows that value “25 –slices” is changed from “40 –slices” that was on the Command Line before closing/restarting Hybrid.
 
Now I want to apply Preset Medium:
  • Enable 'x264->Base->Restriction Settings->Preset' to 'medium'
  • Apply the preset ('x264->Base->Restriction Settings->Preset->Apply Preset')
 
Now is the Problem:
·      X264>Frames>Max Number of Reference Frames number has changed back to 3.
·      GOP Size Min value also changed from 1 to 0.
 
Command Line has changed:
x264 --preset veryfast --pass 1 --bitrate 1500 --profile high --level 4.1 --bluray-compat --keyint 50 --b-pyramid strict --sync-lookahead 1 --rc-lookahead 25 --slices 4 --mvrange 511 --nal-hrd cbr --sar 1:1 --qpfile GENERATED_QP_FILE --non-deterministic --range tv --stats "PATH TO THE .stats FILE" --demuxer raw --input-res 1280x720 --input-csp i420 --input-range tv --input-depth 8 --fps 25/1 --output-depth 8 --output NUL -
 
x264 --pass 2 --bitrate 1500 --profile high --level 4.1 --bluray-compat --keyint 50 --b-pyramid strict --sync-lookahead 1 --rc-lookahead 25 --slices 4 --mvrange 511 --weightp 1 --vbv-maxrate 40000 --vbv-bufsize 30000 --nal-hrd cbr --sar 1:1 --qpfile GENERATED_QP_FILE --non-deterministic --range tv --colormatrix bt470bg --stats "PATH TO THE .stats FILE" --demuxer raw --input-res 1280x720 --input-csp i420 --input-range tv --input-depth 8 --fps 25/1 --output-depth 8 --output OUTPUTFILE –
 
 
If I change slider back to 5, GOP Size Min to 1:
·       X264>Frames>Max Number of Reference Frames – setting slider to 5
 
Command Line shows that Medium preset is no longer applied (even if Medium it still shown on Resrrcition Settings), preset fast:
x264 --preset veryfast --pass 1 --bitrate 1500 --profile high --level 4.1 --bluray-compat --keyint 50 --min-keyint 1 --b-pyramid strict --sync-lookahead 1 --rc-lookahead 25 --slices 4 --mvrange 511 --nal-hrd cbr --sar 1:1 --qpfile GENERATED_QP_FILE --non-deterministic --range tv --stats "PATH TO THE .stats FILE" --demuxer raw --input-res 1280x720 --input-csp i420 --input-range tv --input-depth 8 --fps 25/1 --output-depth 8 --output NUL -
 
x264 --preset fast --pass 2 --bitrate 1500 --profile high --level 4.1 --bluray-compat --ref 5 --keyint 50 --min-keyint 1 --b-pyramid strict --sync-lookahead 1 --rc-lookahead 25 --slices 4 --mvrange 511 --subme 7 --vbv-maxrate 40000 --vbv-bufsize 30000 --nal-hrd cbr --sar 1:1 --qpfile GENERATED_QP_FILE --non-deterministic --range tv --colormatrix bt470bg --stats "PATH TO THE .stats FILE" --demuxer raw --input-res 1280x720 --input-csp i420 --input-range tv --input-depth 8 --fps 25/1 --output-depth 8 --output OUTPUTFILE -
 
Command Line shows: preset fast --pass 2 --– no longer Medium applied.
 
From now it is no way to get Reference Frames number 5 and Medium applied at the same time!
If I change them they jump back and forth.
 
If I press arrow Apply Preset (Medium is already shown):
  • Apply the preset ('x264->Base->Restriction Settings->Preset->Apply Preset')
 
·       X264>Frames>Max Number of Reference Frames number has changed back to 3.
·       GOP Size Min value also changed from 1 to 0.
 
Command Line shows that Medium is applied:
x264 --pass 2 -
 
If I change Max Number of Reference Frames slider back to 5, GOP Size Min to 1:
 
Command Line shows: preset fast --pass 2 --– no longer Medium applied.
 
And so on and so on.
 
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)