[GUIDE] Ubuntu repository - maintained by djcj
#1
Information 
First of all, I did not package the Hybrid binary itself, as that would be a license violation. But I made a package that will download the binary at startup and save it in $HOME/.hybrid-bin/.

To add the ppa type:
sudo add-apt-repository ppa:djcj/hybrid
sudo apt-get update

The following packages are available and can be installed with sudo apt-get install xxx :
  • hybrid - the actual Hybrid launcher
  • hybrid-tools - A package to enable downloads of Hybrid's helper tools. To add non-free packages run hybrid-get-nonfree-tools after installation.
  • hybrid-avisynth-extension - The AviSynth extension. It's in a separate package because it depends on wine.
  • hybrid-vapoursynth-extension - A meta-package that installs VapourSynth, the VSeditor and a collection of plugins.
  • dvdcopy - A bad-sectors resistant DVD-to-disc command-line program. This tool is not used by Hybrid! You have to use it manually if you think it might come in handy.


There are some command line options available:
SYNOPSIS
       hybrid [options] [<QT options>]

OPTIONS
       --log
              save a log file in ~/.hybrid/logs/

       --no-update
              don't check for available updates on startup

       --disable-updates
              disable automatic updates

       --enable-updates
              enable automatic updates

       --rollback
              Switch  back  to  the  previous  version if a backup is available.
              This disables automatic updates.  A backup of the currently installed version
              is automatically saved in ~/.hybrid-bin/ when upgrading to a new version.

       -h, --help
              show usage information

       -V, --version
              show the current version and quit
More information can be obtained with man hybrid.

If Hybrid doesn't start after an update or if it doesn't recognize AviSynth when it should, you could try to delete the locally installed files (~/.hybrid-bin/ and ~/.hybrid/misc.ini) and let the starter script re-download everything.
Please, read the 'Infos needed to fix&reproduce bugs,..'-sticky before you post about a problem.
Reply
#2
Hey, thanks for setting up this PPA.

So, I was able to install the hybrid, hybrid-tools, and hybrid-avisynth-extension packages just fine. Unfortunately, hybrid-get-nonfree-tools has problems shortly after it downloads faac. The script fails and quits at this point. I'm running Ubuntu 16.04.3.

It turns out that you have to run "apt-get install libtool" to fix the issue. Could libtool be worth adding to one of the packages on the PPA?
Reply
#3
(15.08.2017, 05:47)blazin Wrote: It turns out that you have to run "apt-get install libtool" to fix the issue. Could libtool be worth adding to one of the packages on the PPA?

I've added a libtool/libtoolize check to the build script. I will update the packages on the PPA too. I've also updated faac to 1.29.3 (you have to run hybrid-get-nonfree-tools again to update it).
Reply
#4
Hi, djcj, there is an important problem in the latest packages of hybrid-avisynth-extension! I don't know in which version it has started, but there is no "avisynth.dll" in "avisynthPlugins" folder, which stops Avisynth from running and working, and leads to Avisynth plugins not being available in Filtering tab in Hybrid.

One more problem: fft3dfilter.dll is not recognised, as it is required to be called "FFT3DFilter.dll".

[Image: obMwbT2.png]"

P.S. Both of problems were fixed.
Reply
#5
Installed a new Ubuntu 16.04 and then called:
sudo apt-get update && sudo apt-get -y dist-upgrade && sudo apt-get -y autoclean && sudo apt-get -y autoremove && sudo reboot
after a restart, I then called:
sudo add-apt-repository ppa:djcj/hybrid
sudo apt-get update
sudo apt-get install hybrid-vapoursynth-extension
and got:
Paketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut.      
Statusinformationen werden eingelesen.... Fertig
Einige Pakete konnten nicht installiert werden. Das kann bedeuten, dass
Sie eine unmögliche Situation angefordert haben oder, wenn Sie die
Unstable-Distribution verwenden, dass einige erforderliche Pakete noch
nicht erstellt wurden oder Incoming noch nicht verlassen haben.
Die folgenden Informationen helfen Ihnen vielleicht, die Situation zu lösen:

Die folgenden Pakete haben unerfüllte Abhängigkeiten:
hybrid-vapoursynth-extension : Hängt ab von: vapoursynth-editor ist aber nicht installierbar
E: Probleme können nicht korrigiert werden, Sie haben zurückgehaltene defekte Pakete.
calling:
apt-cache search vapoursynth
gave me:
vapoursynth - frameserver for the 21st century
libvapoursynth-dev - frameserver for the 21st century - development files
vapoursynth-python3 - frameserver for the 21st century - Python 3 module
vspipe - pipe the output of a Vapoursynth script
vapoursynth-dbg - frameserver for the 21st century - debug symbols
vapoursynth-extra-plugins - Additional plugins for VapourSynth
vapoursynth-docs - frameserver for the 21st century - documentation
libvapoursynth - frameserver for the 21st century
libvapoursynth-script0 - frameserver for the 21st century - VSScript runtime
vapoursynth-waifu2x-models - model files for the waifu2x VapourSynth plugin
hybrid-vapoursynth-extension - Hybrid VapourSynth support
d2vwitch - MPEG 1/2 stream indexer

-> Seems like 'vapoursynth-editor' is missing from the repository (sources can be found over at: https://github.com/Selur/vapoursynth-editor)

sudo apt-get install hybrid-get-nonfree-tools
also fails due to missing package,..

Cu Selur

Ps.: Same happens on 17.04
Reply
#6
I've added VSEditor.

PS:
@Selur can you create a diff with all important changes between your fork of vseditor and the original version?
Reply
#7
Not really, changed to much. Best stick with the one I use, probably will through out more of the code it currently includes.
Reply
#8
If your fork differs relatively much from the upstream version, can't you rename it to something like vseditmod and let Hybrid only use vsedit if there's not vseditmod in PATH? That way someone can still use the upstream version.
Reply
#9
Should be possible, will try to look into it tomorrow.

Cu Selur
Reply
#10
@djcj: released a new version, didn't get around to change the name of vsedit. Simply extracting the avisynthExtension package into the .hybrid-bin/avisynth-folder should be okay now.

Cu Selur
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)