Remove Vertical Lines in movie
#1
Hi.
I want help to clearing up a movie with Vertical Lines!
The first image is my original movie, and the second is my encoded with DeGrain.
What are these vertical lines? And how to clear up them?


Attached Files Thumbnail(s)
       
Reply
#2
DeGrain is the wrong filter for this, that is no grain or noise.
Looks more like a job for Avisynths DeFreq (https://avisynth.org.ru/defreq/defreq.html), Vapoursynths vcFreq (http://www.avisynth.nl/users/vcmohan/vcfreq/vcfreq.html) or Avisynths DeStripe (http://avisynth.nl/index.php/DeStripe) which are all not supported in Hybrid.
Also just saw something through my online search which looks like your problem: https://forum.doom9.org/showthread.php?t=163574
-> if you can share a few second long sample I can try looking into it some more.

Cu Selur
Reply
#3
(14.03.2018, 13:26)Selur Wrote: DeGrain is the wrong filter for this, that is no grain or noise.
Looks more like a job for Avisynths DeFreq (https://avisynth.org.ru/defreq/defreq.html), Vapoursynths vcFreq (http://www.avisynth.nl/users/vcmohan/vcfreq/vcfreq.html) or Avisynths DeStripe (http://avisynth.nl/index.php/DeStripe) which are all not supported in Hybrid.
Also just saw something through my online search which looks like your problem: https://forum.doom9.org/showthread.php?t=163574
-> if you can share a few second long sample I can try looking into it some more.

Cu Selur

Thank you very much for your guide.
Here, the sample for testing.

https://www.mirrorcreator.com/files/1IIZPPHL/In_America_(2002).mkv_links
Reply
#4
Got the file will look into it.

Cu Selur
Reply
#5
That file doesn't have any vertical lines such as you showed,.. -> seems like this is a playback problem on your end or the wrong sample.
In case you use a Radeon card, make sure you turn off the demo or any addition filtering in the video settings in your Radeon settings.

Cu Sekzr
Reply
#6
(14.03.2018, 14:55)Selur Wrote: That file doesn't have any vertical lines such as you showed,.. -> seems like this is a playback problem on your end or the wrong sample.
In case you use a Radeon card, make sure you turn off the demo or any addition filtering in the video settings in your Radeon settings.

Cu Sekzr

In normal play can't see those vertical lines, but with shaders in mpchc you can see vertical lines.
Reply
#7
Quote:In normal play can't see those vertical lines, but with shaders in mpchc you can see vertical lines.
Then what makes you think this is an artifact in the source that you can remove and not a bug in the shader implementation or mpc-hc?

---
That aside I think I see something like those artifacts in the short scene (cut in) where the flower opens (frame 526-672).
So do you also only see those artifacts in that scene?

Cu Selur
Reply
#8
(14.03.2018, 15:33)Selur Wrote:
Quote:In normal play can't see those vertical lines, but with shaders in mpchc you can see vertical lines.
Then what makes you think this is an artifact in the source that you can remove and not a bug in the shader implementation or mpc-hc?

---
That aside I think I see something like those artifacts in the short scene (cut in) where the flower opens (frame 526-672).
So do you also only see those artifacts in that scene?

Cu Selur

Yes, In that scene you can see without any shader. but if you use shader, can see those vertical lines in the all scene.
Reply
#9
Give me more details, because I can't see those artifacts when I just add a shader.
Just added Denoise to pre-resizing and the artifacts are still only in that scene.

Cu Selur

Ps.: if you overclocked you gpu in any way or it is overclocked by default, this might be caused by overclocking,...
Reply
#10
I use this shader to see that vertical lines:

(14.03.2018, 15:46)Selur Wrote: Give me more details, because I can't see those artifacts when I just add a shader.
Just added Denoise to pre-resizing and the artifacts are still only in that scene.

Cu Selur

Ps.: if you overclocked you gpu in any way or it is overclocked by default, this might be caused by overclocking,...

Add that shader file in mpc-hc Shader presets and enable it.

Go to:

mpc-hc>View>Options...>Shaders

Click on "Add Shader file" and select shader file

Select Shader file in left box and click on "add to pre-resize"

Add a name for it on the "Shader presets" box and click on save.

Now play movie in mpc-hc and click ctrl+z
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)