AV1 encode & decode build issue
#1
I have successfully git code the latest code from https://aomedia.googlesource.com/aom#get-the-code
and successfully generating the projects and solution for the Microsoft IDE.

I am currently stuck after this. I wish to generate .exe file for both encoder and decoder but when I run build on visual studio for aom_av1_encoder project there are some error LNK1181: cannot open input file'Release\aom.lib'

Does any one have any experiences in compiling the AV1 encode and decode source code in Windows OS?
Reply
#2
I use https://github.com/jb-alvarado/media-autobuild_suite to build aomenc and aomdec (and lots of other stuff).

Cu Selur

Ps.: Hybrid on Windows also has both binaries in its 64bit folder.
Reply
#3
(13.04.2018, 17:31)Selur Wrote: I use https://github.com/jb-alvarado/media-autobuild_suite to build aomenc and aomdec (and lots of other stuff).

Cu Selur

Ps.: Hybrid on Windows also has both binaries in its 64bit folder.

Thanks for your reply. Is there any difference between the AOM build version of the link you mentioned compared to the official released version? and what is the benefit of using this?
Reply
#4
The build suite creates a whole build environment on Windows to build aom (and other stuff) checks out the sources and builds the tools.
It's a way to build up-to-date versions of tools without having to manually check for updates etc.
-> Aside that it doesn't use MSVC the resulting .exe files should create the same results.

Cu Selur
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)