[BUG] Hybrid 2018.05.22.1 Windows 10 x64: video crashed: Crashed with exit status 0
#1
Hallo,

Hybrid 2018.05.22.1 auf Windows 10 x64 bringt reproduzierbar einen Fehler. Unter Hybrid 2018.04.08 hat noch alles geklappt. Im Log wird angezeigt:
-> 20_16_46_0410_02_video crashed: Crashed with exit status 0
Ich erstelle 'ganz normal' den Job um ein MKV mit x264 zu komprimieren. Die Einstellungen klicke ich mir im Reiter "x264" zusammen:
  • Ich lade die Konfiguration "x264 Hybrid Default",
  • wähle bei "Encoding Mode" "constant rate factor (1-pass),
  • bei "Quantization Factor" den Wert "21",
  • bei "Preset" "slower" und bei
  • "Tune" "film".
Der Job bricht dann wie oben angegeben ab.

Die HybridDebugOutput.txt habe ich angefügt.

Ansonsten ein tolles Programm, vielen Dank dafür!
Reply
#2
Ist ein Fehler im Encodingaufruf:
"C:\PROGRA~1\Hybrid\64bit\ffmpeg.exe" -y -loglevel fatal -threads 4 -i "F:\[mkv]\unkomprimiert\Video.mkv" -map 0:0 -an -sn  -vsync 0 -vf zscale=rangein=limited:range=limited -pix_fmt yuv420p  -f rawvideo - | "C:\PROGRA~1\Hybrid\64bit\x264.exe" --preset slower --crf 21.00 --profile high --level 4.1 --ref 4 --psy-rd 1.00:0.15 --vbv-maxrate 62500 --vbv-bufsize 78125 --sar 1:1 --qpfile "G:\[mkv]\Video_20_16_46_0410_01.qp" --deblock -1:-1 --non-deterministic--demuxer raw --input-res 1920x1080 --input-csp i420 --input-depth 8 --fps 24000/1001 --output-depth 8 --output "G:\[mkv]\20_16_46_0410_02.264" -
da fehlt ein Leerzeichen.
Quote: --non-deterministic--demuxer raw
müsste:
Quote: --non-deterministic --demuxer raw
sein.
Sehr merkwürdig.
-> Könntest Du mir einen kleinen Ausschnitt von der Quelle, mit dem man das Problem nachstellen kann (1 Sek. oder nur ein paar Frames reicht), irgendwo hochladen und mit mir teilen?
Vermute Hybrid macht da irgendwas abhängig von der Quelle, da ich das hier nicht nachgestellt bekomme.

Cu Selur
Reply
#3
Bei mir passiert das mit jedem Eingangsvideo. Ein entsprechendes einsekündiges (4,6 MiB) Video habe ich dir hier bereitgestellt:
https://bit.ly/2IVLQyq

Habe nochmal Hybrid 2018.04.08.1 installiert. Wenn ich nun dasselbe mache, ist da tatsächlich in diesem Feld unten auf der Registerkarte "x264" ein Leerzeichen vor dem "--demuxer raw", welches in Hybrid 2018.05.22.1 nicht ist.

Wenn bei "Encoding Mode" "constant rate factor (1-pass)" eingestellt ist, dann verschwindet dieses Leerzeichen in Hybrid 2018.05.22.1 in dem Moment, wo ich bei "Preset" etwas auswähle und auf "Apply Preset" klicke.
Reply
#4
Hier passiert das nicht.
Was ich mit einem frisch zurückgesetzten ('Config->Defaults->Reset->All' 'Apply') Hybrid mache:
  1. Hybrid starten
  2. Dein Video laden
  3. 'x264->Base->General Settings->Encoding Mode' auf 'constant rate factor (1-pass)' ändern
    Der x264 Aufruf sieht dann so aus:
    x264 --crf 18.00 --profile high --level 4.1 --direct auto --qcomp 0.5 --no-mbtree --partitions i4x4,p8x8,b8x8 --no-fast-pskip --subme 5 --trellis 0 --weightp 1 --aq-mode 0 --vbv-maxrate 62500 --vbv-bufsize 78125 --sar 1:1 --qpfile GENERATED_QP_FILE --non-deterministic --range tv --colormatrix bt709 --demuxer raw --input-res 1920x1080 --input-csp i420 --input-range tv --input-depth 8 --fps 24000/1001 --output-depth 8 --output OUTPUTFILE -
  4. 'x264->Base->Restriction->Settings->Preset' auf 'slower' setzen und 'Apply' drücken.
    Der x264 Aufruf sieht dann so aus:
    x264 --preset slower --crf 18.00 --profile high --level 4.1 --ref 4 --vbv-maxrate 62500 --vbv-bufsize 78125 --sar 1:1 --qpfile GENERATED_QP_FILE --non-deterministic --range tv --colormatrix bt709 --demuxer raw --input-res 1920x1080 --input-csp i420 --input-range tv --input-depth 8 --fps 24000/1001 --output-depth 8 --output OUTPUTFILE -
Wenn ich anschließend 'x264->Advanced' aktiviere und unter 'x264->VUI->Visual usability Information' alles deaktiviere sieht die Zeile immer noch richtig aus:
x264 --preset slower --crf 18.00 --profile high --level 4.1 --ref 4 --vbv-maxrate 62500 --vbv-bufsize 78125 --sar 1:1 --qpfile GENERATED_QP_FILE --non-deterministic --demuxer raw --input-res 1920x1080 --input-csp i420 --input-range tv --input-depth 8 --fps 24000/1001 --output-depth 8 --output OUTPUTFILE -

-> Schreib mir mal bitte Schritt für Schritt auf was Du machst um das Problem zu haben, nachdem Du Hybrid zurückgesetzt hast, damit ich das hier nachstellen kann.

Danke!

Cu Selur
Reply
#5
Habe es genau nach deiner Anleitung gemacht. Das klappt, da passt dann alles.

Der Unterschied zu meiner Vorgehensweise ist, dass ich zwischen deinen Schritten 2 und 3 noch einen Schritt 2a mache, in dem ich die Konfiguration "x264 Hybrid Default" auswähle und Apply drücke. Dadurch schaut dann (nach Schritt 4) der Aufruf so aus und das Leerzeichen fehlt:
x264 --preset slower --crf 18.00 --profile high --level 4.1 --ref 4 --vbv-maxrate 62500 --vbv-bufsize 78125 --sar 1:1 --qpfile GENERATED_QP_FILE --non-deterministic--demuxer raw --input-res 1920x1080 --input-csp i420 --input-depth 8 --fps 24000/1001 --output-depth 8 --output OUTPUTFILE -
Wenn ich dann aber bei VUI "color matrix:" deaktiviere kommt das Leerzeichen wieder:
x264 --preset slower --crf 18.00 --profile high --level 4.1 --ref 4 --vbv-maxrate 62500 --vbv-bufsize 78125 --sar 1:1 --qpfile GENERATED_QP_FILE --non-deterministic --demuxer raw --input-res 1920x1080 --input-csp i420 --input-depth 8 --fps 24000/1001 --output-depth 8 --output OUTPUTFILE -
Mit deinem Vorgehen klappt wie gesagt alles, damit kann ich gut leben. Ob mein bisheriges Vorgehen besonders sinnvoll ist weiß ich nicht, da kenne ich mich in der Materie zu wenig aus. Ich habe das bisher eher aus Gewohnheit so gemacht. Komisch ist aber trotzdem die Veränderung des Verhaltens zwischen den Versionen 2018.04.08.1 und 2018.05.22.1.

Ich habe zur Sicherheit erneut Hybrid heruntergeladen und in einer virtuellen Maschine installiert. Da ist das genauso.
Reply
#6
Treibt mich in den Wahnsinn. Ich kann das hier nicht nachstellen.

Was ich mache:
  • Hybrid starten
  • Dein Video laden
  • bei 'x264->Base->Configuration', 'x264 Hybrid Default' auswählen
  • bei 'x264->Base->Configuration->Apply' drücken, der Aufruf sieht entsprechend so aus:
    x264 --preset superfast --pass 1 --bitrate 1500 --profile high --level 4.1 --direct auto --sync-lookahead 15 --qcomp 0.5 --rc-lookahead 40 --aq-mode 0 --sar 1:1 --qpfile GENERATED_QP_FILE --non-deterministic --stats "PATH TO THE .stats FILE" --demuxer raw --input-res 1920x1080 --input-csp i420 --input-range tv --input-depth 8 --fps 24000/1001 --output-depth 8 --output NUL -

    x264 --pass 2 --bitrate 1500 --profile high --level 4.1 --direct auto --sync-lookahead 15 --qcomp 0.5 --no-mbtree --partitions i4x4,p8x8,b8x8 --no-fast-pskip --subme 5 --trellis 0 --weightp 1 --aq-mode 0 --vbv-maxrate 62500 --vbv-bufsize 78125 --sar 1:1 --qpfile GENERATED_QP_FILE --non-deterministic --colormatrix bt470bg --stats "PATH TO THE .stats FILE" --demuxer raw --input-res 1920x1080 --input-csp i420 --input-range tv --input-depth 8 --fps 24000/1001 --output-depth 8 --output OUTPUTFILE -
  • 'x264->Base->General Settings->Encoding Mode' auf 'constant rate factor (1-pass)' auf ändern
    Der Aufruf sieht dann so aus:
    x264 --crf 18.00 --profile high --level 4.1 --direct auto --sync-lookahead 15 --qcomp 0.5 --no-mbtree --partitions i4x4,p8x8,b8x8 --no-fast-pskip --subme 5 --trellis 0 --weightp 1 --aq-mode 0 --vbv-maxrate 62500 --vbv-bufsize 78125 --sar 1:1 --qpfile GENERATED_QP_FILE --non-deterministic --colormatrix bt470bg --demuxer raw --input-res 1920x1080 --input-csp i420 --input-range tv --input-depth 8 --fps 24000/1001 --output-depth 8 --output OUTPUTFILE -
  • 'x264->VUI->Video Usability Information->Color Matrix' deaktivieren. Der Aufruf sieht dann so aus:
    x264 --crf 18.00 --profile high --level 4.1 --direct auto --sync-lookahead 15 --qcomp 0.5 --no-mbtree --partitions i4x4,p8x8,b8x8 --no-fast-pskip --subme 5 --trellis 0 --weightp 1 --aq-mode 0 --vbv-maxrate 62500 --vbv-bufsize 78125 --sar 1:1 --qpfile GENERATED_QP_FILE --non-deterministic --demuxer raw --input-res 1920x1080 --input-csp i420 --input-range tv --input-depth 8 --fps 24000/1001 --output-depth 8 --output OUTPUTFILE -

-> Deinstalliere mal Hybrid komplett mit allen Settings. Installiere Hybrid 2018.05.22.1 und Schreibe wirklich jeden Schritt auf den Du machst.

Cu Selur
Reply
#7
Der Einfachkeit halber hier ein 45 sekündiges Screencapture-Video, welches mein Treiben dokumentiert:
https://bit.ly/2s9fdD7

Ist von einer frischen Hybrid-Installation auf einer virtuellen Windows 7 x64 Maschine. Hybrid wurde vorab "geresetet".
Reply
#8
Sehr strange, mache genau die gleichen Dinge und bei mir tritt der Effekt nicht auf.
-> Ich gucke drauf.
Reply
#9
Hier wie es bei mir aussieht.

Cu Selur
Reply
#10
Hab's vielleicht gefunden,.. schicke Dir gleich per PM nen Link zu ner Version zum Testen.

Cu Selur
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)