not working VP9 video
#11
(10.02.2019, 15:15)Selur Wrote: Avisynth script
C:\temp\encodingTempSynthSkript_20_48_49_3710.avs
looks okay:
LoadCPlugin("C:\PROGRA~1\Hybrid\32bit\AVISYN~1\ffms2.dll")
LoadPlugin("C:\PROGRA~1\Hybrid\32bit\AVISYN~1\masktools2.dll")
LoadPlugin("C:\PROGRA~1\Hybrid\32bit\AVISYN~1\ImageSequence.dll")
Import("C:\Program Files\Hybrid\32bit\avisynthPlugins\Logo.avs")
SetFilterMTMode("DEFAULT_MT_MODE", MT_MULTI_INSTANCE)
# loading source: D:\goop.mkv
#  input color sampling YV12
#  input luminance scale tv
FFVideoSource("D:\goop.mkv",cachefile="C:\temp\20_48_49_3710.ffindex",fpsnum=25)
# current resolution: 3840x2160
# filtering
# scaling
Spline36Resize(1280,720)
# current resolution: 1280x720
# adding logo
Logo("D:\good1.png",x=0,I=0,O=0,mode="Screen",Wstr=1.20)
PreFetch(4)
return last
Encoding call looks okay:
"C:\PROGRA~1\Hybrid\32bit\ffmpeg.exe" -y -loglevel fatal -threads 4 -i "C:\temp\encodingTempSynthSkript_20_48_49_3710.avs" -an -sn   -vf zscale=rangein=tv:range=tv -pix_fmt yuv420p -vsync 0  -f rawvideo - || "C:\PROGRA~1\Hybrid\64bit\x264.exe" --preset superfast --tune psnr --pass 1 --bitrate 1500 --profile high --level 3.1 --rc-lookahead 40 --weightp 2 --sar 1:1 --non-deterministic --range tv --stats "C:\temp\goop_20_48_49_3710_08.stats" --demuxer raw --input-res 1280x720 --input-csp i420 --input-range tv --input-depth 8 --fps 25/1 --output-depth 8 --output NUL
and looking at the debug output 227 frames get encoded (x264 output: 227 frames: 3.57 fps, 1583.51 kb/s), but then the decoder (in your case ffmpeg) crashed.
Seeing that the input has 276 my guess is that, either:
a. the source has a bug which causes FFVideoSource to crash
b. the decoding process causes Avisynth to use too much RAM
c. something else causes ffmpeg to crash

-> Assuming your source file is okay, and ffmpeg isn't using too much RAM and your system has no memory issue, try the following:
  • enable 'Filtering->Avisynth->Misc->Use FFms200'
  • if that doesn't help, enable 'Filtering->Avisynth->Misc->LibavVideoSource instead of FFmpegSource'
  • if that doesn't help, disable 'Config->Internals->Avisynth->Prefer FFmpeg as decoder' and enable 'Config->Internals->Avisynth->Prefer avs2yuv as decoder'
  • if that doesn't help, try using Vapoursynth instead of Avisynth
  • if that doesn't help, share the source and the logo with me so I can try to reproduce the issue here.

Cu Selur

enable 'Filtering->Avisynth->Misc->Use FFms200' (crashed)
if that doesn't help, enable 'Filtering->Avisynth->Misc->LibavVideoSource instead of FFmpegSource' (Successful coding)
if that doesn't help, disable 'Config->Internals->Avisynth->Prefer FFmpeg as decoder' and enable 'Config->Internals->Avisynth->Prefer avs2yuv as decoder' (crashed)
if that doesn't help, try using Vapoursynth instead of Avisynth (Successful coding)

thank you
Reply
#12
Okay, seems like FFmpegSource is having some problems with the source.
Happy you got a solution. Smile

Cu Selur
Reply
#13
(11.02.2019, 19:28)Selur Wrote: Okay, seems like FFmpegSource is having some problems with the source.
Happy you got a solution. Smile

Cu Selur

Thank you, can use your encoder again, very happy
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)