Problem/bug?: Start Timecode offset nur bei .ts Containern ?
#1
1.Was für eine Hybrid Version wurde verwendet?
Version : Windows 10 64bit mit Hybrid 2017.05.06.1
und MacOs 10.10 mit Hybrid 2017.05.06.1

2.Wie lautet die genaue Fehlermeldung (falls eine erstellt wurde)?
Keine Fehlermeldung. 
Start Timecode startet bei 4200 anstelle bei 0, wenn das File als .ts  Container gespeichert wird.
(Ausgelesen und Infos abgespeichert mit ffprobe). 

Der Fehler tritt unabhängig des Input-files auf (waren alle 4K)
Beim Speichern des gleichen Files als  .mkv oder .mp4 tritt das Problem nicht auf.
Der Fehler tritt unabhängig des Systems auf (macOs W10)

Das FileInformationen /Timecode wurde mit Hilfe von ffprobe ausgelesen und als csv gespeichert.

3. Wie wurde das Problem produziert ?

-> Test Files in Hybrid als Input geladen.
-> Main Tab: Einstellungen x265 / audio ignore oder pass through.
-> Main Tab: Output File definert:  xxx.ts   (TS Container)
-> x265 Tab:  Nur das Preset definiert (medium) , sonst keine Einstellungen verändert - Hybrid Default (CRF 18, 5.1, Main, High, 420) 
 
- Wie gesdagt: Bei gleichen Einstellungen aber Containertyp als mkv oder mp4 ensteht dieses Problem nicht.


4. Gezippte Files anbei: 
-> Eine Debug-Ausgabe
-> 2 csv Dateien generiert durch ffprobe: Timestamp/Frame,FrameTyp,Datenrate

5. Verwendete Files: 

->Elysium 2013 2160p – 1 Minute Sample Footage:
http://4ksamples.com/elysium-2013-2160p-...e-footage/

-> The_World_in_HDR_in_4K_HDR10.mkv
http://demo-uhd3d.com/fiche.php?cat=uhd&id=159  

Ich komme einfach nicht weiter: Wenn ich aus der Kommandozeile mit ffmpeg (und x265lib) encodiere, entsteht das Timecode Problem nicht.

Da ich relativ neu in diesem Bereich bin, befürchte ich, dass es trotzdem eher mein Konfigurationsfehler ist... ;(
Reply
#2
encoding call sieht korrekt auf:
"/Applications/Hybrid.app/Contents/MacOS/ffmpeg" -y -threads 8 -i "/Users/SebastianKraft/Desktop/The_World_in_HDR_in_4K_HDR10.mkv" -map 0:0 -an -sn  -vsync 0 -pix_fmt yuv420p  -f yuv4mpegpipe - | "/Applications/Hybrid.app/Contents/MacOS/x265" --preset ultrafast --input - --y4m --profile main --high-tier --level-idc 5.1 --bitrate 15000 --crf-min 0.00 --crf-max 0.00 --vbv-maxrate 160000 --vbv-bufsize 160000 --zones 0,20,q=0 --range limited --colormatrix bt709 --strict-cbr --output "/var/folders/0m/gzs59vm10w7df83rj6zw70km0000gn/T/12_36_38_0010_01.265"
Muxing parameter für tsMuxeR, sehen auch okay aus:
MUXOPT --no-pcr-on-video-pid --new-audio-pes --vbr --vbv-len=500
V_MPEGH/ISO/HEVC, "/var/folders/0m/gzs59vm10w7df83rj6zw70km0000gn/T/12_36_38_0010_01.265", fps=59.940, insertSEI, contSPS, ar=1:1 (Square)
-> Scheint als ob tsMuxeR irgendwei Probleme mit dem Stream hat, da tsMuxeR closed source ist und der Author seit Jahren nicht erreichbar ist kann ich da direkt nichts machen.
Was Du antesten kannst ist, was passiert, wenn Du tsMuxeR aus dem '/Applications/Hybrid.app/Contents/MacOS/'-Ordner entfernst. Hybrid sollte dann ffmpeg zum Multiplexen verwenden.

-----
Der Stream ist irgendwie kaputt, außer mit ffplay lässt er sich bei mir nicht ohne (größere) Probleme abspielen. (irgendwie wird da rechts noch ss
Yup da ist vor dem eigentlich Video noch irgendein Müll, wenn ich den Stream einfach remuxe, sieht man auch wie selbst ffplay sich beschwert.
-> sieht nach einem kaputten Input und nicht nach einem Fehler in Hybrid aus.
Handbrake kommt eventuell mit so nem Stream klar.

Cu Selur

Ps.: unter Windows 10 könntest Du testen ob sich etwas ändert wenn Du 'Config->Internals->Avisynth->Always use Avisynth' aktivierst.
Reply
#3
Super - Diese Infos hat wirklich geholfen.
Ich hatte schon vermutet ich sei zu 'blöd'. 
Das mit dem Entfernen von tsMuxeR muss ich noch ausprobieren.


Ein kleiner Dank folgt, hoffentlich reicht er für ein paar Kaffee, etc... Smile
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)