[HELP] Resize doesn't seem to be working
#11
What aspect ratio?
see: https://en.wikipedia.org/wiki/Pixel_aspect_ratio

If Vapoursynth is used during filter preview, make sure to set the zoom in the preview to 'no zoom' otherwise the preview will be adjusted to the window size.

Quote:what wrong do I do ?
You don't trust Hybrid enough and you are not aware that by default Hybrid will adjust the picture to the window size.
So if the PAR is same and the height is the same the window size doesn't have to change.

Cu Selur

Ps.: Also '640x480' doesn't make any sense unless your input is totally broken or you are also changing the PAR (= Pixel aspect ratio).
Reply
#12
hi,

I'll try to precise here some points :
- my cartoon size is 720x480, but it's a wrong size as a circle appears horizontally elongated, so I'd like to reduce only the width so the circle is round again ; so I have to try some tests, beginning with 640x480 (why not ? I have some cartoons with that size), using the preview to see what it looks like, changing if needed until it's a circle again.
- it's not that i don't trust Hybrid, but i don't KNOW this tool, what it does by default, etc.

So by "aspect ratio", I meant a "visual aspect" ratio (the circle not looking like a circle), not a technical one.

This told, if we take my example above, which steps should I do please ?

regards
Reply
#13
From what you describe there shouldn't be any need for resizing, but probably simply adjusting the PAR value.
-> if you can share a small sample of your source I can look at it.

Cu Selur
Reply
#14
hello,
on which web site can I put the video sample please ?
Reply
#15
Use for example google drive or any other site that isn't malware&co flooded.

Cu Selur
Reply
#16
i'll use wetransfer, i don't know/use google drive...

here is the link

regards
Reply
#17
Got the file, like I suspected the pixel aspect ration is simply wrong.

When reencoding, setting:
"Crop/Resize->Pixel Aspect Ratio (PAR)->Input PAR" to "8x9" you get what I would assume to be the right aspect ratio.
No resizing needed. (You can still crop and resize if you want, setting the PAR as mentioned above should keep the aspect ratio fine.)
When remuxing (Base->Processing->Video->passthrough), enabling 'Muxing->Overwrite->Pixel aspect ratio' to '8x9' should fix the issue.
(Attached a remuxed version where I just changed the PAR in the container.)

I also suspect the clip is telecined (can't say for sure from the intro).
Thus you probably might want to try:
  1. enable 'Filtering-(De-)Interlace/Telecine->Deinterlace/Telecine Settings->Overwrite input scan type to'
  2. setting 'Filtering-(De-)Interlace/Telecine->Deinterlace/Telecine Settings->Overwrite input scan type to' to 'telecine'

Cu Selur

Ps.: Old by probably a good start to get some understanding in artifacts&co: https://www.aquilinestudios.org/avsfilters/index.html


Attached Files
.zip   S1943E24 - remuxed.zip (Size: 3,67 MB / Downloads: 11)
Reply
#18
Hi,

1st, thank you vey much for all the time you spend ! Wink

Quote:When reencoding, setting:
"Crop/Resize->Pixel Aspect Ratio (PAR)->Input PAR" to "8x9" you get what I would assume to be the right aspect ratio.
No resizing needed. (You can still crop and resize if you want, setting the PAR as mentioned above should keep the aspect ratio fine.)
How did you know it's 8x9 ??? how can I guess that - without you ? Huh

Quote:When remuxing (Base->Processing->Video->passthrough), enabling 'Muxing->Overwrite->Pixel aspect ratio' to '8x9' should fix the issue.

I did Base->Processing->Video->passthrough, enabling 'Muxing->Overwrite->Pixel aspect ratio' to '8x9'.
I tried to base > preview to check what that will do to the clip (it's always my wish to see what it will be before starting the coding), but it doesn't seem to show the changes... Sad
Are you sure it's 8x9 ? because even the circle at the beginning of "remux.mkv" you sent isn't round... Huh

Quote:I also suspect the clip is telecined (can't say for sure from the intro).
Thus you probably might want to try:
  1. enable 'Filtering-(De-)Interlace/Telecine->Deinterlace/Telecine Settings->Overwrite input scan type to'
  2. setting 'Filtering-(De-)Interlace/Telecine->Deinterlace/Telecine Settings->Overwrite input scan type to' to 'telecine'

Cu Selur

Ps.: Old by probably a good start to get some understanding in artifacts&co: https://www.aquilinestudios.org/avsfilters/index.html

Thank you very much for your suggestion ! Indeed it is telecined & I wouldn't have guessed this parameter alone !

regards
Reply
#19
Base->Preview is to preview the source,.. use the Vapoursynth Preview under Filtering,..
Reply
#20
ok when I use a filter.
but when I don't, as it's the case with the PAR example as you told me previously (as there's no 'filtering' tab) ? It's not possible ?

BTW : I checked the result with PAR = 8x9 (and no encoding) : it's ok, the circle is round !!! Big Grin

so how did you know it was these digits to choose ? Huh

regards
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)