absturz beim Kodieren....
#1
Ich habe mehrfach immer wieder absturz beim kodieren von  m2TS video (direct von bluray) mit NVENC nur CUDA.
Es erscheint ein kleines fenster mit der nachricht,  "avcuvid: codec vc1(yuv420p) unable to decode by cuvid", wenn ich dann im fenster auf OK druecke, schliesst das programm, obwohl es weiterhin kodiert, die Graka ist voll am werken. Habe aktuellste version installiert. Gruss
Reply
#2
Quote:Ich habe mehrfach immer wieder absturz beim kodieren von m2TS video (direct von bluray) mit NVENC nur CUDA.
Was verstehst Du unter "NVENC nur CUDA." ?
Von der Fehlermeldung her würde ich sagen, dass es Probleme beim Decodieren des Quellmaterials gibt.
Da Du nichts zu Deinen genauen Einstellungen mitteilst und auch keinen Debug Output gepostet hast:
Keine Ahnung was da passiert.
Hybrid sollte sich eigentlich nicht komplett schließen,..

Cu Selur
Reply
#3
(18.08.2018, 21:04)Selur Wrote:
Quote:Ich habe mehrfach immer wieder absturz beim kodieren von  m2TS video (direct von bluray) mit NVENC nur CUDA.
Was verstehst Du unter "NVENC nur CUDA." ?
Von der Fehlermeldung her würde ich sagen, dass es Probleme beim Decodieren des Quellmaterials gibt.
Da Du nichts zu Deinen genauen Einstellungen mitteilst und auch keinen Debug Output gepostet hast:
Keine Ahnung was da passiert.
Hybrid sollte sich eigentlich nicht komplett schließen,..

Cu Selur

Wenn ich unter spalte NVENC/Filtering/Use only encoder/  auf CUDA stelle. Ich habe zwar ueber den Debug Output gelesen, finde aber nicht die Anleitung, und glaube das es nichts bringt, da das programm komplett schliesst, sobald ich auf den OK knopf der fehlermeldung druecke.
Wenn ich dann neu starte ist alles weg, keine log liste der jobs, nur meine Gespeicherte kodiereinstellung bleibt erhalten und die Paths usw.

Meine aktuelle kodier Einstellung ist folgende, hat aber glaube ich nichts mit dem fehler zu tun. Es erscheint mir das das ensprechende teil des programms, aus irgendeinen grund nicht korrekt  VC1 kodierung erkennt oder nicht dekodieren kann. Auch nicht wenn ich direkt als bluray eingabe mache, statt nur die m2ts datei, die den film enthaelt.

NVEnc --avhw cuda -i -INPUT- --fps 25.000 --codec h265 --profile main --level auto --sar 1:1 --lookahead 32 --vbrhq 15000 --max-bitrate 240000 --aq --gop-len 0 --bframes 0 --ref 5 --mv-precision Q-pel --cu-max 32 --cu-min 8 --preset quality --videoformat undef --colorprim bt709 --transfer bt709 --colormatrix bt470bg --vpp-resize default --output-res 1920x1080 --vpp-gauss disabled --output OUTPUTFILE

Beispiel der datei die nicht funktionert:
NVEnc --avhw cuda -i -INPUT- --fps 23.976 --codec h265 --profile main --level auto --sar 1:1 --lookahead 32 --vbrhq 15000 --max-bitrate 240000 --aq --gop-len 0 --bframes 0 --ref 5 --mv-precision Q-pel --cu-max 32 --cu-min 8 --preset quality --videoformat undef --colorprim bt709 --transfer bt709 --colormatrix bt709 --vpp-resize default --output-res 1920x1080 --vpp-gauss disabled --output "G:\Edicion Output TEMP\Eagle Eye [2008][HEVC][FHD-rip]_new.265"

Ausserdem erscheint unter BASE/ Stream selektion -- Source und video, ausgegraut. Als ob es nicht erkannt wird, obwohl die ID des videostreams erkannt wird in diesem fall. 4113.

Wie geht das mit dem Output debug?  .. link please

Gruss
Reply
#4
Quote:Wie geht das mit dem Output debug? .. link please
steht im sticky.

Quote:Wenn ich unter spalte NVENC/Filtering/Use only encoder/ auf CUDA stelle.
Okay, dann ist das Problem klar. Wenn Die Option aktiviert ist öffnet NVEncC direkt die Quelle und verwendet die Grafikkarte zu dekodieren.
"avcuvid: codec vc1(yuv420p) unable to decode by cuvid"
sagt dann, dass die Graifkkarte mit den aktuellen Treibern und diesen Einstellungen den Input nicht dekodieren kann. Smile

Cu Selur
Reply
#5
(19.08.2018, 15:52)Selur Wrote:
Quote:Wie geht das mit dem Output debug?  .. link please
steht im sticky.

Quote:Wenn ich unter spalte NVENC/Filtering/Use only encoder/  auf CUDA stelle.
Okay, dann ist das Problem klar. Wenn Die Option aktiviert ist öffnet NVEncC direkt die Quelle und verwendet die Grafikkarte zu dekodieren.
"avcuvid: codec vc1(yuv420p) unable to decode by cuvid"
sagt dann, dass die Graifkkarte mit den aktuellen Treibern und diesen Einstellungen den Input nicht dekodieren kann. Smile

Cu Selur

Was muss ich dann aendern, NICHT auf encoder only CUDA stellen, und auf standart lassen?? Gruss
Reply
#6
Quote:Was muss ich dann aendern, NICHT auf encoder only CUDA stellen, und auf standart lassen??
Du kannst:
a. die unterschiedlichen 'Decoder type' Einstellungen versuchen, ich vermute, dass 'software' gehen sollte. Dann wird die libav Bibliothek die in NVEncC reinkompiliert ist zum dekodieren verwendet.
b. 'Only use encoder' deaktivieren, dann wird Hybrid ffmpeg zum Dekodieren verwenden.

Cu Selur
Reply
#7
(19.08.2018, 16:06)Selur Wrote:
Quote:Was muss ich dann aendern, NICHT auf encoder only CUDA stellen, und auf standart lassen??
Du kannst:
a. die unterschiedlichen 'Decoder type' Einstellungen versuchen, ich vermute, dass 'software' gehen sollte. Dann wird die libav Bibliothek die in NVEncC reinkompiliert ist zum dekodieren verwendet.
b. 'Only use encoder' deaktivieren, dann wird Hybrid ffmpeg zum Dekodieren verwenden.

Cu Selur

(19.08.2018, 16:16)newbi14 Wrote:
(19.08.2018, 16:06)Selur Wrote:
Quote:Was muss ich dann aendern, NICHT auf encoder only CUDA stellen, und auf standart lassen??
Du kannst:
a. die unterschiedlichen 'Decoder type' Einstellungen versuchen, ich vermute, dass 'software' gehen sollte. Dann wird die libav Bibliothek die in NVEncC reinkompiliert ist zum dekodieren verwendet.
b. 'Only use encoder' deaktivieren, dann wird Hybrid ffmpeg zum Dekodieren verwenden.

Cu Selur

OK, habe probiert mit version B, und genauso, programm schliesst (GUI nur?) und Graka, bleibt auf full speed. Mal sehen unter software....

Edit:  OK unter nur encoder/Software funktioniert es, aber nur nocht mit 60fps, statt 130fps. Wieso? und kann ich da noch was aendern, das es flotter geht?  gruss
Reply
#8
Quote:OK unter nur encoder/Software funktioniert es, aber nur nocht mit 60fps, statt 130fps. Wieso? und kann ich da noch was aendern, das es flotter geht?
JNein, das Problem ist, dass NVEncC bzw. NVEnC bzw. deine Grafikkarte&Treiber das was Du ihr fütterst nicht dekodieren kann. Was einem nur bleibt ist anstatt Hardware-, Softwaredekoding zu verwenden, dass geht dann über die CPU.
Was man machen könnte damit es schneller geht, ist:
a. warten bis eine neue Grafikkarte kommt welche das Material dekodieren kann und diese nutzen
b. eine schnellere CPU verwenden

Quote:OK, habe probiert mit version B, und genauso, programm schliesst (GUI nur?) und Graka, bleibt auf full speed. Mal sehen unter software....
Erstell mal einen DebugOutput Level 9 vom Job Processing wenn du Variante B verwendest, vielleicht sieht man da was dazu führt das Hybrid crashed.

Falls Du ein kleines Sample mit dem man das Problem nachstellen kann mit mir Teilen könntest wäre das super.

Cu Selur
Reply
#9
(19.08.2018, 16:37)Selur Wrote:
Quote:OK unter nur encoder/Software funktioniert es, aber nur nocht mit 60fps, statt 130fps. Wieso? und kann ich da noch was aendern, das es flotter geht?
JNein, das Problem ist, dass NVEncC bzw. NVEnC bzw. deine Grafikkarte&Treiber das was Du ihr fütterst nicht dekodieren kann. Was einem nur bleibt ist anstatt Hardware-, Softwaredekoding zu verwenden, dass geht dann über die CPU.
Was man machen könnte damit es schneller geht, ist:
a. warten bis eine  neue Grafikkarte kommt welche das Material dekodieren kann und diese nutzen
b. eine schnellere CPU verwenden

Quote:OK, habe probiert mit version B, und genauso, programm schliesst (GUI nur?) und Graka, bleibt auf full speed. Mal sehen unter software....
Erstell mal einen DebugOutput Level 9 vom Job Processing wenn du Variante B verwendest, vielleicht sieht man da was dazu führt das Hybrid crashed.

Falls Du ein kleines Sample mit dem man das Problem nachstellen kann mit mir Teilen könntest wäre das super.

Cu Selur

Entschudige aber ich bin noch zu bloed, hab das tema mit Graka und CPU, verstanden, aber wie mache ich ein Output debug level9?? finde sticky nicht.....  Blush
Reply
#10
Sticky: [INFO] Angaben die nötig sind um Fehler zu beheben,...

Cu Selur
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)