[BUG] audio not synchronized after cutting videos
#1
Hi,

the version 2018.09.29.1 works fine to put chapters where I want.

But there's a little problem : the audio track is not synchronized anymore, it starts for each chapter after the video, and each time a little more late...
[Image: sad.png]

(I tried with 3 different video files containing different numbers of chapters)

regards
Reply
#2
Are you cutting on key frames?
Reply
#3
hi

huh... I cut where the chapters have been put (manually/visually by myslef) in the video file in a previous step (the one we discussed already together - hence the 2018.09.29.1 dev version)

or don't i understand what is your meaning ???

regards
Reply
#4
Did you reencode and was a .qp file created and used?
Read the sticky and provide proper info so I don't have to guess what you did.

Cu Selur
Reply
#5
Selur


What I would do is:
I. Create a new proper file in the target format I want
  1. set a default output folder
  2. load source
  3. adjust Input PAR
  4. do cropping and filter
  5. add chapter points and name them according to the episode (unless you mess with the qp file Hybrid will automatically create key frames on the chapter start points)
  6. configure audio&video to the formats I want 
  7. encode the file
II. Split the file and name the output files after the chapters.
  1. load output of previous file as source
  2. set audio&video processing to passthrough
  3. enable Config->Output->Filename Generation->Output Filename Generation->Use chapter names
  4. enable Base->Generate
  5. hit 'Queue Chapters' to let Hybrid create the jobs to split the source into the chapters and name the output files according to the chapter names
This way one has one encoding of the whole thing and one splitting of the reencoded file.

Cu Selur
******************************
Hi,

sorry, I tend to forget that you don't have only my problems to solve...

Above is what you told me here to do to add chapters in a long video & then cut it using the "queue chapters".
As an old ffmpeg version did have "problems" to put keframes anywhere i wanted to, you sent me a dev version last week-end via PM because ffmpeg had a new version which allowed now to do that.

I didn't have time to test that this week, & tried this evening.

so the 1st step seems ok, I chose :
- Base->processing->video : "NVEnc"
- NVEnc->Base - codec : "h265" - encoding mode : "constant quantizer" - quantizer->"split 20/23/25"
- Base->processing->audio : "passthrough all"
--> so I assume that now with this dev version I can put chapter points wherever I like - no ?

but when I apply the 2nd step & check the resulting videos, the audio is not synchronized anymore.

I don't see any .qp file anywhere (where should it be BTW ?)

regards
Reply
#6
Side note: If you would use the 'Insert a Quote'-button you wouldn't have to make stuff italic and they would be more readable.

Quote:I don't see any .qp file anywhere (where should it be BTW ?)
If everything worked as intended your job queue would contain an 'XX_create' 'generating qp file: ... .qp' -entry.

In case it doesn't the version you used is still broken in that regard.

Cu Selur
Reply
#7
(05.10.2018, 18:53)Selur Wrote: Side note: If you would use the 'Insert a Quote'-button you wouldn't have to make stuff italic and they would be more readable.

Quote:I don't see any .qp file anywhere (where should it be BTW ?)
If everything worked as intended your job queue would contain an 'XX_create' 'generating qp file: ... .qp' -entry.

In case it doesn't the version you used is still broken in that regard.

Cu Selur

Hi,

I know to do this in the same post - but not in different posts... Sad 

here is a link to picture of my job queue, after having hit 'queue chapters' (I deployed only the 1st job for the 1st chapter)
-> i still don't know where to look for the qp file Sad
I see a chp info : is that it ?

(BTW I don't get it because, from my point of view, the chapters have been created in the previous step...)

AH ! I just see that you sent me a new dev version -> will try it ASAP

regards
Reply
#8
The qp file should be part of the queue where you encoded the clip you are splitting.
In case it wasn't there then, key-frames are not on chapter beginnings and thus output will be async.
In case you didn't reencode the file you are splitting there you got the same problem,..
Reply
#9
hi

i'm still downloading your last dev version...

to be sure to do the right thing next time :
the qp file information should be visible in the 1st step ('encoding with chapters') or in the 2nd ?
just to be sure when I have to check for it

regards
Reply
#10
It needs to be part of the encoding of the file you later want to split, so 'encoding with chapters'.
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)