[BUG] audio not synchronized after cutting videos
#21
ok that's quite a relief !
there's definitely a problem with cutting according to chapters...

thank you for your time !
Reply
#22
or with NVEncC setting the key frames where its supposed to,...
Reply
#23
It's a problem related to NVEncC when using x265 as codec the whole process works fine as it should and the output is synch.
Think I know why from the looks of it the qp file is broken.
-> looking into it
(doesn't seem to happen always, seems like sometimes the chapter data send to NVEncC by Hybrid is only partially processed,..)

Cu Selur

Ps.: send you a dev version which should help with the problem,...
Reply
#24
hi,

Hybrid v2018.10.10.1
I'm sorry to say that it doesn't solve the problem   Sad 

I re-created a new encoded file with the chapters, and cut this file according the chapters in a 2nd step...
...and the audio in the 2nd chapter is already not sync anymore.

what can i do for you to help ?

regards
Reply
#25
Create two debug outputs, one for each step you make.
Reply
#26
Hi,

the "step 1 encoding" log is here
and the "step 2 splitting" log is there

regards

Hi,

the "key frames for chapters" was not set by default so I think i forgot it
--> I do it again
sorry

EDIT :
hoping i did all right, the 2 logs are here
(the audio is 10 sec late in the 2nd chapter)
regards
Reply
#27
Chapter file content looks fine:
CHAPTER01=00:00:00.000
CHAPTER01NAME=hare ribbin'
CHAPTER02=00:08:08.000
CHAPTER02NAME=the return of mr hook
CHAPTER03=00:12:00.000
CHAPTER03NAME=mr hook in the good egg
CHAPTER04=00:15:08.000
CHAPTER04NAME=mr hook in tokyo woes
CHAPTER05=00:19:20.000
CHAPTER05NAME=my dream is yours
keyfile content looks fine:
0
14625
21578
27212
34765
Video encoding call:
"C:\WEYBPR~2\Hybrid\64bit\ffmpeg.exe" -y -loglevel fatal -hwaccel auto -threads 1 -i "Y:\2 scrap\Jeunesse - 2 scrap\cartoons\looney tunes\H264-originaux\2_add_chapters_2_encode\720x480_ld5-8.PAR corrigé.mkv" -map 0:0 -an -sn -vf crop=694:476:26:0,scale=694:536,zscale=rangein=tv:range=tv -pix_fmt yuv420p -vsync 0  -sws_flags spline -f yuv4mpegpipe - | "C:\WEYBPR~2\Hybrid\64bit\NVEncC.exe" --y4m -i - --fps 29.970 --codec h265 --profile main --level auto --sar 1:1 --lookahead 16 --cqp 28 --gop-len 0 --bframes 0 --ref 3 --mv-precision Q-pel --cu-max 32 --cu-min 8 --preset default --videoformat undef --colorprim undef --transfer undef --colormatrix bt470bg --keyfile "C:\temp\720x480_ld5-8.PAR corrigé_hare ribbin'_NVEnc_cqp28_key_chapt_18_53_49_8610_02.qp" --output "C:\temp\720x480_ld5-8.PAR corrigé_hare ribbin'_NVEnc_cqp28_key_chapt_18_53_49_8610_03.265"
looks fine, btw. since you are not doing any filtering aside from resizing you can probably speed up the process by enabling "NVEnc->Filtering->Only use encoder" and set 'Decoder' to 'Cuda'.

-> Can you share the file you try to encode and cut with me? (I tested this here with a few files from me and had no problem,...)

Cu Selur
Reply
#28
Hi,

here is the video file (315MB)
here is the chapter file (it'll be easier for you Rolleyes ) with 5 chapters

choices :
- base->processing->video : NVEnc
- base->processing->audio : passthrough
- NVENc->base->codec : h265 ; encoding mode : constant quantizer ; quantizer : 28
- NVEnc->misc->key frames for chapters
- crop/resize->base->picture crop : 26 on the left + 4 at the bottom
- crop/resize->base->PAR->input PAR : 8x9
- crop/resize->base->PAR->convert output to PAR : square pixel

I hope i didn't forget anything...

The 1st step result seems ok, the audio is synchronized with the video (i checked the 5 chapters).

BTW : I think smtimes i'll enable 'overwrite input scan type to : telecine' --> can i still enable "NVEnc->Filtering->Only use encoder" and set 'Decoder' to 'Cuda' ?

regards
Reply
#29
Quote: I think smtimes i'll enable 'overwrite input scan type to : telecine' --> can i still enable "NVEnc->Filtering->Only use encoder" and set 'Decoder' to 'Cuda' ?
Never tried it, might work,...

Will try to reproduce your steps.

Cu Selur
Reply
#30
Is this the wrong file?
I need the source to properly reproduce the issue.
The file you linked to does have chapter markings at:
  • 00:00:00
  • 00:00:02
  • 00:00:05
  • 00:00:07
and is alread HEVC created by Hybrid. (There are no key frames at the chapter markings.)
The chapter file you liked to has chapters at:
  • 00:00:00.000
  • 00:08:08.000
  • 00:12:00.000
  • 00:15:08.000
  • 00:19:20.000
Since:
a. your steps include no adding chapters
b. the clip is only 13 seconds long
c. the clip only has key frames at frame 0 and 300
I'm a bit confused.

-> Properly explain this please.

Cu Selur
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)