NVEnc crasht
#1
Hi Selur,

Hybrid 2018.10.07.1  ... bei mir tritt exakt das gleiche Problem auf: https://forum.selur.net/showthread.php?tid=655

Es reicht aus Hybrid zu starten, "NVEnc" bei Processing auszuwählen, und dann einfach im TAB irgendwas an den Settings zu verändern: Beispiel Profil auf "Main 10" oder "Bit depth" auf 10-bit einstellen. Dann crasht es reproduzierbar:
 Problemereignisname:    APPCRASH
  Anwendungsname:    Hybrid.exe
  Anwendungsversion:    2018.10.7.0
  Anwendungszeitstempel:    5bb9ab16
  Fehlermodulname:    Qt5Core.dll
  Fehlermodulversion:    5.11.1.0
  Fehlermodulzeitstempel:    5b234a4c
  Ausnahmecode:    c0000005
  Ausnahmeoffset:    00000000000a586a
  Betriebsystemversion:    6.1.7601.2.1.0.256.1
  Gebietsschema-ID:    1031
  Zusatzinformation 1:    4505
  Zusatzinformation 2:    4505469cbb3b6cb597ff70ceac7b92e9
  Zusatzinformation 3:    3899
  Zusatzinformation 4:    38990f4fc8b3f8daf911dc1ab7bf01b1

Sys: Windows 7 64bit / GTX1070

Gruß ggrub
Reply
#2
Problem ist, ich kann das hier nicht nachstellen,.. Sad
Ich habe extra meine Einstellungen verworfen (reset defaults), aber wenn ich zu Hybrid danach neu starte, NVEnc als Encoder auswähle, crashed da nichts egal woran ich drehe. Sad

Hast Du irgendwas am Windows Theme oder so geändert?
Läuft irgendeine All-In-One Firewall&Co Lösung?

Cu Selur
Reply
#3
Nee, ich hab nix verändert. Die letzte Dev-Version die ich von Dir bekommen hatte, lief problemlos.

Hat es vielleicht was damit zu tun das Hybrid nicht mehr als Admin gestartet werden kann ? Kann man das eigentlich zum Testen mal deaktivieren ?
Reply
#4
Gibt zum Deaktivieren der Option extra einen neuen misc.ini-Eintrag, die Option macht aber nichts außer beim Startup einen Check durchzuführen.
Die kann es nicht sein. Wenn Hybrid startet ist der Check schon vorbei und alles spätere sieht ist nicht geändert.
Was mich wundert, ist dass ich an den Qt dlls schon ne ganze Weile nicht geändert habe.
Hast Du mal versucht ob sich was ändert wenn Du Deine Defaults zurücksetzt?
Am NVEncC frontend habe ich auch nur das 'key frame from chapters' hinzugefügt,..

Cu Selur
Reply
#5
Neuinstallation hat auch nicht geholfen.

Also hab ich mal gegengetestet. Hybrid 2018.10.07.1 deinstalliert, Hybrid_2018.08.05.1 installiert .... NVEnc (ffmpeg) crasht nicht mehr beim Ändern der Settings. Kann ich hier jederzeit reproduzieren. Irgendwas klemmt bei der Version 2018.10.07.1, was aber wohl nicht bei jedem auftritt. Keine Ahnung was der Grund ist ... Huh
Reply
#6
Ahhh,... "ffmpeg (NVEnc)" nicht nur NVEnc,.. -> den Crash kann ich nachstellen!! Big Grin

-> gucke drauf Smile
Reply
#7
Gefunden, ist ein Fehler der durch das Hinzufügen von Rav1e gekommen ist.
-> kompiliere gleich ne neue dev Version und schicke Dir nen Link per PM

Cu Selur
Reply
#8
Der Fehler ist weg, danke für den Fix.

Was für eine ffmpeg version verwendet Hybrid ?
Ist das v4 ? In bezug auf ffmpeg 4.0.2 (arch) fehlen da auch noch settings. Bei verschiedenen Settings würde mir "mein" ffmpeg "veraltet" anzeigen.
Kannst du auch bei ffmpeg-nvenc die "Addition" einbauen ?

Eine Fortschritts/Performance-Anzeige ist wohl nicht möglich ? Bei mir werden nur % angezeigt.
Reply
#9
Fortschrittsanzeige bei FFmpeg (NVEnc) kann ich mal draufgucken, sollte eigentlich möglich sein.
Baue die FFmpeg Version immer mit https://github.com/jb-alvarado/media-autobuild_suite was direkt die aktuellste Version verwendet unter Linux musst Du djcj mal anhauen, bzw. bei arch den entsprechenden Maintainer des Repositories.
Reply
#10
NVEnc (Rigaya): Die CUT-Funktion klappt nicht bei der Videospur (bei Audio ok). Die % Anzeige läuft deutlich über 100% hinauß.
NVEnc --avhw cuda  -i "G:\HDMI-cap\test.mkv" --fps 23.976 --codec h265 --profile main10 --level auto --sar 1:1 --lookahead 32 --output-depth 10 --vbrhq 14000 --max-bitrate 24000 --gop-len 24 --bframes 0 --ref 4 --mv-precision Q-pel --cu-max 32 --cu-min 8 --preset quality --videoformat undef --colorprim bt2020 --transfer smpte2084 --colormatrix bt2020nc --vpp-resize lanczos --output-res 2560x1440 --vpp-gauss disabled --aq --aq-strength 4 --keyfile "D:\_tmp\hybrid\test_new_12_14_40_8410_05.qp" --output "D:\_tmp\hybrid\test_new_12_14_40_8410_06.265"
Hier ist nirgends der CUT-Bereich aufgeführt. NVEnc scheint das auch selber nicht zu unterstützen. Da müßte wohl als Zwischenschritt ein ffmpeg-video-cut-demux ausgeführt werden, damit NVEnc dann die richtige Videolänge encodet. Oder liege ich da falsch ?
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)