NVEnc crasht
#11
Wenn Du nicht 'Only use encoder' aktivierst sollte es gehen.
Kann ich denke ich auch schreiben, dass es geht wenn 'Only use encoder' aktiviert ist, dann muss nur '--trim ...' verwendet werden.
(hab ich nur gar nicht drann gedacht als ich 'Only use encoder' geschrieben habe)

Cu Selur
Reply
#12
Bin bis Sonntag früh wieder außer Haus/unterwegs. Ich werden am Sonntag Nachmittag die Dev-Version testen.
Reply
#13
So, wieder daheim.

Bin gerade Hybrid_dev_2018.10.14.1 am testen ... sieht gut aus. Hab noch einen kleinen Bug gefunden.

Wählt man bei NVEnc (Rigaya) "h265" aus, kann der Spatial Filter nicht verwendet werden. Es ist nicht möglich die Stärke (Strength) einzugeben. Kann man natürlich bei "Addition" per Hand eintragen: --aq --aq-strength 4

Ansonsten erscheint nur "--aq":
NVEnc --y4m -i - --fps 23.976 --codec h265 --profile main10 --level auto --sar 1:1 --lookahead 32 --output-depth 10 --vbrhq 14000 --max-bitrate 240000 --aq --gop-len 24 --bframes 0 --ref 4 --mv-precision Q-pel --cu-max 32 --cu-min 8 --preset quality --videoformat undef --colorprim bt2020 --transfer smpte2084 --colormatrix bt2020nc --max-cll 1000,300 --keyfile ...

EDIT: Wenn 'Only use encoder' aktiviert ist mit "cut", crasht es. Logfile kommt noch, ich schau erst mal näher hin ob der Fehler bei mir liegt.

HybridDebugOutput.zip
Reply
#14
Wegen aq:
Was sagt denn 'NVEncC --check-features' und eventuell hilft ein leeren des Tool Caches, damit Hybrid 'check-features' auch neu aufruft.
Wegen dem cut kann ich nachher nochmal draufgucken, bin jetzt wieder @home und hab ne NVIDIA Karte. Wink

Cu Selur
Reply
#15
Die CUT-Funktion funktioniert nun. Auffällig ist nur die ca. 50-60s lange Wartepause zwischen "05_create 100%" und dem Beginn des Encodings. Ist das normal ?

Der Spatial Filter wird definitiv unterstützt. Manuell eingetragen "--aq --aq-strength 4" funktioniert es ja. "NVEncC --check-features" zeigt den weder bei h.264 noch bei h.265 unter Win 7 an. Sogar unter arch mit ffmpeg funktioniert spatial.
Vielleicht hat der gute Rigaya einfach vergessen diesen Filter bei "NVEncC --check-features" zu testen. Da du ja jetzt auch eine NVidiakarte hast, teste das doch mal bitte.

EDIT:
--aq-strength <int>          [H264] set aq strength (weak 1 - 15 strong)
                                default: 0 = auto
Mhhmm .... merkwürdig. Würde also bedeuten das "--aq --aq-strength 4" bei h.265, wenn manuell eingetragen, einfach ignoriert wird. Da würde ich eher einen Crash erwarten.
Reply
#16
Gerade bei mir gecheckt, da geht aq ohne Probleme, es sei denn man verwendet 'constant quantizer' da ist es natürlich deaktiviert, da man dann keine konstante Quantisierung hätte.

Quote:NVEnc --y4m -i - --fps 25.000 --codec h264 --profile high --level auto --sar 1:1 --lookahead 16 --vbrhq 1500 --max-bitrate 240000 --aq --aq-strength 6 --gop-len 0 --bframes 0 --ref 3 --mv-precision Q-pel --cabac --deblock --preset default --colormatrix bt470bg --keyfile GENERATED_KEY_FILE --output "E:\Temp\test.264"
und
Quote:NVEnc --y4m -i - --fps 25.000 --codec h265 --profile main --level auto --sar 1:1 --lookahead 16 --output-depth 8 --vbrhq 1500 --max-bitrate 240000 --aq --gop-len 0 --bframes 0 --ref 3 --mv-precision Q-pel --cu-max 32 --cu-min 8 --preset default --colormatrix bt470bg --keyfile GENERATED_KEY_FILE --output "E:\Temp\test.265"
werden von Hybrid richtig erzeugt und funktionieren hier auch,..

Nur bei H.264 kann man die aq strength setzen, da:
--aq-strength <int>          [H264] set aq strength (weak 1 - 15 strong)
                                  default: 0 = auto
das nur ein Feature für H.264 ist.

Bei deinem Aufruf ist ja das '--aq' auch da. -> wenn '--aq-strength' auch bei H.265 gehen sollte, melde dies bitte rigaya.

Cu Selur
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)