[HELP] BD : extract audio crashes

I'm with v2018.11.02.1, W7 64b

- loaded a ripped BD structure
- base->processing->video = NVEnc ; audio = passthrough all
- NVEnc->base->codec = h265 ; encoding mode = constant quantizer ; quantizer = 28
- config->input->disabled "ignore playlists with"
(the rest : by default)

i tried with other mpls files (bonuses), same result Sad

here is the level 4 log, tell me if you need a sample (the 4mn mpls file is 870MB big...).

thank you very much for your inquiry.

regardsPlease, read the 'Infos needed to fix&reproduce bugs,..'-sticky before you post about a problem.
What happens if you call:
C:\WEYBPR~2\Hybrid\64bit\ffmpeg.exe" -y -threads 8 -analyzeduration 200M -probesize 200M -i bluray:"Y:\2 scrap\HELIUM_D2" -playlist 73 -angle 0 -map 0:1 -vn -sn -acodec copy  -map_metadata -1 -metadata handler_name="Hybrid 2018.11.02.1" "C:\temp\iId_100_aid_4352_lang_en_22_20_18_3310_01.ac3"
inside a Windows Command Prompt?

My guess is that ffmpeg is throwing some error since it can't handle your source.
Might be that the selected playlist (73) is a dummy or broken.

Cu Selur

Ps.: current release is 2018.11.05.1 btw. so since 2018.11.05.1 contains a newer ffmpeg version this might already fix the problem,... (I doubt it, but it is worth a shot.)

i tried and got :
"syntax of filename, directory or volume incorrect" (equivalent of french message)

tried to see where the problem is :
- ffmpeg syntax : correct
does not exist (but i think it's the destination)

should i try other options (fe without -playlist) ?
where the playlist should be?

I have a "FAB!" directory besides "BDMV" (because it was ripped by DVDFab, I think) : could it disturb Hybrid ?

About the call:
"C:\WEYBPR~2\Hybrid\64bit\ffmpeg.exe" -y -threads 8 -analyzeduration 200M -probesize 200M -i bluray:"Y:\2 scrap\HELIUM_D2" -playlist 73 -angle 0 -map 0:1 -vn -sn -acodec copy  -map_metadata -1 -metadata handler_name="Hybrid 2018.11.02.1" "C:\temp\iId_100_aid_4352_lang_en_22_20_18_3310_01.ac3"
Here's what each part of the call does:
  • "C:\WEYBPR~2\Hybrid\64bit\ffmpeg.exe": is the path to ffmpeg
  • -y tells ffmpeg to overwrite the output in case it exists
  • -threads 8: sets the numbers of threads used
  • -analyzeduration 200M -probesize 200M sets how much of the input should be analysed to be sure of it's characteristics
  • -i bluray:"Y:\2 scrap\HELIUM_D2": lets ffmpeg know that the input is a blu-ray and where it's base folder is located at
  • -playlist 73: selects the playlist item (from the PLAYLIST-folder) you told Hybrid to use
  • -angle 0: sets that the stream associated to angle zero should be used
  • -map 0:1: selects which stream (the one with index 1) should be used from input with index 0.
  • -vn: disables video processing
  • -sn: disables subtitle processing
  • -acodec copy: passthrough the audio
  • -map_metadata -1: ignore/drop input meta data
  • -metadata handler_name="Hybrid 2018.11.02.1": if applicable tag the output with the Hybrid version
  • "C:\temp\iId_100_aid_4352_lang_en_22_20_18_3310_01.ac3": sets the output file name
see: https://www.ffmpeg.org/ffmpeg-all.html if you want to know more about ffmpegs command line switches

Quote:should i try other options (fe without -playlist) ?
where the playlist should be?
No clue why ffmpeg would report that the output doesn't exist. Are you sure you copied the command line call correctly?

Quote:I have a "FAB!" directory besides "BDMV" (because it was ripped by DVDFab, I think) : could it disturb Hybrid ?
Hybrid itself doesn't care about the 'FAB' folder and I doubt any of the tools Hybrid uses does.

Wild guess is that:
a. either you didn't copy and execute the call correctly, or
b. there is something wrong with your files or playlist (no clue how good DVDFab is,  might be that some streams were removed from the original, but some data wasn't properly adjusted to reflect those changes)

=> atm. it doesn't looks more like a 'broken' source than a bug in Hybrid or ffmpeg

You can try whether disabling: "Config->Internals->Extraction->Prefer ffmpeg for extraction from transport streams" helps, since this might convince Hybrid to use tsMuxeR instead of ffmpeg for the extraction and tsMuxeR is sometimes more forgiving in regard of Blu-ray structures.

Cu Selur

I copied/pasted the command line call in a prompt window, so i'm quite sure to have copied the command line call correctly

But i disabled "config->input->Extraction->Prefer ffmpeg for extraction from transport streams" and it worked !

Thank you !

Forum Jump:

Users browsing this thread: 1 Guest(s)