[HELP] Error adding subtitle with speed change
#11
Will look into it.
Reply
#12
Thanks again, tried today with a fresh install of the dev version and the job successfully finishes and an output file is created with no crash. Unfortunately the stretch doesn't appear to have applied as the subtitles move further out of sync the further you move through the video. 
I've attached a screengrab of the settings in the subtitle tab + latest debug log.
   


Attached Files
.7z   HybridDebugOutput.7z (Size: 44,17 KB / Downloads: 1)
Reply
#13
Settings seem to be fine.
When stretching idx/sub-subtile Hybrid only takes the idx files and copies it's content and adjusts the time codes, in your case by a factor of 25/23.976=1.0240.., saves a new subtitle file and copies the sub file.
Background info: the idx file contains the location of the subtitles inside the sub file and the time code when to show it, the sub file contains the subtitles.

Looking at the calls, Hybrid uses:
Audio extraction:
"C:\PROGRA~1\Hybrid\64bit\MKVEXT~1.EXE" tracks "D:\Uncompressed Rips\Scrubs\Season 4\Scrubs - S04E02 - My Office.mkv" 1:"D:\Compressed Rips\Temp\iId_1_aid_0_lang_en_12_32_27_6710_01.ac3"
Audio filtering and reencoding:
"C:\PROGRA~1\Hybrid\64bit\ffmpeg.exe" -y -threads 8 -loglevel fatal -i "D:\Compressed Rips\Temp\iId_1_aid_0_lang_en_12_32_27_6710_01.ac3" -ac 2 -ar 48000 -f sox | "C:\PROGRA~1\Hybrid\64bit\sox.exe" --multi-threaded  --temp "D:\Compressed Rips\Temp\12_32_27_671002" --buffer 524288 -S -t sox - -b 32 -t sox - speed 0.95904000 | "C:\PROGRA~1\Hybrid\64bit\ffmpeg.exe" -y -threads 8 -f sox -i - -b:a 192k -ac 2 -ar 48000 -channel_layout stereo "D:\Compressed Rips\Temp\iId_1_aid_0_lang_en_12_32_27_6710_02.ac3"

Video decoding and encoding call:
"C:\PROGRA~1\Hybrid\64bit\ffmpeg.exe" -y -loglevel fatal -threads 8 -i "D:\Uncompressed Rips\Scrubs\Season 4\Scrubs - S04E02 - My Office.mkv" -map 0:0 -an -sn   -vf zscale=rangein=tv:range=tv -pix_fmt yuv420p -vsync 0  -f rawvideo - | "C:\PROGRA~1\Hybrid\64bit\x264.exe" --crf 20.00 --profile high --level 4.1 --direct auto --sync-lookahead 21 --qcomp 0.5 --no-mbtree --partitions i4x4,p8x8,b8x8 --no-fast-pskip --subme 5 --trellis 0 --weightp 1 --aq-mode 0 --vbv-maxrate 62500 --vbv-bufsize 78125 --sar 16:15 --qpfile "D:\Compressed Rips\Temp\Scrubs - S04E02 - My Office_12_32_27_6710_07.qp" --non-deterministic --range tv --colormatrix bt470bg --demuxer raw --input-res 720x576 --input-csp i420 --input-range tv --input-depth 8 --fps 24000/1001 --output-depth 8 --output "D:\Compressed Rips\Temp\12_32_27_6710_08.264" -

I see that sox uses a factor of 0.95904000 (23.976/25) instead of 1.0240.. (25/23.976) that the subtitle stretching is using. So either one of them seems to be mixed up.

Is it only the subtitles or does the audio also go out-of-synch with the video?
If one of them is correct I can adjust the other to use the same stretch factor. Smile

Cu Selur
Reply
#14
(25.11.2018, 07:38)Selur Wrote: Settings seem to be fine.
When stretching idx/sub-subtile Hybrid only takes the idx files and copies it's content and adjusts the time codes, in your case by a factor of 25/23.976=1.0240.., saves a new subtitle file and copies the sub file.
Background info: the idx file contains the location of the subtitles inside the sub file and the time code when to show it, the sub file contains the subtitles.

Looking at the calls, Hybrid uses:
Audio extraction:
"C:\PROGRA~1\Hybrid\64bit\MKVEXT~1.EXE" tracks "D:\Uncompressed Rips\Scrubs\Season 4\Scrubs - S04E02 - My Office.mkv" 1:"D:\Compressed Rips\Temp\iId_1_aid_0_lang_en_12_32_27_6710_01.ac3"
Audio filtering and reencoding:
"C:\PROGRA~1\Hybrid\64bit\ffmpeg.exe" -y -threads 8 -loglevel fatal -i "D:\Compressed Rips\Temp\iId_1_aid_0_lang_en_12_32_27_6710_01.ac3" -ac 2 -ar 48000 -f sox | "C:\PROGRA~1\Hybrid\64bit\sox.exe" --multi-threaded  --temp "D:\Compressed Rips\Temp\12_32_27_671002" --buffer 524288 -S -t sox - -b 32 -t sox - speed 0.95904000 | "C:\PROGRA~1\Hybrid\64bit\ffmpeg.exe" -y -threads 8 -f sox -i - -b:a 192k -ac 2 -ar 48000 -channel_layout stereo "D:\Compressed Rips\Temp\iId_1_aid_0_lang_en_12_32_27_6710_02.ac3"

Video decoding and encoding call:
"C:\PROGRA~1\Hybrid\64bit\ffmpeg.exe" -y -loglevel fatal -threads 8 -i "D:\Uncompressed Rips\Scrubs\Season 4\Scrubs - S04E02 - My Office.mkv" -map 0:0 -an -sn   -vf zscale=rangein=tv:range=tv -pix_fmt yuv420p -vsync 0  -f rawvideo - | "C:\PROGRA~1\Hybrid\64bit\x264.exe" --crf 20.00 --profile high --level 4.1 --direct auto --sync-lookahead 21 --qcomp 0.5 --no-mbtree --partitions i4x4,p8x8,b8x8 --no-fast-pskip --subme 5 --trellis 0 --weightp 1 --aq-mode 0 --vbv-maxrate 62500 --vbv-bufsize 78125 --sar 16:15 --qpfile "D:\Compressed Rips\Temp\Scrubs - S04E02 - My Office_12_32_27_6710_07.qp" --non-deterministic --range tv --colormatrix bt470bg --demuxer raw --input-res 720x576 --input-csp i420 --input-range tv --input-depth 8 --fps 24000/1001 --output-depth 8 --output "D:\Compressed Rips\Temp\12_32_27_6710_08.264" -

I see that sox uses a factor of 0.95904000 (23.976/25) instead of 1.0240.. (25/23.976) that the subtitle stretching is using. So either one of them seems to be mixed up.

Is it only the subtitles or does the audio also go out-of-synch with the video?
If one of them is correct I can adjust the other to use the same stretch factor. Smile

Cu Selur

The audio is perfect, confirming it is only the subtitles that go out of sync.
Reply
#15
I'll make a version where the stretch of the subtitle is inverted and send it to you in a few minutes for testing. Smile
Reply
#16
(25.11.2018, 07:54)Selur Wrote: I'll make a version where the stretch of the subtitle is inverted and send it to you in a few minutes for testing. Smile

I was playing around with the inverted Dev version and tried a few really far out factors to see what would happen and i've noticed it doesn't actually seem to be making any difference to the subtitle timings...

eg running it at 25.00 to 2.3976 (deliberately moving decimal point) didn't actually change the subtitle timing.
   

this example was 25.00 to 35.00 with no change as well (done after debug was attached)
   

Debug is also attached


Attached Files
.7z   HybridDebugOutput.7z (Size: 50,8 KB / Downloads: 0)
Reply
#17
Just changing the value does not change the subtitle queue entry, you have to add a new entry. Wink
uploading a new version for testing atm. will send you a pm

Cu Selur
Reply
#18
(25.11.2018, 09:29)Selur Wrote: Just changing the value does not change the subtitle queue entry, you have to add a new entry. Wink
uploading a new version for testing atm. will send you a pm

Cu Selur

That one did the trick, everything syncing 100% now!.

Donation coming your way, great to get such quick and helpful responses  Cool
Reply
#19
Happy to help.
Thanks for the donation. Smile

Cu Selur
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)