Constant Bitrate in HEVC
#11
[quote]-muxrate[/quuote]
No clue where that comes from, did you mean '--vbv-maxrate' ? (That is under 'x265->Rate Control->Video Buffer Verifier (VBV)'.)

Cu Selur
Reply
#12
(18.10.2018, 16:11)Selur Wrote:
Quote:-muxrate[/quuote]
No clue where that comes from, did you mean '--vbv-maxrate' ? (That is under 'x265->Rate Control->Video Buffer Verifier (VBV)'.)

Cu Selur
I just found it
Config, Output, Container Settings then TS Bitrate stuffing. (illustration included)
Reply
#13
(18.10.2018, 16:28)Othni Wrote:
(18.10.2018, 16:11)Selur Wrote:
Quote:-muxrate[/quuote]
No clue where that comes from, did you mean '--vbv-maxrate' ? (That is under 'x265->Rate Control->Video Buffer Verifier (VBV)'.)

Cu Selur
I just found it
Config, Output, Container Settings then TS Bitrate stuffing. (illustration included)

Anyway, I found out that it does not work at all...... Confused 

Well, it says it is experimental.....hope it would work though. That is what I need.
Reply
#14
okay, problem is that:
a. tsMuxeR is closed source and it's author left years ago.
b. I don't know of an alternative muxer to add bitrate stuffing
so there's nothing I can do if using the --strict-cbr&Co options together with the muxing option doesn't help.

If someone knows other options to archive cbr (no clue why one would want it), I'm open for suggestions. Smile

Cu Selur
Reply
#15
Wink 
(18.10.2018, 16:28)Othni Wrote:
(18.10.2018, 16:11)Selur Wrote:
Quote:-muxrate[/quuote]
No clue where that comes from, did you mean '--vbv-maxrate' ? (That is under 'x265->Rate Control->Video Buffer Verifier (VBV)'.)

Cu Selur
I just found it
Config, Output, Container Settings then TS Bitrate stuffing. (illustration included)


Attached Files Thumbnail(s)
   
Reply
#16
(24.10.2018, 04:53)Selur Wrote: okay, problem is that:
a. tsMuxeR is closed source and it's author left years ago.
b. I don't know of an alternative muxer to add bitrate stuffing
so there's nothing I can do if using the --strict-cbr&Co options together with the muxing option doesn't help.

If someone  knows other options to archive cbr (no clue why one would want it), I'm open for suggestions. Smile

Cu Selur

ffmpeg provides the -muxrate options and it works fine.

If tsMuxeR does not work, maybe you can drop that and use the -muxrate option of ffmpeg better.
Reply
#17
Busy atm. but remind be at the weekend again and I can look into it.

Cu Selur
Reply
#18
Looked at the code, there is already code that if the output is .m2ts and ffmpeg is used for muxing Hybrid will set the muxrate.
FFmpeg will be used for muxing.
Atm. Hybrid only uses ffmpeg for tsMuxeR in case tsMuxeR can't be used. (so removing tsMuxeR from the Hybrid folder and clearing the tool cache would force Hybrid to do that)
-> I'll think about adding an additional option to Hybrid to enforce this behavior.

Cu Selur
Reply
#19
(18.11.2018, 09:33)Selur Wrote: Looked at the code, there is already code that if the output is .m2ts and ffmpeg is used for muxing  Hybrid will set the muxrate.
FFmpeg will be used for muxing.
Atm. Hybrid only uses ffmpeg for tsMuxeR in case tsMuxeR can't be used. (so removing tsMuxeR from the Hybrid folder and clearing the tool cache would force Hybrid to do that)
-> I'll think about adding an additional option to Hybrid to enforce this behavior.

Cu Selur

Thank you!

Will definitely try tomorrow and let you know.
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)