Crop View bringt komische Fenster ...
#1
Hallo,

vielleicht stehe ich da gerade etwas auf dem Schlauch ...
Wenn ich auf Crop View klicke, um einen Film manuell zu schneiden (schwarze Ränder), erscheinen diese Fenster:

[Image: hybrid-cropview-1podyc.png]

Darunter liegt dieses Fenster:

[Image: hybrid-cropview0yiuo.png]

Der schwarze Inhalt von letzterem Fenster bleibt so schwarz. Da mein Testvideo nur 5 Minuten lang ist und ich auch die Festplattenaktivität überwache (und keine Aktivität mehr stattfindet), passiert da wohl auch nichts mehr.

Ich kannte das eigentlich so, dass sich ein Fenster öffnet, in dem der Film dann losläuft und man ihn mittels Tastenkombinationen (z.B. p für Pause oder w für zuschneiden von oben) bearbeiten kann.

Mein System:
Windows 10, 1809, neue Installation
Hybrid 2018.11.11.1
CPU/GPU: Intel J5005

Es handelt sich um eine MKV-Datei, die ich auf einem anderen Rechner mit Windows 7 und einer älteren Version von Hybrid auch auf die o.g. Weise schneiden kann.
Also an der Datei liegt's nicht.

Erst hatte ich auf dem neuen PC unter C/Benutzer/User/Appdata/Roaming den Ordner hybrid vom alten PC übernommen.
Nach diesem Problem habe ich ihn alber umbenannt, so dass Hybrid einen neuen Ordner angelegt hat.
Dann habe ich unter Config eigentlich nichts geändert (außer mkv als default container und die Pfade für output und temp.

Meine Crop/Resize Einstellungen sind wie folgt:
[Image: hybrid-crop-settings-u0ipc.png]
[Image: hybrid-crop-settings-rbdlr.png]


Ich habe es aber unter "Crop Style" auch schon mit Avisynth probiert.

Der Auto-Crop funktioniert aber und auch das Encodieren klappt! Ich kann's halt nur nicht mehr überprüfen, was da per Auto-Crop geschnitten wurde ... oder verstehe ich das neue Fenster nur nicht? Huh

PS: Ein frohes Neues! Smile
Reply
#2
Komisch, dass das erste Fenster bei Dir zu sehen ist.
Eigentlich sollte das nur kurz auf-flackern und dann nicht mehr zu sehen sein.
(Bist Du in ner VM-Umgebung oder so? Oder hast Du irgendwas an den Themes in Windows geändert?)

Croppen sollte aber im 2ten Fenster über die 'Crop mode'-Zeile möglich sein.
In der Quelle scrollen kannst Du in dem Du:
  • in der Zeile über der Crop 'Crop mode'-Zeile:
    • bei der Skala den Indikator verschiebst, oder
    • vorne in der Zeile in der ersten SpinBox die Frameposition angibst
  • in dem Du die links/rechts Pfeiltasten auf der Tastatur verwendest

Du kannst auch wenn Du unter 'Filtering->Support' auf 'Avisynth' wechselst den alten Avisynth Crop-View nutzen, oder wenn du auf 'No XSynth' wechselst den Mplayer basierten Crop-View nutzen.

Cu Selur
Reply
#3
Ah ... Idea , danke für die Tipps!

Okay, was das (für mich) neue Tool zum Schneiden angeht, da war ich wohl schlicht überfordert! Ich wusste nicht, dass das da unten in der Bedienungsleiste so eine Art Zeitstrahl ist, innerhalb dessen man sich beliebig reinklicken kann und so eine möglichst geeignete Szene suchen kann.
Nachdem ich das Fenster dann auch mal auf Bildschirmgröße erweitert hatte und den Zoom auf 1x gestellt hatte ... und dann unter Crop Mode ein wenig rumgespielt hatte ... wurde alles klar!
Damit kann ich arbeiten! Smile

Und was das andere (erste) Fenster angeht: Das verhält sich jetzt komischerweise wie von Geisterhand plötzlich so, wie du schreibst! Poppt also nur ganz kurz auf und ist dann auch schon wieder verschwunden! Keine Ahnung, woran das jetzt liegt.

Ich hatte festgestellt, wenn ich Fenster 1 wegge-xt habe, dann verschwand auch automatisch Fenster 2. Das wäre aber auch kein Beinbruch gewesen, weil ich ja Fenster 1 dann halt auch hätte minimieren können.
Wenn ich Fenster 2 weg-xte, blieb Fenster 1 erhalten, ich wurde dann einmal noch irgendwie beim Wegklicken von Fenster 1 gefragt, ob ich irgendwelche Änderungen speichern möchte, was ich aber verneint habe, weil ich nicht wusste, was da gespeichert würde.
Möglicherweise verhält es sich seitdem korrekt?!

Na ja, Windows 10 verhält sich in einigen Bereich nicht nachvollziehbar, bzw. Programme reagieren unerwartet ... z.B. zeigt MakeMKV (bei mir) nicht mehr per Meldung an, dass der Beta-Key abgelaufen ist, sondern das Programm wird beim Kopieren immer langsamer und/oder hängt sich schließlich ganz auf, erzeugt dabei aber 100% Festplattenaktivität und/oder die externe Festplatte wird auch schon mal ab- und wieder angemeldet ...
Ich war gestern schon am Verzweifeln, weil ich nicht wusste, was los ist, hätte ja von kaputter Festplatte über kaputter SATA-/USB-Adapter, Kabel, Anschluss, Treiber ... alles mögliche sein können.
Drauf gekommen bin ich auch eher durch Zufall, weil mir in Windows 7 direkt mitgeteilt wurde, dass der key abgelaufen ist.
Da dachte ich, "probiers doch in Win10/MakeMKV auch mal mit einem neuen key" ...

In der virtuellen Maschine läuft Hybrid jedenfalls nicht. Ich hab allerdings Comodo laufen, und was Comodo nicht kennt, wird (aus Sicherheitsgründen) erst mal virtualisiert. Das sieht man dann aber daran, dass um das Programm so ein grüner Rahmen ist.
Bei Hybrid war/ist das nicht der Fall.
Das Windows-Theme habe ich schon leicht personalisiert (viele Möglichkeiten hat man da ja nicht), Hintergrund Volltonfarbe schwarz, und unter Farben - Windows-Farben habe ich ein grau ausgewählt. Das habe ich dann so als "mein Design" abgespeichert.
Reply
#4
Quote:Ich hatte festgestellt, wenn ich Fenster 1 wegge-xt habe, dann verschwand auch automatisch Fenster 2.
Das erste Fenster läuft normalerweise versteckt im Hintergrund, wenn man das schließt wird auch der Preview gekillt,... Smile

Irgendwas läuft bei deinem System auf jeden Fall nicht ganz normal. Smile
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)