MKV Cutter Question
#11
Argh, put the wrong dll into the package, will fix after work.

Cu Selur
Reply
#12
Did a few tests, packed the files I used and uploaded a new version.
So the file should be fine. (tested on Win10 64bit)

Cu Selur
Reply
#13
Thanks, just tested on 3 videos and I still get  -

avs [error]: Plugin G:\mkvCutterWithAudio3\ffms2.dll is not an AviSynth 2.6 or 2.5 plugin.
(V:\Movies_mkv\Copied to BU drive\temp\o-001.avs, line 1)
x264 [error]: could not open input file `V:\Movies_mkv\Copied to BU drive\temp\o-001.avs'

ExitCode: -1, ExitStatus: 0
 x264 encoding finished,..
Resetting since x264 crashed,..

I'm on Win7, is it possible the ffms2.dll is different for Win7 vs Win10?

When it hangs here, I cannot read the avs file because it is deleted already. Is there a way to prevent that or would that not help determine the problem?

Wait- just noticed that the ffms2.dll is identical in size and content to the previous one, please check.
Reply
#14
Ah, it isn't the ffms2 version it's that there was still a LoadPlugin instead of a LoadCPlugin call.
-> reuploaded MkvCutter_r20190122_untested

Cu Selur
Reply
#15
I'm still getting the same error. I don't know why.
Reply
#16
1. Aktiviere mal 'keep intermediate' und poste mal das komplette Log.
2. Was für eine CPU hast Du?

Wenn 'keep intermediate' an ist sieht man die Avisynth Skripte (.avs) welche verwendet werden, in diesen sollte immer LoadCPlugin verwendet werden, da die ffms2 version die ich verwende von https://forum.doom9.org/showthread.php?t=175173 ist und ein C Plugin ist. Du kannst ja mal die ffms2.dll durch die FFMS2 C-plugin r1315+119 Version ersetzen (Wichtig: 32bit Version muss verwendet werden.) und sehen ob das etwas ändert.

Cu Selur
Reply
#17
OK, I'm using i7-3770k cpu.
I tried FFMS2 C-plugin r1315 119 version but no difference.
How do I activate "keep intermediate". I remember seeing it somewhere but can't find it now.
Reply
#18
It's where you set the output and the temp folder.
Have you tried another file, just to be sure that this isn't a problem with the source?
Also since the preview works, the ffms2.dll should be fine. :/

Cu Selur
Reply
#19
OK, making progress -

In temp\moviename-001.avs, this is the plugin load in the script which hangs I think -


LoadPlugin("G:\Tony\mkvCutterWithAudio3\ffms2.dll")

Should the above be LoadCPlugin?

In the main folder this is the plugin load for moviename.avs -


LoadCPlugin("G:\Tony\mkvCutterWithAudio3\ffms2.dll")


Which seems to be ok I think.
Reply
#20
Yes, it should be -> made a version which uses LoadPlugin to avoid the general confusion.

Cu Selur
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)