[HELP] Encoding question
#1
Hello,

I'm having trouble encoding a source and was hoping for some direction. The issue is the audio starts in sync, goes noticeably out of sync by the middle of video, then comes back into sync again by the end, which I believe may be caused by the source being VFR and having issues with the timecodes. This happens in 1 or 2 episodes in every season of the TV show which I've personally ripped from dvd, and the rest of the episodes are perfectly fine.

I've enabled scan for 'stretched streams' and also tried 'prefer original framerate' but not had any luck.

This is the media info for one of the 'issue' episodes:

General
Unique ID                                : 217442236971553844626522833404061655284 (0xA395D9FE402682B175F491FB08D5A0F4)
Complete name                            : \\NAS20F5EC\USBDisk1\TV Shows\Archer\Season 3\Archer (2009) - S03E01 - Heart of Archness Part I.mkv
Format                                   : Matroska
Format version                           : Version 2
File size                                : 916 MiB
Duration                                 : 21 min 32 s
Overall bit rate mode                    : Variable
Overall bit rate                         : 5 948 kb/s
Encoded date                             : UTC 2018-12-15 05:30:39
Writing application                      : MakeMKV v1.14.2 win(x64-release)
Writing library                          : libmakemkv v1.14.2 (1.3.5/1.4.7) win(x64-release)

Video
ID                                       : 1
ID in the original source medium         : 224 (0xE0)
Format                                   : MPEG Video
Format version                           : Version 2
Format profile                           : Main@Main
Format settings                          : CustomMatrix / BVOP
Format settings, BVOP                    : Yes
Format settings, Matrix                  : Custom
Format settings, GOP                     : Variable
Codec ID                                 : V_MPEG2
Codec ID/Info                            : MPEG 1 or 2 Video
Duration                                 : 21 min 32 s
Bit rate mode                            : Variable
Bit rate                                 : 5 487 kb/s
Maximum bit rate                         : 9 800 kb/s
Width                                    : 720 pixels
Height                                   : 480 pixels
Display aspect ratio                     : 16:9
Frame rate mode                          : Variable
Frame rate                               : 24.000 FPS
Original frame rate                      : 23.976 (24000/1001) FPS
Color space                              : YUV
Chroma subsampling                       : 4:2:0
Bit depth                                : 8 bits
Scan type                                : Progressive
Scan order                               : 2:3 Pulldown
Compression mode                         : Lossy
Bits/(Pixel*Frame)                       : 0.662
Time code of first frame                 : 00:59:58;00
Time code source                         : Group of pictures header
Stream size                              : 845 MiB (92%)
Language                                 : English
Default                                  : No
Forced                                   : No
Original source medium                   : DVD-Video

I can share a cut of the source if it would help.
Reply
#2
Quote:This happens in 1 or 2 episodes in every season of the TV show which I've personally ripped from dvd
DVD is CFR, MakeMKV probably is doesn't something fishy.
I would try enabling "Config->Internals->Ignore all input timecodes".

Hybrid should ignore the input time codes when:
Original source medium                   : DVD-Video
is detected, can't say whether it does of if there is a bug somewhere.

Cu Selur
Reply
#3
(04.02.2019, 09:44)Selur Wrote:
Quote:This happens in 1 or 2 episodes in every season of the TV show which I've personally ripped from dvd
DVD is CFR, MakeMKV probably is doesn't something fishy.
I would try enabling "Config->Internals->Ignore all input timecodes".

Hybrid should ignore the input time codes when:
Original source medium                   : DVD-Video
is detected, can't say whether it does of if there is a bug somewhere.

Cu Selur

Hmmm I tried "Config->Internals->Ignore all input timecodes" and the audio still seems to go out of sync. It seems to go out of sync at about the 2:30 mark. Below is a link to a 6 min cut of the encoded video:

https://drive.google.com/open?id=1q2QgZA...TIWKoYY0q0
Reply
#4
Won't look at the encoded video since it wouldn't show me anything that I could help me to know whats happening.
Reply
#5
and also a link to a 6 min cut of original source:

https://drive.google.com/open?id=105ymHI...Idx3Osbg8H

I made it 6 mins as by then the sync issue is obvious in the encoded file
Reply
#6
Source doesn't seem to be telecine, even though it's signaled as:
Scan order                               : 2:3 Pulldown
Setting 'Filtering->(De-)Interlace/Telecine->Deinterlaced/Telecine Settings->Overwrite input scan type to' to 'progressive', and keeping the frame rate at 29.97 seems to keep the content sync @29.97.
Dropping the time codes causes async problem.
Using sRestore and no time codes doesn't help.
Using cfr output + sRestore and no time codes produces sync output @23.976.
-> Personally I would go for the last:
  • enabling 'Config->Input->Decoding->CFR output'
  • setting 'Filtering->(De-)Interlace/Telecine->Deinterlaced/Telecine Settings->Overwrite input scan type to' to 'progressive'
  • enabling 'Filtering->Vapoursynth->Other->Restore' and setting 'Filtering->Vapoursynth->Other->Restore->sRestrore->Frate' set to '23.976'

Cu Selur
Reply
#7
(04.02.2019, 11:57)Selur Wrote: Source doesn't seem to be telecine, even though it's signaled as:
Scan order                               : 2:3 Pulldown
Setting 'Filtering->(De-)Interlace/Telecine->Deinterlaced/Telecine Settings->Overwrite input scan type to' to 'progressive', and keeping the frame rate at 29.97 seems to keep the content sync @29.97.
Dropping the time codes causes async problem.
Using sRestore and no time codes doesn't help.
Using cfr output + sRestore and no time codes produces sync output @23.976.
-> Personally I would go for the last:
  • enabling 'Config->Input->Decoding->CFR output'
  • setting 'Filtering->(De-)Interlace/Telecine->Deinterlaced/Telecine Settings->Overwrite input scan type to' to 'progressive'
  • enabling 'Filtering->Vapoursynth->Other->Restore' and setting 'Filtering->Vapoursynth->Other->Restore->sRestrore->Frate' set to '23.976'

Cu Selur

That last one did the trick, appreciate the help! It's weird that it only happens on some episodes of a series
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)