[HELP] Avisynth not working
#1
I have Avisynth MT 2.6 and Avisynth+ x64 installed. As standalone, both work perfectly.

Hybrid has never worked (when trying to use Avisynth filters), filters throw errors, sometimes just crash Hybrid.

For example, load file, if I go to filtering tab, leave everything default (deinterlace auto), click the avsViewer button (little filter strip with stuff, 2nd from button of window in lower right)

Quote:Avisynth preview error: Not An Avisynth 2 C Plugin: C:\Program Files\Hybrid\avisynthPlugins\yadif.dll
click OK:
Quote:Avisynth preview error: (C:\Users\xx\AppData\Local\Temp\tempPreviewAvisynthFile06_53_36_256_tmp/avs, line 21)
click OK:
Quote:Avisynth preview error: Couldn't import: 2 C Plugin: C\Program Files\Hybrid\avisynthPlugins\yadif.dll
click OK:
Quote:Avisynth preview error: Avisynth error:

If I just ignore the previewing, try to add job and run it, step 3 is generating Avisynth file, step 4 is CRASH.

I'm using an old version, don't want to update it right now. It was broken in 2014, 2015 and again with my 2016.04.10.1 version. Unless Avisynth was specifically fixed since then, I don't necessarily want to update.

I'm not installing 32-bit Avisynth+, it makes some things quit working that were fine on Avisynth.

I've never used Vapoursynth, and my main reason for Avisynth at all (in Hybrid) is easy integrated QTGMC. If Vapoursynth doesn't conflict with Avisynth already installed on my system, and is an alternative for running QTGMC, I'll do it.

So what can be done to make QTGMC work in Hybrid? Confused
Reply
#2
Quote:I'm using an old version,..
and that is where my interest in it died

Quote:So what can be done to make QTGMC work in Hybrid?
With some mysterious version from X years ago: no clue.
Too much changed since then.

Try not to update from such an old version, deinstall it completely and install a current version.
If it still doesn't work, create a debug output level 9 (!read the sticky!).

Cu Selur

Ps.: As a side note: Hybrid does neither install any version of Avisynth or Vapoursynth system-wide.
Reply
#3
Alright, I'll finish my current project, and look at remove/install.

But I don't want to spend lots of time re-making my custom configs. Where are those saved? I want to back those up before the uninstall, place them back when the new version is installed.

This program is excellent, I use it often for x264 transcoding. It's just the Avisynth that never worked, and it'd be nice to not have to encode in several steps when I do need filters.
Reply
#4
Quote:But I don't want to spend lots of time re-making my custom configs. Where are those saved? I want to back those up before the uninstall, place them back when the new version is installed.
see: "Config->Path->Infos->Settings path"
Also be warned, old configs might break Hybrid, so if you load an old config, resave it with the new version. (and keep your fingers crossed)

Cu Selur
Reply
#5
I installed the current version just now.
I didn't uninstall the old version at C:\PF\Hybrid, but instead added it at C:\PF\Hybrid.2019.

It seems to be previewing fine.  Smile

I'll set up an encode a bit later, and hopefully it goes smoothly as well. After installing several versions for 3 years, I didn't think it was be as easy as just installing yet another version. Sometimes it's nice to be wrong. That was easy.

Yes, I knew Avisynth wasn't installed system-wide, just internally to Hybrid.

There's definitely been some changes, but nothing overly so. Main change I see is adding Vapoursynth.

Thanks for the info on presets. I'll try that.

I think my only question would be about the Vapoursynth KNLmeansCL. What would you say are the equivalent settings to the Medium setting for NLmeansCL in Handbrake? I'm guessing strength is the main aspect. (I dislike Handbrake, but had to use it some, and NLmeansCL was sometimes why.)
Reply
#6
Quote:I didn't uninstall the old version at C:\PF\Hybrid, but instead added it at C:\PF\Hybrid.2019.
If you use the same settings path (Config->Path->Infos->Settings path) one of the installs might break the other.

Quote:What would you say are the equivalent settings to the Medium setting for NLmeansCL in Handbrake?
No clue, since I don't use Handbrake, my guess is that the use the same or similar code than the Vapoursynth developers so if there is a way to see the options handbrake uses, matching them to Vapousynth should not be hard.

Cu Selur
Reply
#7
You're right, both use the same path.
How can I change the settings path? There was no option given at install, nor does one appear after install.

Looking in the settings folder, it seems no file has been updated since 2016, so does this mean that the new install did not add or overwrite any of the default settings? That can't seem correct, but just to confirm, you've tweaked those in post-2016 updates?

I don't use the defaults, but it would be nice to have the option. If nothing else, to compare my settings to your baseline.

Installation seems messy, so I may be forced to uninstall everything, reinstall only the latest.
Reply
#8
Quote:You're right, both use the same path.
How can I change the settings path? There was no option given at install, nor does one appear after install.
Create a misc.ini and add something along the lines of:
[General]
     settingPath="E:\SettingsPathHybrid1"
see: [INFO] *hidden* Hybrid options,...

Quote:Looking in the settings folder, it seems no file has been updated since 2016, so does this mean that the new install did not add or overwrite any of the default settings?
Yes, Hybrid does not overwrite the default values unless old default values get deleted/reset, since the files might be user modified.
As a side note: Looking at the changelog should mention a few times the mentioning that one should delete all settings&co, not doing so can cause problems.

Quote:That can't seem correct, but just to confirm, you've tweaked those in post-2016 updates?
Yes, some of the defaults settings and a lot of other things have changed since 2016.

Cu Selur
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)