[BUG] DVD source - crash
#1
Hi Selur,

Its me again, found you another bug Smile
The crash occurs when I select DVD as the source.
Debug log - now really - attached.
Cheers.
Reply
#2
Encoding call:
"C:\PROGRA~1\Hybrid\64bit\VAPOUR~1\vspipe.exe" "C:\Users\Laci\AppData\Local\Temp\encodingTempSynthSkript_16_07_02_4810.vpy" - --y4m | "C:\PROGRA~1\Hybrid\64bit\x264.exe" --preset veryfast --pass 1 --bitrate 1250 --profile high --level 4.1 --bframes 5 --rc-lookahead 40 --qpmax 51 --weightp 2 --aq-strength 0.6 --sar 8:9 --deblock 1:1 --non-deterministic --range tv --stats "C:\Users\Laci\AppData\Local\Temp\extras_16_07_02_4810_03.stats" --demuxer y4m  --fps 24000/1001 --output-depth 8 --output NUL -
looks fine, but aborts with:
y4m [error]: bad sequence header magic
Vapousynth script:
# Imports
import vapoursynth as vs
core = vs.get_core()
# Loading Plugins
core.std.LoadPlugin(path="C:/Program Files/Hybrid/64bit/vsfilters/SourceFilter/d2vSource/libd2vsource.dll")
# Loading J:\VIDEO_TS using D2VSource
clip = core.d2v.Source(input="C:/Users/Laci/AppData/Local/Temp/16_07_02_4810.d2v", rff=False)
# making sure input color matrix is set as 709
clip = core.resize.Point(clip, matrix_in_s="709",range_s="limited")
# making sure frame rate is set to 30000/1001
clip = core.std.AssumeFPS(clip, fpsnum=30000, fpsden=1001)
# Setting color range to TV (limited) range.
clip = core.std.SetFrameProp(clip=clip, prop="_ColorRange", intval=1)
clip = core.vivtc.VFM(clip=clip, order=0, mode=1)
clip = core.vivtc.VDecimate(clip=clip)
# ColorMatrix: adjusting color matrix from 470bg to 709
clip = core.resize.Bicubic(clip=clip, matrix_in_s="c", matrix_s="709", range_in=0, range=0)
# Output
clip.set_output()
looks fine too.
No clue why it's crashing for you.
Does the Vapoursynth preview work properly?

As a side note:
Seeing that the source was detected as bt709 and you applying ColorMatrix with values that convert from Rec.601 (470bg) to Rec.709 (709) seems wrong.

Cu Selur
Reply
#3
(16.02.2019, 18:25)Selur Wrote: Encoding call:
"C:\PROGRA~1\Hybrid\64bit\VAPOUR~1\vspipe.exe" "C:\Users\Laci\AppData\Local\Temp\encodingTempSynthSkript_16_07_02_4810.vpy" - --y4m | "C:\PROGRA~1\Hybrid\64bit\x264.exe" --preset veryfast --pass 1 --bitrate 1250 --profile high --level 4.1 --bframes 5 --rc-lookahead 40 --qpmax 51 --weightp 2 --aq-strength 0.6 --sar 8:9 --deblock 1:1 --non-deterministic --range tv --stats "C:\Users\Laci\AppData\Local\Temp\extras_16_07_02_4810_03.stats" --demuxer y4m  --fps 24000/1001 --output-depth 8 --output NUL -
looks fine, but aborts with:
y4m [error]: bad sequence header magic
Vapousynth script:
# Imports
import vapoursynth as vs
core = vs.get_core()
# Loading Plugins
core.std.LoadPlugin(path="C:/Program Files/Hybrid/64bit/vsfilters/SourceFilter/d2vSource/libd2vsource.dll")
# Loading J:\VIDEO_TS using D2VSource
clip = core.d2v.Source(input="C:/Users/Laci/AppData/Local/Temp/16_07_02_4810.d2v", rff=False)
# making sure input color matrix is set as 709
clip = core.resize.Point(clip, matrix_in_s="709",range_s="limited")
# making sure frame rate is set to 30000/1001
clip = core.std.AssumeFPS(clip, fpsnum=30000, fpsden=1001)
# Setting color range to TV (limited) range.
clip = core.std.SetFrameProp(clip=clip, prop="_ColorRange", intval=1)
clip = core.vivtc.VFM(clip=clip, order=0, mode=1)
clip = core.vivtc.VDecimate(clip=clip)
# ColorMatrix: adjusting color matrix from 470bg to 709
clip = core.resize.Bicubic(clip=clip, matrix_in_s="c", matrix_s="709", range_in=0, range=0)
# Output
clip.set_output()
looks fine too.
No clue why it's crashing for you.
Does the Vapoursynth preview work properly?

As a side note:
Seeing that the source was detected as bt709 and you applying ColorMatrix with values that convert from Rec.601 (470bg) to Rec.709 (709) seems wrong.

Cu Selur
im gonna go check and report back.
well as far as the color scheme is concerned, if i dont do this, i get different colors from the original, definitely more vivid. i can only guess the detection aint correct.
im using telecine DVD material for source.
Reply
#4
Quote:well as far as the color scheme is concerned, if i dont do this, i get different colors from the original, definitely more vivid. i can only guess the detection aint correct.
My guess would be that it is because you disabled signaling the colorMatrix, thus the decoder needs to guess, but it's your encode and your settings, it's just something that seems wrong to me. Smile

Cu Selur
Reply
#5
(16.02.2019, 18:53)Selur Wrote:
Quote:well as far as the color scheme is concerned, if i dont do this, i get different colors from the original, definitely more vivid. i can only guess the detection aint correct.
My guess would be that it is because you disabled signaling the colorMatrix, thus the decoder needs to guess, but it's your encode and your settings, it's just something that seems wrong to me. Smile

Cu Selur

i dont even know where to set that option :S
Reply
#6
Quote:i dont even know where to set that option :S
You must have disabled it since normally the calls Hybrid uses all include '--colormatrix ...', and your call doesn't.
Reply
#7
(16.02.2019, 23:53)Selur Wrote:
Quote:i dont even know where to set that option :S
You must have disabled it since normally the calls Hybrid uses all include '--colormatrix ...', and your call doesn't.

well, i didnt touch anything im 100% sure, just setting medium and animation, and maybe fiddle a little with max quantizer.
by the way ivtc deinterlacer copes with me setting the input to DVD, and only Vapoursynth fails.
again this is that weird telecine DVD set, from which i posted that file in my other thread.
Reply
#8
Fact is, by default 'x264->VUI->Video Usability Information->Color Matrix' is enabled (for years) which for this clip would add '--colormatrix bt709' since your command line doesn't contain this, the option must have been disabled by you.

Cu Selur
Reply
#9
(17.02.2019, 00:08)Selur Wrote: Fact is,  by default 'x264->VUI->Video Usability Information->Color Matrix' is enabled (for years) which for this clip would add '--colormatrix bt709' since your command line doesn't contain this, the option must have been disabled by you.

Cu Selur

nope, its enabled, just checked Smile
would have been strange cause i have never been to the VUI menu before.
Reply
#10
Then I got no clue why you command line doesn't contain any '--colormatrix' part.

Cu Selur
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)